glassfish
  1. glassfish
  2. GLASSFISH-19883

[508] ERROR : Update center image link dont have text

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 4.0_b78
    • Fix Version/s: 4.0_b84_RC1
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      508 Windows 7 / FireFox 19.0 , GF 4.0 b78

      Description

      After loading the admin console update center link ( Below Oracle GlassFish Server image ) dont have the link text.
      Got error in OGHAG link test.

        Activity

        Anissa Lam added a comment -

        When console is first loaded, the update count, even if there is any, may not shown up until after the first click on anything which triggers the header refresh.
        Before the first click, only the image is shown. I have added the 'alt' to the image to ensure that image will be read out.

        After the first click, if there is any update, there will be text next to the image if there is any updates available. At this point, both the 'alt' and tooltip will include both 'update tools' and the # of updates.

        fix is available, but can't check in as java.net seems down.

        Anissa Lam added a comment -

        Fix committed.

        Log Message:
        ------------
        GLASSFISH-19883. Fix 508 issue for update center image.

        Revisions:
        ----------
        60998

        Modified Paths:
        ---------------
        trunk/main/appserver/admingui/updatecenter/src/main/resources/updatesAvailable.inc

        RameshT added a comment - - edited

        The issue is still seen in build 83. No update image text is displayed.

        Also with this a regression occured.

        when you click the update image at first time it is working as expected.
        If you click at second time it throws error as :
        "An Error has occured
        Cannot find specified Config Resource. Config may have been deleted. "

        Hence reopening the issue.

        This is occurring in win8 - IE10 and win7-FF19.0.

        Anissa Lam added a comment -

        The config error you are seeing is due to GLASSFISH-20156.
        The fix for that bug goes in on 4/4 and didn't make it to build 83.
        So, please verify with the latest nightly build, or any build after 4/6.


          People

          • Assignee:
            Anissa Lam
            Reporter:
            RameshT
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: