glassfish
  1. glassfish
  2. GLASSFISH-19896

must close validator and validator factory at application undeploy

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0_b82_EE7MS7
    • Fix Version/s: 4.0_b86_RC2
    • Component/s: cdi
    • Labels:
      None

      Activity

      jjsnyder83 added a comment -

      Please remove the following commented code in WeldDeployer when this is implemented.

      // JJS: commented out next 2 lines as the new hibernate validator provides this via their
      // portable extensions.
      //ValidationServices validationServices = new ValidationServicesImpl();
      //deploymentImpl.getServices().add(ValidationServices.class, validationServices);

      jjsnyder83 added a comment -

      Look up the ValidatorFactory in java:comp and call close on it.

      jjsnyder83 added a comment -

      What is the impact on the customer of the bug?
      Causes memory leaks

      How likely is it that a customer will see the bug and how serious is the bug?
      Is it a regression? Does it meet other bug fix criteria (security, performance, etc.)?
      What CTS failures are caused by this bug?
      Causes memory leaks

      What is the cost/risk of fixing the bug?
      N/A

      How risky is the fix? How much work is the fix? Is the fix complicated?
      N/A

      Is there an impact on documentation or message strings?
      No

      Which tests should QA (re)run to verify the fix did not destabilize GlassFish?
      quicklook

      Which is the targeted build of 4.0 for this fix?
      4.0_b86_RC2

      If this an integration of a new version of a component from another project,
      what are the changes that are being brought in? This might be list of
      Jira issues from that project or a list of revision messages.
      N/A

      Tom Mueller added a comment -

      Approved for 4.0.

      jjsnyder83 added a comment -

      Committed revision 61624.


        People

        • Assignee:
          jjsnyder83
          Reporter:
          jjsnyder83
        • Votes:
          0 Vote for this issue
          Watchers:
          1 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved: