glassfish
  1. glassfish
  2. GLASSFISH-19899

After creating a JMS resource, it does not show when I use list-jmsdest, not in the JNDI

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Works as designed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: jms
    • Labels:
      None

      Description

      I created a new JMS Queue in the admin console of glassfish 4 b80. The GUI says the queue deployed and appears even after restart. However, when I run

      asadmin> list-jmsdest
      mq.sys.dmq
      Command list-jmsdest executed successfully

      And not my queue. In addition, when I try to refer it in the JNDI it does not appear.

        Activity

        David Zhao added a comment -

        This is desired.

        The physical destination name is the destination name in the Message Queue broker, which is referred by the adminstration object created by create-jms-resource. If the destination does not exist, it will be created automatically when needed. So the physical destination will be created automatically when it is being used by sending/receiving messages to/from it for the first time if it doesn't exit. Looking up the administration object from JNDI doesn't trigger the creation of physical destination. However, it is good practice to create the physical destination beforehand. For production purposes, please always create physical destinations. The command create-jmsdest can be used for that. Once the physical destination is created by the first message sending/receiving or by create-jmsdest, you can see it by list-jmsdest.

        John D. Ament added a comment -

        Not sure if you read the entire issue. The fact that I cannot look up via the JNDI name doesn't seem to be "as desired." I would expect that I can look up destinations after creating them in JNDI.

        David Zhao added a comment -

        So you are talking about you cannot look up the jms topic/queue from JNDI after you have created them via create-jms-resource? Can you give more details about it? For example, what glassfish release are you using? what is the OS platform? What are the commands that you used to create JMS resources. The source code of your JMS client. Do you get any exceptions?

        BTW, the discussion forum http://www.java.net/forums/glassfish/glassfish or the mailing list users@glassfish.java.net could be more efficient for the usage questions.

        John D. Ament added a comment -

        Well I just tried posting a question on the glassfish forums. Seems like I broke them.

        Hello,

        I am trying to make a JMS destination in GlassFish 4.

        In the admin console, I create a new Destination Resource, with the following entries:

        JNDI Name: SomeQueue
        Physical Destination Name: SomeQueue
        Resource Type: javax.jms.Queue
        Deployment Order: 100

        Nothing else set.

        I then create a JAX-RS Stateless EJB. Here's the body:

        @Stateless
        @Path("/foo")
        public class FooResource {

        @Resource(name = "SomeQueue")
        private Queue someQueue;

        @Produces("text/plain")
        @GET
        public String getQueue() {
        if (this.someQueue != null)

        { return "injected queue " + this.someQueue.getClass().getCanonicalName(); }

        else

        { return "queue not injected."; }

        }
        }

        I then deploy this app to my server. When I attempt to access this resource in my browser, I get the following error (in the logs);

        javax.ejb.EJBException: javax.ejb.EJBException: javax.ejb.CreateException: Could not create stateless EJB
        at com.sun.ejb.containers.StatelessSessionContainer._getContext(StatelessSessionContainer.java:435)
        at com.sun.ejb.containers.BaseContainer.getContext(BaseContainer.java:2534)
        at com.sun.ejb.containers.BaseContainer.preInvoke(BaseContainer.java:1924)
        at com.sun.ejb.containers.EJBLocalObjectInvocationHandler.invoke(EJBLocalObjectInvocationHandler.java:210)
        at com.sun.ejb.containers.EJBLocalObjectInvocationHandlerDelegate.invoke(EJBLocalObjectInvocationHandlerDelegate.java:88)
        at $Proxy312.getQueue(Unknown Source)
        at com.tad.foo._EJB31_GeneratedFooResourceIntf__Bean_.getQueue(Unknown Source)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:601)
        at org.glassfish.jersey.server.model.internal.ResourceMethodInvocationHandlerFactory$1.invoke(ResourceMethodInvocationHandlerFactory.java:81)
        at org.glassfish.jersey.server.model.internal.AbstractJavaResourceMethodDispatcher.invoke(AbstractJavaResourceMethodDispatcher.java:125)
        at org.glassfish.jersey.server.model.internal.JavaResourceMethodDispatcherProvider$TypeOutInvoker.doDispatch(JavaResourceMethodDispatcherProvider.java:195)
        at org.glassfish.jersey.server.model.internal.AbstractJavaResourceMethodDispatcher.dispatch(AbstractJavaResourceMethodDispatcher.java:91)
        at org.glassfish.jersey.server.model.ResourceMethodInvoker.invoke(ResourceMethodInvoker.java:350)
        at org.glassfish.jersey.server.model.ResourceMethodInvoker.apply(ResourceMethodInvoker.java:345)
        at org.glassfish.jersey.server.model.ResourceMethodInvoker.apply(ResourceMethodInvoker.java:102)
        at org.glassfish.jersey.server.ServerRuntime$1.run(ServerRuntime.java:214)
        at org.glassfish.jersey.internal.Errors$1.call(Errors.java:207)
        at org.glassfish.jersey.internal.Errors$1.call(Errors.java:203)
        at org.glassfish.jersey.internal.Errors.process(Errors.java:251)
        at org.glassfish.jersey.internal.Errors.process(Errors.java:233)
        at org.glassfish.jersey.internal.Errors.process(Errors.java:203)
        at org.glassfish.jersey.process.internal.RequestScope.runInScope(RequestScope.java:317)
        at org.glassfish.jersey.server.ServerRuntime.process(ServerRuntime.java:190)
        at org.glassfish.jersey.server.ApplicationHandler.handle(ApplicationHandler.java:865)
        at org.glassfish.jersey.servlet.WebComponent.service(WebComponent.java:329)
        at org.glassfish.jersey.servlet.ServletContainer.service(ServletContainer.java:372)
        at org.glassfish.jersey.servlet.ServletContainer.service(ServletContainer.java:335)
        at org.glassfish.jersey.servlet.ServletContainer.service(ServletContainer.java:218)
        at org.apache.catalina.core.StandardWrapper.service(StandardWrapper.java:1682)
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:318)
        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:160)
        at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:734)
        at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:673)
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:175)
        at org.apache.catalina.connector.CoyoteAdapter.doService(CoyoteAdapter.java:357)
        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:260)
        at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:188)
        at org.glassfish.grizzly.http.server.HttpHandler.runService(HttpHandler.java:191)
        at org.glassfish.grizzly.http.server.HttpHandler.doHandle(HttpHandler.java:168)
        at org.glassfish.grizzly.http.server.HttpServerFilter.handleRead(HttpServerFilter.java:189)
        at org.glassfish.grizzly.filterchain.ExecutorResolver$9.execute(ExecutorResolver.java:119)
        at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeFilter(DefaultFilterChain.java:288)
        at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeChainPart(DefaultFilterChain.java:206)
        at org.glassfish.grizzly.filterchain.DefaultFilterChain.execute(DefaultFilterChain.java:136)
        at org.glassfish.grizzly.filterchain.DefaultFilterChain.process(DefaultFilterChain.java:114)
        at org.glassfish.grizzly.ProcessorExecutor.execute(ProcessorExecutor.java:77)
        at org.glassfish.grizzly.nio.transport.TCPNIOTransport.fireIOEvent(TCPNIOTransport.java:838)
        at org.glassfish.grizzly.strategies.AbstractIOStrategy.fireIOEvent(AbstractIOStrategy.java:113)
        at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.run0(WorkerThreadIOStrategy.java:115)
        at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.access$100(WorkerThreadIOStrategy.java:55)
        at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy$WorkerThreadRunnable.run(WorkerThreadIOStrategy.java:135)
        at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:564)
        at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.run(AbstractThreadPool.java:544)
        at java.lang.Thread.run(Thread.java:722)
        Caused by: javax.ejb.EJBException: javax.ejb.CreateException: Could not create stateless EJB
        at com.sun.ejb.containers.StatelessSessionContainer$SessionContextFactory.create(StatelessSessionContainer.java:700)
        at com.sun.ejb.containers.util.pool.NonBlockingPool.getObject(NonBlockingPool.java:246)
        at com.sun.ejb.containers.StatelessSessionContainer._getContext(StatelessSessionContainer.java:430)
        ... 56 more
        Caused by: javax.ejb.CreateException: Could not create stateless EJB
        at com.sun.ejb.containers.StatelessSessionContainer.createStatelessEJB(StatelessSessionContainer.java:514)
        at com.sun.ejb.containers.StatelessSessionContainer.access$000(StatelessSessionContainer.java:97)
        at com.sun.ejb.containers.StatelessSessionContainer$SessionContextFactory.create(StatelessSessionContainer.java:698)
        ... 58 more
        Caused by: com.sun.enterprise.container.common.spi.util.InjectionException: Exception attempting to inject Unresolved Message-Destination-Ref SomeQueue@java.lang.String@null into class com.tad.foo.FooResource: Lookup failed for 'java:comp/env/SomeQueue' in SerialContext[myEnv=

        {java.naming.factory.initial=com.sun.enterprise.naming.impl.SerialInitContextFactory, java.naming.factory.state=com.sun.corba.ee.impl.presentation.rmi.JNDIStateFactoryImpl, java.naming.factory.url.pkgs=com.sun.enterprise.naming}
        at com.sun.enterprise.container.common.impl.util.InjectionManagerImpl._inject(InjectionManagerImpl.java:717)
        at com.sun.enterprise.container.common.impl.util.InjectionManagerImpl.inject(InjectionManagerImpl.java:484)
        at com.sun.enterprise.container.common.impl.util.InjectionManagerImpl.injectInstance(InjectionManagerImpl.java:170)
        at com.sun.ejb.containers.BaseContainer.injectEjbInstance(BaseContainer.java:1718)
        at com.sun.ejb.containers.StatelessSessionContainer.createStatelessEJB(StatelessSessionContainer.java:475)
        ... 60 more
        Caused by: javax.naming.NamingException: Lookup failed for 'java:comp/env/SomeQueue' in SerialContext[myEnv={java.naming.factory.initial=com.sun.enterprise.naming.impl.SerialInitContextFactory, java.naming.factory.state=com.sun.corba.ee.impl.presentation.rmi.JNDIStateFactoryImpl, java.naming.factory.url.pkgs=com.sun.enterprise.naming}

        [Root exception is javax.naming.CommunicationException: Communication exception for SerialContext[myEnv=

        {java.naming.factory.initial=com.sun.enterprise.naming.impl.SerialInitContextFactory, java.naming.factory.state=com.sun.corba.ee.impl.presentation.rmi.JNDIStateFactoryImpl, java.naming.factory.url.pkgs=com.sun.enterprise.naming, com.sun.enterprise.naming.logicalName=java:comp/env/SomeQueue}

        [Root exception is java.lang.NullPointerException]]
        at com.sun.enterprise.naming.impl.SerialContext.lookup(SerialContext.java:491)
        at com.sun.enterprise.naming.impl.SerialContext.lookup(SerialContext.java:438)
        at javax.naming.InitialContext.lookup(InitialContext.java:411)
        at com.sun.enterprise.container.common.impl.util.InjectionManagerImpl._inject(InjectionManagerImpl.java:613)
        ... 64 more
        Caused by: javax.naming.CommunicationException: Communication exception for SerialContext[myEnv=

        {java.naming.factory.initial=com.sun.enterprise.naming.impl.SerialInitContextFactory, java.naming.factory.state=com.sun.corba.ee.impl.presentation.rmi.JNDIStateFactoryImpl, java.naming.factory.url.pkgs=com.sun.enterprise.naming, com.sun.enterprise.naming.logicalName=java:comp/env/SomeQueue}

        [Root exception is java.lang.NullPointerException]
        at com.sun.enterprise.naming.impl.SerialContext.lookup(SerialContext.java:513)
        at com.sun.enterprise.naming.impl.SerialContext.lookup(SerialContext.java:438)
        at javax.naming.InitialContext.lookup(InitialContext.java:411)
        at com.sun.enterprise.naming.util.JndiNamingObjectFactory.create(JndiNamingObjectFactory.java:82)
        at com.sun.enterprise.naming.impl.GlassfishNamingManagerImpl.lookup(GlassfishNamingManagerImpl.java:745)
        at com.sun.enterprise.naming.impl.GlassfishNamingManagerImpl.lookup(GlassfishNamingManagerImpl.java:715)
        at com.sun.enterprise.naming.impl.JavaURLContext.lookup(JavaURLContext.java:161)
        at com.sun.enterprise.naming.impl.SerialContext.lookup(SerialContext.java:471)
        ... 67 more
        Caused by: java.lang.NullPointerException
        at com.sun.enterprise.naming.impl.SerialContext.lookup(SerialContext.java:460)
        ... 74 more
        ]]

        Any ideas?


          People

          • Assignee:
            David Zhao
            Reporter:
            John D. Ament
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: