glassfish
  1. glassfish
  2. GLASSFISH-19915

[508] Contents of the successful save details are not read out by Jaws Screen reader.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0_b78
    • Fix Version/s: 4.0_b83
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      OS : Windows 7
      Browser : FF 19.0
      Build : GF 4.0 build 78
      JAWS version 14.0

      Description

      The message show up at the time of saving the context services in the console are not being read by the JAWS screen reader tool. The tool only announces that it is clicked save button. But the information in the message of success / failures is not being read out.
      Steps:
      --Start adminconsole in firefox server.
      --Edit a Managed executor service and save it.
      --A caution message is displayed in the screen after successfully saving the page.
      "New Values successfully saved."
      --JAWS screen reader does not reads out the message.

      This issue exists for all concurrency services. (context services, managed thread factories, managed executor services and managed scheduled executor services. )

        Activity

        Anissa Lam added a comment -

        This "New Values successfully saved." message is 'generically' implemented for all edit screen. If you go to other screen, eg Web Container screen, and click SAVE
        this message will be displayed also. Do you hear JAWS reading it out ?

        I want to see if this issue is specific to the Concurrent Resource screen. We have this for all other edit screen, and have been like this for many release.
        If it is an issue, I would have heard about that before, but i don't remember.

        RameshT added a comment -

        I didnot tested this with other screen. When I tested the concurrency services I came to know this issue. I have checked the same with other screens now, It seems they are also behaving like this. Success / Failures should be announced to the customer / listener. If this is not expected requirement we can close this bug.

        Anissa Lam added a comment -

        When looking at the html source, the image itself has the "alt" text of 'Success', 'Warning' etc, and the text "New values successfully saved" is just text on screen.
        I don't understand why the JAWS reader doesn't read that out. I don't see this being reported before either.

        Anyway, I changed the image 'alt' text to be the same as the text itself. So, it should read it out now.
        I have the fix, but can't commit due to java.net error.

        Anissa Lam added a comment -

        I have just committed the change. The fix should be in 4/1 nightly build.
        Marking as resolved.

        Log Message:
        ------------
        GLASSFISH-19915. specify 'alt' of <sun:alert> to be the alert summary and alert details, this overwrites the image default text which is 'Success', or 'Alert' etc.

        Revisions:
        ----------
        61060

        Modified Paths:
        ---------------
        trunk/main/appserver/admingui/common/src/main/resources/shared/alertMsg.inc
        trunk/main/appserver/admingui/common/src/main/resources/shared/alertMsg_1.inc

        RameshT added a comment -

        Now after the save when I select the message "new values successfully saved" is reading well. But I dont know once the save button is done it has to be readout. In that case it has to be popup message instead of text message in the screen itself. This needs to be confirmed by the design spec people.

        Anissa Lam added a comment -

        It is not designed to have popup message. Otherwise, user will need to confirm with another click which is very cumbersome.


          People

          • Assignee:
            Anissa Lam
            Reporter:
            RameshT
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: