glassfish
  1. glassfish
  2. GLASSFISH-19982

[regression] GlassFish 4-b80-ml.zip generates bundle warnings flooding the server.log

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 4.0_b80_EE7MS6
    • Fix Version/s: 4.0_b81
    • Component/s: build_system
    • Labels:
      None
    • Environment:

      Welcome to GlassFish Server Open Source Edition 4.0 (build 80)
      JDK 1.7_u15
      Win 7-64bit

      Description

      Starting GF I get a bunch of warnings for every module all following this example:

      [2013-03-21T07:22:48.062+0100] [glassfish 4.0] [WARNING] [] [org.jvnet.hk2.osgiadapter] [tid: _ThreadID=119 _ThreadName=admin-listener(6)] [timeMillis: 1363846968062] [levelValue: 900] [[
      Exception org.osgi.framework.BundleException: Could not create bundle object. while adding location = file:/D:/glassfish4-b80-ml/glassfish/modules/appclient-server-core-l10n.jar]]

      This is flooding the logfile :<

        Activity

        TangYong added a comment -

        In windows xp, the issue does not happen. as for win 7 64 bit, I will validate it from my home env.

        myfear added a comment -

        I could provide a complete logfile ... drop me a line myfear at web dot de

        Sanjeeb Sahoo added a comment - - edited

        While using 4.0-b80-ml.zip on Linux, I do see exceptions like:

        [#|2013-03-21T01:01:09.317-0700|WARNING|glassfish 4.0|org.jvnet.hk2.osgiadapter|_ThreadID=78;_ThreadName=Thread-12;_TimeMillis=1363852869317;_LevelValue=900;|
        Exception org.osgi.framework.BundleException: Could not create bundle object. while adding location = file:/scratch/sanjsaho/software/gf-4.0-b80-ml/glassfish4/glassfish/modules/console-corba-plugin-l10n.jar|#]

        But, I also notice exceptions at the start of the server like this:

        Launching GlassFish on Felix platform
        Mar 21, 2013 1:00:59 AM com.sun.enterprise.glassfish.bootstrap.osgi.BundleProvisioner createBundleProvisioner
        INFO: Create bundle provisioner class = class com.sun.enterprise.glassfish.bootstrap.osgi.BundleProvisioner.
        Mar 21, 2013 1:00:59 AM com.sun.enterprise.glassfish.bootstrap.LogFacade log
        WARNING: Failed to install file:/scratch/sanjsaho/software/gf-4.0-b80-ml/glassfish4/glassfish/modules/console-jms-plugin-l10n.jar.
        org.osgi.framework.BundleException: Could not create bundle object.
        at org.apache.felix.framework.Felix.installBundle(Felix.java:2940)
        at org.apache.felix.framework.BundleContextImpl.installBundle(BundleContextImpl.java:165)
        at com.sun.enterprise.glassfish.bootstrap.osgi.BundleProvisioner.install(BundleProvisioner.java:445)
        at com.sun.enterprise.glassfish.bootstrap.osgi.BundleProvisioner.installBundles(BundleProvisioner.java:205)
        at com.sun.enterprise.glassfish.bootstrap.osgi.OSGiGlassFishRuntimeBuilder.build(OSGiGlassFishRuntimeBuilder.java:142)
        at org.glassfish.embeddable.GlassFishRuntime._bootstrap(GlassFishRuntime.java:157)
        at org.glassfish.embeddable.GlassFishRuntime.bootstrap(GlassFishRuntime.java:110)
        at com.sun.enterprise.glassfish.bootstrap.GlassFishMain$Launcher.launch(GlassFishMain.java:112)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:601)
        at com.sun.enterprise.glassfish.bootstrap.GlassFishMain.main(GlassFishMain.java:97)
        at com.sun.enterprise.glassfish.bootstrap.ASMain.main(ASMain.java:54)
        Caused by: java.lang.IllegalArgumentException: invalid version "$

        Unknown macro: {project.osgi.version}

        ": non-numeric "${project"
        at org.osgi.framework.Version.parseInt(Version.java:170)
        at org.osgi.framework.Version.<init>(Version.java:126)
        at org.apache.felix.framework.util.VersionRange.parse(VersionRange.java:98)
        at org.apache.felix.framework.util.manifestparser.ManifestParser.parseFragmentHost(ManifestParser.java:1335)
        at org.apache.felix.framework.util.manifestparser.ManifestParser.<init>(ManifestParser.java:146)
        at org.apache.felix.framework.BundleRevisionImpl.<init>(BundleRevisionImpl.java:118)
        at org.apache.felix.framework.BundleImpl.createRevision(BundleImpl.java:1199)
        at org.apache.felix.framework.BundleImpl.<init>(BundleImpl.java:96)
        at org.apache.felix.framework.Felix.installBundle(Felix.java:2887)
        ... 13 more
        Caused by: java.lang.NumberFormatException: For input string: "${project"
        at java.lang.NumberFormatException.forInputString(NumberFormatException.java:65)
        at java.lang.Integer.parseInt(Integer.java:481)
        at java.lang.Integer.parseInt(Integer.java:527)
        at org.osgi.framework.Version.parseInt(Version.java:168)
        ... 21 more

        To see them, you need to start with -v option:

        asadmin start-domain -v

        This exception is happening because of bad manifest:

        [MANIFEST console-jms-plugin-l10n.jar]
        Archiver-Version Plexus Archiver
        Bnd-LastModified 1363208767995
        Build-Jdk 1.7.0_09
        Built-By java_re
        Bundle-Description Java.net - The Source for Java Technology Collaboration
        Bundle-ManifestVersion 2
        Bundle-Name Admin Console JMS Plugin l10n
        Bundle-SymbolicName org.glassfish.main.admingui.console-jms-plugin-l10n
        Bundle-Version 4.0.0.b80
        Created-By Apache Maven Bundle Plugin
        Fragment-Host org.glassfish.main.admingui.console-jms-plugin; bundle-version=${project.osgi.version}
        Manifest-Version 1.0
        Tool Bnd-1.15.0

        The good thing is I don't see such exceptions in b81. In b81, the manifest has been fixed. I don't know how we ended up promoting b80 with such a blocking bug, but that's a question for our release engineering team. I am assigning it to them. They should close it as RESOLVED with an explanation for the svn revision that fixed the issue. They should also fix promotion process to avoid such issues in future.

        Romain Grécourt added a comment -

        You don't know ? The answer is easy though.

        I fixed this last sunday, b81 includes the fix.

        Sanjeeb Sahoo added a comment -

        I don't deny the answer was perhaps easy to find by looking at all check in logs. I didn't put that effort. I am still looking for an answer as to how how we promoted this zip? Don't we run any tests again ml builds?

        Romain Grécourt added a comment -

        My comment was exactly about this question.
        Note that those are warinings, even if we tested the ml bundles, the tests would have passed.

        Romain Grécourt added a comment -

        There is no test that uses l10n bundles AFAIK.

        Sanjeeb Sahoo added a comment -

        Thanks for clarifying, Romain. You are absolutely right, they are warnings. I missed that part. Server does come up fine. It's just that the l10n does not work. So, that does reduce the severity of the issue to major from blocking. I assume our l10n QA would have caught that issue in due course of time.


          People

          • Assignee:
            Joe Di Pol
            Reporter:
            myfear
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: