glassfish
  1. glassfish
  2. GLASSFISH-19991

Create-domain command failed to create any domain when providing "--portbase" option

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 4.0_b80_EE7MS6
    • Fix Version/s: 4.0
    • Labels:
      None
    • Environment:

      Windows 7 SP1
      Glassfish v4 b80

      Description

      While creating new domain from command line interface asadmin using the following command

      create-domain --portbase 7000 domain2

      the interface failed to create the domain as the following (tested with different range of numbers but with the same error) when using ---portbase option:

      asadmin> create-domain --portbase 7000 domain2
      Enter admin user name [Enter to accept default "admin" / no password]>
      Using port 7048 for Admin.
      Using port 7080 for HTTP Instance.
      Using port 7076 for JMS.
      Using port 7037 for IIOP.
      Using port 7081 for HTTP_SSL.
      Using port 7038 for IIOP_SSL.
      Using port 7039 for IIOP_MUTUALAUTH.
      Using port 7086 for JMX_ADMIN.
      Using port 7066 for OSGI_SHELL.
      Using port 7009 for JAVA_DEBUGGER.
      Distinguished Name of the self-signed X.509 Server Certificate is:
      [CN=EF-BS-0003.EFinance.com.eg,OU=GlassFish,O=Oracle Corporation,L=Santa Clara,ST=California,C=US]
      Distinguished Name of the self-signed X.509 Server Certificate is:
      [CN=EF-BS-0003.EFinance.com.eg-instance,OU=GlassFish,O=Oracle Corporation,L=Santa Clara,ST=California,C=US]
      null( java.lang.NumberFormatException: null )
      CLI130: Could not create domain, domain2

      -----------------------------------------------------

      While running the same command without this option succeed as the following:

      asadmin> create-domain domain2

      asadmin> create-domain domain2
      Enter admin user name [Enter to accept default "admin" / no password]>
      Default port 4848 for Admin is in use. Using 8359
      Default port 8080 for HTTP Instance is in use. Using 8360
      Default port 7676 for JMS is in use. Using 8361
      Default port 3700 for IIOP is in use. Using 8362
      Default port 8181 for HTTP_SSL is in use. Using 8363
      Using default port 3820 for IIOP_SSL.
      Using default port 3920 for IIOP_MUTUALAUTH.
      Default port 8686 for JMX_ADMIN is in use. Using 8364
      Using default port 6666 for OSGI_SHELL.
      Using default port 9009 for JAVA_DEBUGGER.
      Distinguished Name of the self-signed X.509 Server Certificate is:
      [CN=EF-BS-0003.EFinance.com.eg,OU=GlassFish,O=Oracle Corporation,L=Santa Clara,ST=California,C=US]
      Distinguished Name of the self-signed X.509 Server Certificate is:
      [CN=EF-BS-0003.EFinance.com.eg-instance,OU=GlassFish,O=Oracle Corporation,L=Santa Clara,ST=California,C=US]
      Domain domain2 created.
      Domain domain2 admin port is 8,359.
      Domain domain2 allows admin login as user "admin" with no password.
      Command create-domain executed successfully.

        Activity

        Tom Mueller added a comment -

        This is a duplicate of GLASSFISH-19926


          People

          • Assignee:
            Tom Mueller
            Reporter:
            Mohamed Taman
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: