Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: 4.0_b81
    • Fix Version/s: 4.0_b82_EE7MS7
    • Component/s: rest-interface
    • Labels:
      None

      Description

      If i use curl to do 'restart-domain'
      curl -Ss -X POST -H 'X-Requested-By: foo' -H "Accept: application/json" http://localhost:4848/management/domain/restart-domain
      It is working fine.

      When i do this through the admin console, using the same endpoint, the server will be stopped, but over 90% chance that it won't start up again. There is only 2 times that i see it restarts.

      To reproduce this:

      • launch console
      • go to server-config- Loggers Settings -> Logger Setting page. Change something and then Save
      • notice the restart is required link at the upper left corner
      • click on the link to get to the restart page
      • click Restart button and you can see that domain will be stopped, usually it won't start again.

        Activity

        Hide
        Jason Lee added a comment -

        This functionality has worked every time I tried (7+ tries).

        Show
        Jason Lee added a comment - This functionality has worked every time I tried (7+ tries).
        Hide
        Jason Lee added a comment -

        These steps appear to work as expected against trunk. Please reopen if the issue recurs.

        Show
        Jason Lee added a comment - These steps appear to work as expected against trunk. Please reopen if the issue recurs.
        Hide
        Anissa Lam added a comment -

        https://bug.oraclecorp.com/pls/bug/webbug_print.show?c_rptno=16735276 is filed about cannot restart domain. Maybe my steps above doesn't reproduce the problem everytime.
        I tried the steps in bug# 16735276 on my Mac using FF and Chrome, cannot restart domain for all the 3 times i tried.
        I not sure if its REST issue or backend, its under Tom Mueller right now.

        Show
        Anissa Lam added a comment - https://bug.oraclecorp.com/pls/bug/webbug_print.show?c_rptno=16735276 is filed about cannot restart domain. Maybe my steps above doesn't reproduce the problem everytime. I tried the steps in bug# 16735276 on my Mac using FF and Chrome, cannot restart domain for all the 3 times i tried. I not sure if its REST issue or backend, its under Tom Mueller right now.

          People

          • Assignee:
            Jason Lee
            Reporter:
            Anissa Lam
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: