glassfish
  1. glassfish
  2. GLASSFISH-20007

Can't update glassfish modules using update tool.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.0_b85
    • Component/s: l10n
    • Labels:
      None
    • Environment:

      Windows 7 SP1
      Glassfish v4 b80

      Description

      while opening the admin console --> update center --> update tool and selecting available updates then process to update, after a while I got the following error alongside other modules but the same error:

      Launching GlassFish on Felix platform
      Mar 23, 2013 2:12:15 AM com.sun.enterprise.glassfish.bootstrap.osgi.BundleProvisioner createBundleProvisioner
      INFO: Create bundle provisioner class = class com.sun.enterprise.glassfish.bootstrap.osgi.BundleProvisioner.
      Mar 23, 2013 2:12:16 AM com.sun.enterprise.glassfish.bootstrap.LogFacade log
      WARNING: Failed to install file:/E:/Utilities/Glassfish_v4/glassfish/modules/appclient-server-core-l10n.jar.
      org.osgi.framework.BundleException: Could not create bundle object.
      	at org.apache.felix.framework.Felix.installBundle(Felix.java:2940)
      	at org.apache.felix.framework.BundleContextImpl.installBundle(BundleContextImpl.java:165)
      	at com.sun.enterprise.glassfish.bootstrap.osgi.BundleProvisioner.install(BundleProvisioner.java:445)
      	at com.sun.enterprise.glassfish.bootstrap.osgi.BundleProvisioner.installBundles(BundleProvisioner.java:205)
      	at com.sun.enterprise.glassfish.bootstrap.osgi.OSGiGlassFishRuntimeBuilder.build(OSGiGlassFishRuntimeBuilder.java:142)
      	at org.glassfish.embeddable.GlassFishRuntime._bootstrap(GlassFishRuntime.java:157)
      	at org.glassfish.embeddable.GlassFishRuntime.bootstrap(GlassFishRuntime.java:110)
      	at com.sun.enterprise.glassfish.bootstrap.GlassFishMain$Launcher.launch(GlassFishMain.java:112)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:601)
      	at com.sun.enterprise.glassfish.bootstrap.GlassFishMain.main(GlassFishMain.java:97)
      	at com.sun.enterprise.glassfish.bootstrap.ASMain.main(ASMain.java:54)
      Caused by: java.lang.IllegalArgumentException: invalid version "${project.osgi.version}": non-numeric "${project"
      	at org.osgi.framework.Version.parseInt(Version.java:170)
      	at org.osgi.framework.Version.<init>(Version.java:126)
      	at org.apache.felix.framework.util.VersionRange.parse(VersionRange.java:98)
      	at org.apache.felix.framework.util.manifestparser.ManifestParser.parseFragmentHost(ManifestParser.java:1335)
      	at org.apache.felix.framework.util.manifestparser.ManifestParser.<init>(ManifestParser.java:146)
      	at org.apache.felix.framework.BundleRevisionImpl.<init>(BundleRevisionImpl.java:118)
      	at org.apache.felix.framework.BundleImpl.createRevision(BundleImpl.java:1199)
      	at org.apache.felix.framework.BundleImpl.<init>(BundleImpl.java:96)
      	at org.apache.felix.framework.Felix.installBundle(Felix.java:2887)
      	... 13 more
      Caused by: java.lang.NumberFormatException: For input string: "${project"
      	at java.lang.NumberFormatException.forInputString(NumberFormatException.java:65)
      	at java.lang.Integer.parseInt(Integer.java:481)
      	at java.lang.Integer.parseInt(Integer.java:527)
      	at org.osgi.framework.Version.parseInt(Version.java:168)
      	... 21 more
      

        Activity

        kumara added a comment -

        This seems like an error in creating appclient-server-core-l10n.jar – the version property in manifest is not numeric.

        michael.y.chen added a comment -

        Claire thinks this is already fixed. Need to verify the fix.

        clyang added a comment -

        Issues should be resolved in b83 and later builds.

        clyang added a comment -

        should be resolved in b83 and later builds.

        clyang added a comment -

        Hi Sunny,
        I believe this has been fixed.
        Do you mind verifying it in the next build?
        Thanks, Claire

        sunny-gui added a comment -

        Could not reproduce this issue. Update Tool Bootstrap is not configured during install GF and no available update in the Admin Console.
        will attach screen shots for your reference.

        sunny-gui added a comment -

        Due to limited privilege, can not attach screen shot.

        clyang added a comment -

        Issue not reproducible in b86.
        Close the bug.


          People

          • Assignee:
            clyang
            Reporter:
            Mohamed Taman
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: