glassfish
  1. glassfish
  2. GLASSFISH-20019

Uninstaller stuck on 0% without any progress around 45 min.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 4.0_b80_EE7MS6
    • Fix Version/s: 4.0_b85
    • Component/s: installation
    • Labels:
      None
    • Environment:

      Windows 7 SP1
      Glassfish v4 b80

      Description

      running uninstall.exe failed to uninstall the products and stuck on 0% without any progress around 45 min.

        Activity

        Snjezana Sevo-Zenzerovic added a comment -

        Mohammad, was this the same uninstall run as described in issue GLASSFISH-20019? If so, I believe that the failure is due to the fact that you used JDK 6 and not JDK 7 for installer runtime. Even in that case this is a valid issue since uninstaller should handle that situation more gracefully, but please confirm that you are able to proceed with uninstallation if you provide explicit path to JDK 7 installation.

        Mohamed Taman added a comment - - edited

        Snjezana,

        I ran the uninstaller with JDK 7 and it works fine and uninstall the Glassfish successfully, but leaving some folders as the following:

        C:\glassfish4>tree
        Folder PATH listing for volume System
        Volume serial number is DAAD-A878
        C:.
        ├───glassfish
        │   └───lib
        │       └───registration
        ├───install
        │   ├───bin
        │   ├───lib
        │   │   ├───external
        │   │   │   ├───apache
        │   │   │   ├───beanshell
        │   │   │   ├───charva
        │   │   │   ├───chaxml
        │   │   │   ├───freemarker
        │   │   │   ├───jaxb
        │   │   │   ├───jdom
        │   │   │   └───swixml
        │   │   ├───platforms
        │   │   ├───providers
        │   │   ├───resources
        │   │   │   ├───dependency
        │   │   │   ├───model
        │   │   │   ├───org
        │   │   │   │   └───openinstaller
        │   │   │   │       └───resources
        │   │   │   ├───templates
        │   │   │   └───view
        │   │   └───sims
        │   └───metadata
        │       ├───dependency
        │       ├───model
        │       ├───templates
        │       └───view
        └───var
            └───install
                ├───config
                │   └───Domain
                └───pkgdb
                    ├───sims-product
                    └───uninstall
        
        Snjezana Sevo-Zenzerovic added a comment -

        Thanks for confirmation, Mohamed. I'll look into those leftovers - most of the files that are listed belong to openInstaller framework and are actually required to run uninstaller. I believe we had a hook in native executable which would kick in and remove these files after we are done using them so I'll try to find out if there is an issue with that.

        Snjezana Sevo-Zenzerovic added a comment -

        Given that we can't easily update uninstall native wrapper to enforce JDK 7 usage or provide message to that effect, it is hard to fix the root cause at this point.

        However, given that Windows installer/uninstaller are in fact able to run using JDK 6 runtime provided that we also compile our custom install configuration extensions with 1.6 target, it would IMO make sense to reconfigure maven compiler plugin in installer module and enable this. This would mitigate some of the issues with Windows JDK detection and improve usability. Such installer would still independently enforce the use of JDK 7 for GlassFish runtime.

        • What is the impact on the customer of the bug?

        While this is not a regression, there is significant usability impact with newer Windows versions and increased 64 bit JDK usage. So, it may be worthwhile to be able to run installer with any JDK that is automatically detected by the wrapper.

        • What is the cost/risk of fixing the bug?

        Low/moderate risk. We tested and run an almost identical installer code base in 3.1.x release using JDK 6.

        • Is there an impact on documentation or message strings?

        Possible limited impact on installation guide (need to document the ability to run installer/uninstaller using JDK 6 or higher on Windows platform).

        • Which tests should QA (re)run to verify the fix did not destabilize GlassFish?

        Regular installer testing plus several installer runs using explicitly provided path to JDK 6 installation.

        • Which is the targeted build of 4.0 for this fix?

        b85

        • If this an integration of a new version of a component from another project,
          what are the changes that are being brought in? This might be list of
          Jira issues from that project or a list of revision messages.

        N/A

        Tom Mueller added a comment -

        Approved for 4.0


          People

          • Assignee:
            Snjezana Sevo-Zenzerovic
            Reporter:
            Mohamed Taman
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: