glassfish
  1. glassfish
  2. GLASSFISH-20090

asadmin report wrong message when providing invalid command.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0_b82_EE7MS7
    • Fix Version/s: 4.0
    • Component/s: command_line_interface
    • Labels:
      None
    • Environment:

      Windows 7 SP1
      Glassfish v4 b82

      Description

      Go to this scenarios:

      1. On command line type asadmin.
      2. At asadmin prompt type start-domian
      3. you will got the following:
      asadmin> start-domian
      Not Found
      Closest matching local and remote command(s):
          start-domain
      
      Command start-domian executed successfully.
      
      asadmin> start-do
      Not Found
      Closest matching local and remote command(s):
          restart-domain
          start-domain
      
      Command start-do executed successfully.
      

      The message Command start-domian executed successfully. is an invalid message to show, and it should be something like "Command start-domian is an invalid command."

        Issue Links

          Activity

          Tom Mueller added a comment -

          This is a regression from 3.1. In 3.1.2, the output is as follows for an invalid command:

          $ ~/test/gf-3.1.2/glassfish3/bin/asadmin asdfljk
          Command asdfljk not found.
          Check the entry of command name. This command may be provided by a package that is not installed.
          Command asdfljk failed.

          For something a bit closer to a real command, the output is:

          $ ~/test/gf-3.1.2/glassfish3/bin/asadmin sop-domain
          Command sop-domain not found.
          Check the entry of command name. This command may be provided by a package that is not installed.
          Closest matching local and remote command(s):
          stop-domain

          Command sop-domain failed.

          Note that the error message is "Command <sub-command> not found." Not just "Not found". And the command is indicated as failed.

          This is a must-fix for 4.0 since it is a regression.

          Tom Mueller added a comment -

          Note: the description here is about the output of the multimode command. But we need to fix this when not using multimode too.

          Also, this behavior is seen when the server is up. When the server is down, then the command is indicated as failed.

          martin.mares added a comment -

          revision 61091.


            People

            • Assignee:
              martin.mares
              Reporter:
              Mohamed Taman
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: