glassfish
  1. glassfish
  2. GLASSFISH-20133

Server occasionally fails to restart on Windows

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 4.0_b82_EE7MS7
    • Fix Version/s: 4.1
    • Component/s: admin
    • Labels:
      None
    • Environment:

      Windows 7 Enterprise

      Description

      The admin devtests on Windows occasionally become unstable because of tests that are unable to restart a domain.
      For example, the restart-domain test case sometimes produces the following output:

      restart-domain:
      [java] Listening for transport dt_socket at address: 9010
      [java] ##### Non-Verbose: Only Failures Are Printed #####
      [java] ######### FAILURE #########
      [java] Command restart-domain failed.
      [java]
      [java] Remote server does not listen for requests on [localhost:4848]. Is the server up?
      [java] Unable to get remote commands.
      [java] Closest matching local command(s):
      [java] restart-domain
      [java]
      [java]
      [java] ######### FAILURE #########
      [java] Command delete-domain failed.
      [java]
      [java] A file or folder within domain pwdomain at C:\files\hudson\workspace\admin-devtests-trunk-windows\glassfish4\glassfish\domains\pwdomain is in use. Stop using it before deleting the domain.
      [java]

      The delete-domain failed because the server was still running.

      Between these two tests that failed, there is a stop-domain test which succeeded. The stop-domain probably succeeded because the server was hung, so stop-domain was unable to connect so it thought the domain was down even though it really wasn't down.

      This failure then causes more tests to fail in the admin devtests suite.
      This failure does not happen on every run.

        Issue Links

          Activity

          Byron Nevins added a comment -

          This is important enough to keep at P3 but not important enough to fix post HCF for GF4.
          It is intermittent and difficult to reproduce.

          Eventually I need to take a few days and revamp all of the start/stop commands to all use the same exact way of determining if a server is "alive" or not. We currently have a mix of techniques.

          Also – this would be far too risky to fix post HCF...


            People

            • Assignee:
              Byron Nevins
              Reporter:
              Tom Mueller
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: