glassfish
  1. glassfish
  2. GLASSFISH-20136

Installer sets AS_JAVA incorrectly and other JDK related problems

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 4.0_b82_EE7MS7
    • Fix Version/s: 4.0_b85
    • Component/s: installation
    • Labels:
      None
    • Environment:

      Windows 7

      Description

      When running the installer for the b82 web profile, I'm seeing the following behavior related to the JDK selection page.

      1. The installer is not finding the version of JDK 7 that I have installed. I have both a C:\Program Files (x86)\Java directory and a C:\Program Files\Java directory. In the latter is the jdk1.7.0_17 directory, the only valid JDK for GF 4 that I have on my system. The installer says it could not find a valid JDK and that I must choose one using the 2nd radio button.

      2. I choose the jdk1.7.0_17 directory and the installer continues but is unable to create the domain. The installer says that the configuration was completed successfully even though the domain creation failed.

      3. In the glassfish\config\asenv.bat file, I have the following line:

      set AS_JAVA=C:\Program Files (x86)\Java

      which is incorrect. This cause asadmin to not function correctly.

      4. The uninstall fails with an error about not being able to find the required version of the JDK in the directory listed in (3).

        Activity

        Snjezana Sevo-Zenzerovic added a comment -

        Item 1. is caused by openInstaller framework's limited ability to reliably detect all Windows JDK installations, especially 64 bit JDK installations. At this point we can't do much about this since we really need to extend openInstaller JDK handling interfaces. This part will have to be deferred to future release.

        Items 2. and 3. are due to the fact that installer logic still does not always pick up explicitly provided JDK location in typical installation scenario and incorrectly falls back on the parent directory of the JDK used for installer runtime . This is handled in GlassFish specific install configuration code and will be fixed

        Item 4. is side effect of 3. so will be implicitly fixed.

        Snjezana Sevo-Zenzerovic added a comment -
        • What is the impact on the customer of the bug?

        Not a regression, but issues are becoming more visible and prominent for newer Windows releases. There is significant usability impact on Windows installation since JDK selection is not reliable and subsequent default domain creation and product runtime are severely affected.

        • What is the cost/risk of fixing the bug?

        openInstaller related part of the fix will be deferred due to relatively high cost and risk. However, changes to GlassFish installer configuration code are low/moderate risk .

        • Is there an impact on documentation or message strings?

        No.

        • Which tests should QA (re)run to verify the fix did not destabilize GlassFish?

        Regular Windows installer testing should be sufficient to identify regressions. Some FishCat program participants cover this functionality, too.

        • Which is the targeted build of 4.0 for this fix?

        b85

        • If this an integration of a new version of a component from another project,
          what are the changes that are being brought in? This might be list of
          Jira issues from that project or a list of revision messages.

        N/A

        Tom Mueller added a comment -

        Approved for 4.0. Please create a separate issue for #1 and add a comment to this issue with the number of the issue.

        Snjezana Sevo-Zenzerovic added a comment -

        Filed issue GLASSFISH-20330 to track the first item. Other items addressed in b85.


          People

          • Assignee:
            Snjezana Sevo-Zenzerovic
            Reporter:
            Tom Mueller
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: