glassfish
  1. glassfish
  2. GLASSFISH-20138

[Regression] asadmin create-profiler and delete-profiler fails in build 82

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0_b82_EE7MS7
    • Fix Version/s: 4.0_b83
    • Component/s: command_line_interface
    • Labels:
      None
    • Environment:

      Installed glassfish build 82 and java_ee_sdk-7-b81-unix.sh* for comparison on a system which has OS OEL6, JDK1.7.0_13.

      Description

      The SQE AdminCLI suite has a set of profiler tests that basically run create-profiler and delete-profiler. Using glassfish build 82, 9 out 13 tests fail. Using build 81, all 13 tests pass. The suite executes the following command

      o [test@wolfrun] $ asadmin create-profiler --user admin1 --passwordfile /home/agpineda/workspace/appserver-sqe/common/admincli/config/template/t_passwd1.txt --host wolfrun.us.oracle.com --port 10000 --enabled=true hprof

      o Using build 81, the result is:
      Command create-profiler executed successfully.

      o Using build 82, the result is:
      Command create-profiler failed.
      remote failure: profiler exists. Please delete it first

      The suite continues by executing:
      o [test@wolfrun] $ asadmin delete-profiler --user admin1 --passwordfile /home/agpineda/workspace/appserver-sqe/common/admincli/config/template/t_passwd1.txt --host wolfrun.us.oracle.com --port 10000

      o Using build 81, the result is:
      Command delete-profiler executed successfully.

      o Using build 82, the result is:
      Command delete-profiler failed.
      remote failure: delete failed
      Constraints for this JavaConfig configuration have been violated: on property [ profiler ] violation reason [ may not be null ]

      The rest of the failures in the AdminCLI suite are variations of create & delete profiler with basically the same errors.

        Activity

        Tom Mueller added a comment -

        This appears to be fixed on the latest trunk. I suspect that this was due to revision 60933.


          People

          • Assignee:
            Tom Mueller
            Reporter:
            Alex Pineda
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: