glassfish
  1. glassfish
  2. GLASSFISH-20172

Usage of any EL3.0 operator leads to Method stream not found ELException

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.0_b84_RC1
    • Component/s: cdi
    • Labels:
      None
    • Environment:

      GF 4.0 promoted build 81

      Description

      Sorry I can find category not for the EL implementation, please reassign it if this is not correct one.

      Any simple facelet with the usage of the EL3 operators leads to following exception on GF4.0:
      javax.el.ELException: /index.xhtml: Method stream not found
      at com.sun.faces.facelets.compiler.TextInstruction.write(TextInstruction.java:88)
      at com.sun.faces.facelets.compiler.UIInstructions.encodeBegin(UIInstructions.java:82)
      at com.sun.faces.facelets.compiler.UILeaf.encodeAll(UILeaf.java:183)
      at javax.faces.component.UIComponent.encodeAll(UIComponent.java:1852)
      at javax.faces.component.UIComponent.encodeAll(UIComponent.java:1852)
      at com.sun.faces.application.view.FaceletViewHandlingStrategy.renderView(FaceletViewHandlingStrategy.java:443)
      at com.sun.faces.application.view.MultiViewHandler.renderView(MultiViewHandler.java:131)
      at javax.faces.application.ViewHandlerWrapper.renderView(ViewHandlerWrapper.java:337)
      at com.sun.faces.lifecycle.RenderResponsePhase.execute(RenderResponsePhase.java:120)
      at com.sun.faces.lifecycle.Phase.doPhase(Phase.java:101)
      at com.sun.faces.lifecycle.LifecycleImpl.render(LifecycleImpl.java:201)
      at javax.faces.webapp.FacesServlet.service(FacesServlet.java:646)
      at org.apache.catalina.core.StandardWrapper.service(StandardWrapper.java:1682)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:318)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:160)
      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:734)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:673)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:175)
      at org.apache.catalina.connector.CoyoteAdapter.doService(CoyoteAdapter.java:357)
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:260)
      at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:188)
      at org.glassfish.grizzly.http.server.HttpHandler.runService(HttpHandler.java:191)
      at org.glassfish.grizzly.http.server.HttpHandler.doHandle(HttpHandler.java:168)
      at org.glassfish.grizzly.http.server.HttpServerFilter.handleRead(HttpServerFilter.java:189)
      at org.glassfish.grizzly.filterchain.ExecutorResolver$9.execute(ExecutorResolver.java:119)
      at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeFilter(DefaultFilterChain.java:288)
      at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeChainPart(DefaultFilterChain.java:206)
      at org.glassfish.grizzly.filterchain.DefaultFilterChain.execute(DefaultFilterChain.java:136)
      at org.glassfish.grizzly.filterchain.DefaultFilterChain.process(DefaultFilterChain.java:114)
      at org.glassfish.grizzly.ProcessorExecutor.execute(ProcessorExecutor.java:77)
      at org.glassfish.grizzly.nio.transport.TCPNIOTransport.fireIOEvent(TCPNIOTransport.java:838)
      at org.glassfish.grizzly.strategies.AbstractIOStrategy.fireIOEvent(AbstractIOStrategy.java:113)
      at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.run0(WorkerThreadIOStrategy.java:115)
      at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.access$100(WorkerThreadIOStrategy.java:55)
      at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy$WorkerThreadRunnable.run(WorkerThreadIOStrategy.java:135)
      at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:564)
      at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.run(AbstractThreadPool.java:544)
      at java.lang.Thread.run(Thread.java:722)

      The expression was simple, used from the EL repository tests, see the facelet I used:
      <?xml version='1.0' encoding='UTF-8' ?>
      <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
      <html xmlns="http://www.w3.org/1999/xhtml"
      xmlns:h="http://java.sun.com/jsf/html">
      <h:head>
      <title>Facelet Title</title>
      </h:head>
      <h:body>
      #

      {[1,2,3,4].stream().filter(i->i > 1).toList()}

      </h:body>
      </html>

        Activity

        Manfred Riem added a comment -

        Cannot reproduce this with a GF4.0 build from 3/26

        marfous added a comment -

        Please could you give it try with my application:
        https://dl.dropbox.com/u/1418580/jsf/WebApplication338.zip
        https://dl.dropbox.com/u/1418580/jsf/WebApplication338.war

        It doesn't work to me with GF4.0 build from 3/27. I tried also deployment from the NetBeans IDE as well from the GF Admin Console.
        We would need to detect any issues in the project since this is standard/base NetBeans Web project.

        Thanks a lot...

        Manfred Riem added a comment -

        This appears to be a Weld EL integration issue. Remove the beans.xml file and you'll see it works.

        kchung added a comment -

        Looks like weld's EL reolsvers do not support EL 3.0 yet. The following is what it takes to support EL 3.0, for JSP (taken from http://jcp.org/aboutJava/communityprocess/maintenance/jsr245/245-MR3.html). Weld need to do something similar.

        3. Support EL 3.0 (JSR 341).

        In JSP.2.9, add the following two ELResovers, after item 2, and renumber
        the other ELResolvers on the list. That is, place these ELResolvers between
        the custom ELResolvers and the MapELResolver.

        3. The ELResolver returned by ExpressionFactory.getStreamELResolver().
        4. javax.el.StaticFieldELResolver.

        Jozef Hartinger added a comment -

        Fixed in Weld. The fix will be available in Weld 2.0.0.Beta9.

        jjsnyder83 added a comment -

        Fixed by Weld in 2.0.0.CR1


          People

          • Assignee:
            jjsnyder83
            Reporter:
            marfous
          • Votes:
            1 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: