glassfish
  1. glassfish
  2. GLASSFISH-20184

[Regression] SDK 4.0 - Websocket sample (auction) fails to build

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0_b82_EE7MS7
    • Fix Version/s: 4.0_b84_RC1
    • Component/s: web_socket
    • Labels:
      None
    • Environment:

      Description

      No issues building this sample in promoted java_ee_sdk build 81, however, with java_ee_sdk build 82, it fails when executing:

      o [test@wolfun] $ mvn install

      The error seen is:
      [INFO] Scanning for projects...
      [INFO]
      [INFO] ------------------------------------------------------------------------
      [INFO] Building WebSocket Auction Sample Application 4.0-SNAPSHOT
      [INFO] ------------------------------------------------------------------------
      [INFO]
      [INFO] — maven-compiler-plugin:2.4:compile (default-compile) @ auction —
      [INFO] Compiling 7 source files to /home/agpineda/workspace/glassfish4/samples/websocket/auction/target/classes
      [INFO] -------------------------------------------------------------
      [ERROR] COMPILATION ERROR :
      [INFO] -------------------------------------------------------------
      [ERROR] $TEST/workspace/glassfish4/samples/websocket/auction/src/main/java/org/glassfish/samples/websocket/auction/decoders/AuctionMessageDecoder.java:[50,50] error: cannot find symbol
      [ERROR] symbol: class Adapter
      location: interface Decoder
      $TEST/workspace/glassfish4/samples/websocket/auction/src/main/java/org/glassfish/samples/websocket/auction/encoders/AuctionMessageEncoder.java:[50,50] error: cannot find symbol
      [ERROR] symbol: class Adapter
      location: interface Encoder
      $TEST/glassfish4/samples/websocket/auction/src/main/java/org/glassfish/samples/websocket/auction/AuctionServer.java:[66,37] error: incompatible types
      [ERROR] required: Class<? extends Decoder>
      found: Class<AuctionMessageDecoder>
      $TEST/workspace/glassfish4/samples/websocket/auction/src/main/java/org/glassfish/samples/websocket/auction/AuctionServer.java:[69,37] error: incompatible types
      [ERROR] required: Class<? extends Encoder>
      found: Class<AuctionMessageEncoder>
      $TEST/workspace/glassfish4/samples/websocket/auction/src/main/java/org/glassfish/samples/websocket/auction/decoders/AuctionMessageDecoder.java:[50,7] error: AuctionMessageDecoder is not abstract and does not override abstract method destroy() in Decoder
      [ERROR] $TEST/workspace/glassfish4/samples/websocket/auction/src/main/java/org/glassfish/samples/websocket/auction/encoders/AuctionMessageEncoder.java:[50,7] error: AuctionMessageEncoder is not abstract and does not override abstract method encode(Object) in Text
      [ERROR] $TEST/workspace/glassfish4/samples/websocket/auction/src/main/java/org/glassfish/samples/websocket/auction/encoders/AuctionMessageEncoder.java:[52,4] error: method does not override or implement a method from a supertype
      [INFO] 7 errors
      [INFO] -------------------------------------------------------------
      [INFO] ------------------------------------------------------------------------
      [INFO] BUILD FAILURE
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 2.350s
      [INFO] Finished at: Thu Apr 04 16:13:02 PDT 2013
      [INFO] Final Memory: 12M/212M

      This problem is seen on both Full and Web java_ee_sdk distributions.

        Issue Links

          Activity

          Pavel Bucek added a comment -

          fixed in the trunk

          Pavel Bucek added a comment -
          Alex Pineda added a comment -

          Verified fix in SDK promoted build 83. Mark the bug as resolved.

          Pavel Bucek added a comment -

          it already is marked as resolved..


            People

            • Assignee:
              Pavel Bucek
              Reporter:
              Alex Pineda
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: