glassfish
  1. glassfish
  2. GLASSFISH-20208

Edit Thread Pool requires class name, but none is provided/shown on web gui

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0_b83
    • Fix Version/s: 4.0_b85
    • Component/s: grizzly-kernel
    • Labels:
      None
    • Environment:

      windows 7 x64 jdk 7 u 17

      Description

      configurations/server-config/thread pools/http-thread-pool

      detail pane is shown with no class name value, and this appears to be a mandatory value in order to save any changes.

      therefore I am unable to make any changes, as gui refuses to allow save of values.

        Activity

        Anissa Lam added a comment -

        This seems to be a change in the grizzly code.

        In 3.x, there is a default classname for thread pool, and thats whats displayed in the console.
        ~/GF/3.1.2/gf-pb23/glassfish/bin 88) asadmin get configs.config.server-config.thread-pools.thread-pool.http-thread-pool
        configs.config.server-config.thread-pools.thread-pool.http-thread-pool.classname=com.sun.grizzly.http.StatsThreadPool
        configs.config.server-config.thread-pools.thread-pool.http-thread-pool.idle-thread-timeout-seconds=900
        configs.config.server-config.thread-pools.thread-pool.http-thread-pool.max-queue-size=4096
        configs.config.server-config.thread-pools.thread-pool.http-thread-pool.max-thread-pool-size=5
        configs.config.server-config.thread-pools.thread-pool.http-thread-pool.min-thread-pool-size=2
        configs.config.server-config.thread-pools.thread-pool.http-thread-pool.name=http-thread-pool
        Command get executed successfully.

        However, in 4.0, this classname is gone.

        ~/Awork/GF/glassfish4/glassfish/bin 147) asadmin get configs.config.server-config.thread-pools.thread-pool.http-thread-pool
        configs.config.server-config.thread-pools.thread-pool.http-thread-pool.idle-thread-timeout-seconds=900
        configs.config.server-config.thread-pools.thread-pool.http-thread-pool.max-queue-size=4096
        configs.config.server-config.thread-pools.thread-pool.http-thread-pool.max-thread-pool-size=5
        configs.config.server-config.thread-pools.thread-pool.http-thread-pool.min-thread-pool-size=5
        configs.config.server-config.thread-pools.thread-pool.http-thread-pool.name=http-thread-pool
        Command get executed successfully.

        Notice that the min-thread-pool-size is also changed.

        There is no notification to the GUI team about the classname change. I am not sure whats the intended change. If this is a bug or this is by design for 4.0

        Transfer to Grizzly team. If classname is not needed and should not be displayed, reassign to admin-gui so i can make the change.

        oleksiys added a comment -

        fixed

        Repository: svn
        Revision: 61410
        Date: 2013-04-12 23:41:42 UTC

        Log Message:
        ------------
        + fix issue #20208
        http://java.net/jira/browse/GLASSFISH-20208
        "Edit Thread Pool requires class name, but none is provided/shown on web gui"

        integrating Grizzly 2.3.1


          People

          • Assignee:
            oleksiys
            Reporter:
            pbelbin
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: