glassfish
  1. glassfish
  2. GLASSFISH-20213

(RN) Glassfish version 4_b83 windows Installer failed to start.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 4.0_b83
    • Fix Version/s: 4.1
    • Component/s: installation
    • Labels:
      None
    • Environment:

      Windows 7 SP1
      Java SE 6 u43
      Java SE 7 u17

      Description

      I have opened this issue again as the issue number GLASSFISH-19709 was closed as Duplicate to issue number GLASSFISH-19877 and it was targeting fix version 4.0_b82_EE7MS7. While it is not fixed in this issue.

      Reproduce Scenario:

      1- I have downloaded Glassfish, windows version glassfish-4.0-b83-windows-ml
      2- I have 2 versions of JDK version 6_u43 and 7_u17.
      3- Click the installer, it will popup a setup error message as the following:

      "This application needs version 1.6 or higher of the Java(TM) 2 runtime Environment..... etc."

      It should detect already existing installed JVM version, which installed normally.

      Workaround:
      issue the following command to run the installer:

      C:\Users\mohamed_taman\Desktop>glassfish-4.0-b83-windows-ml.exe -j "C:\Program Files\Java\jdk1.7.0_17"
      

        Activity

        Snjezana Sevo-Zenzerovic added a comment -

        Mohamed, those JDK 6 and JDK 7 installation are both 64-bit JDK installations, correct?

        If that is the case, this is a known issue where native install wrapper does not reliably detect 64 bit JDK installations using the information from Windows registry. Since the native wrapper is legacy component and updates to it are non-trivial it will not be feasible to fix the root cause for 4.0 release. We will, however, need to document the issue and workaround in the release notes.

        Mohamed Taman added a comment -

        Yes those are 64-bit JDKs.


          People

          • Assignee:
            Snjezana Sevo-Zenzerovic
            Reporter:
            Mohamed Taman
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: