glassfish
  1. glassfish
  2. GLASSFISH-20216

[Dev Tests Failed] Some of the deployment dev tests failed

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0_b83
    • Fix Version/s: 4.0_b84_RC1
    • Component/s: deployment
    • Labels:
      None
    • Environment:

      Win7, Mac OS.

      Description

      When I run the dev tests of the deployment comp, Some of the test case failed. Here's my steps about reproduce.
      1). Update the latest source of glassfish and dev tests.

      2). unzip the built glassfish zip file into a disk

      3). Set the following env. variables as below:
      S1AS_HOME=<glassfish v3 installation>
      APS_HOME=<appserv-tests>

      4). Check the following env. variables to set with these values:
      SECURE=false
      DEPL_TARGET=PE
      Nothing needs to be done if you don't have these env. var set.

      5). Start the domain.
      asadmin start-domain -v

      6). Simply type "ant all" from appserv-tests/devtests/deployment.

      7). After run all of the tests, you will find some informations as follows:
      [echo] [PASSED] AppClientAnnotationTest : testDescriptors,
      [echo] [FAILED] EjbAnnotationTest : testDescriptors,
      [echo] [FAILED] InheritanceAnnotationTest : testDescriptors,
      [echo] [PASSED] WebAnnotationTest : testDescriptors,

      All in all, the EjbAnnotationTest and InheritanceAnnotationTest shouldn't be failed.

      BTW: I have run the dev tests in my personal MAC OS, it seems these two tests still can't be passed.

        Activity

        Jeremy_Lv added a comment -

        Here's some of the error messages comes out when I only run the EjbAnnotationTest.

            [junit] ------------- Standard Error -----------------
            [junit] 4 08, 2013 7:15:55 午後 devtests.deployment.util.StandaloneProcessor
         run
            [junit] 情報: processing E:\GF_MAIN\appserv-tests/devtests/deployment/build
            [junit] 4 08, 2013 7:15:56 午後 devtests.deployment.util.DescriptorContentCo
        mparator compareContent
            [junit] SEVERE: last compared Field = private java.util.Map org.glassfish.de
        ployment.common.Descriptor.displayNames
            [junit] ------------- ---------------- ---------------
        

        Sometimes the Standard Error will be as follows:

            [junit] ------------- Standard Error -----------------
            [junit] 4 08, 2013 7:18:08 午後 devtests.deployment.util.StandaloneProcessor
         run
            [junit] 情報: processing E:\GF_MAIN\appserv-tests/devtests/deployment/build
            [junit] 4 08, 2013 7:18:09 午後 devtests.deployment.util.DescriptorContentCo
        mparator compareContent
            [junit] SEVERE: last compared Field = private boolean org.glassfish.ejb.depl
        oyment.descriptor.EjbSessionDescriptor.isStateless
            [junit] ------------- ---------------- ---------------
        

        I did run about all of the devtest on windows at 09/Nov/12 and all of the tests have passed. So I add the tags as a 40_regression issues.

        Jeremy_Lv added a comment -

        I have revert the dev test version to the r56938 and test the gfv4.0-b62 on my Mac OS and the deployment annotation test run successfully.

        I have also confirmed the latest version of dev tests and glassfish released version and the EjbAnnotationTest and InheritanceAnnotationTest will be failed.

        Jeremy_Lv added a comment - - edited

        Hong:
        I have just confirm the dev tests about r59448 you have checked in caused this issue, I have just run dev tests changed at r59448 and gfv4.0-b77 and this phenomenon can be reproduced.

        please take a look about the golden file changes you have checked in to reflected new name space.

        Thanks

        Jeremy

        Hong Zhang added a comment -

        The test changes were made to go with the changes in the GlassFish workspace to change schema namespace from java.sun.com to jcp.org. Do you have both latest GlassFish build as well as test workspace when you ran these tests? It's strange that the corresponding name space test change would cause issues on windows but not other platforms. Can you check what the name space look like in the generated xml (that will be used to compare with the golden file)? For each sub test directory, the generated xml should be under its META-INF subdirectory.

        Jeremy_Lv added a comment - - edited

        it not only happened on windows platform but also happened in my personal Mac OS 10.8.3.

        Do you have both latest GlassFish build as well as test workspace when you ran these tests?

        yes, I have update both of the dev tests and glassfish resource to test the dev tests.

        Can you check what the name space look like in the generated xml (that will be used to compare with the golden file)? For each sub test directory, the generated xml should be under its META-INF subdirectory.

        fine, I will check about it later.

        BTW: The issue is not only happened in my win7 platform but also my Mac OS 10.8.3 although it can be passed on ubuntu platform.

        Jeremy_Lv added a comment -

        Hong:

        I have sent the generated xml file to you through my gmail, pl. take a look about it.

        Thanks

        Jeremy_Lv added a comment -

        Hong:

        I have confirmed this issue is occurred by the description language defined as “en”. After I have delete all of the definition about xml:lang=”en” and the tests can be run successfully.

        Here’s some in the test results to test the annotation:

        [echo] [PASSED] AppClientAnnotationTest : testDescriptors,
        [echo] [PASSED] EjbAnnotationTest : testDescriptors,
        [echo] [PASSED] InheritanceAnnotationTest : testDescriptors,
        [echo] [PASSED] WebAnnotationTest : testDescriptors,
        

        Here's the changes:

        Index: ejb/goldenfiles/ejb-jar.xml
        ===================================================================
        --- ejb/goldenfiles/ejb-jar.xml	(revision 61221)
        +++ ejb/goldenfiles/ejb-jar.xml	(working copy)
        @@ -2,7 +2,7 @@
         <ejb-jar xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" metadata-complete="true" version="3.2" xsi:schemaLocation="http://xmlns.jcp.org/xml/ns/javaee http://xmlns.jcp.org/xml/ns/javaee/ejb-jar_3_2.xsd" xmlns="http://xmlns.jcp.org/xml/ns/javaee">
           <enterprise-beans>
             <session>
        -      <display-name xml:lang="en">myStatefulTest1</display-name>
        +      <display-name>myStatefulTest1</display-name>
               <ejb-name>myStatefulTest1</ejb-name>
               <business-remote>test.ejb.stateful.SFHello</business-remote>
               <ejb-class>test.ejb.stateful.StatefulTest1</ejb-class>
        @@ -35,7 +35,7 @@
               <passivation-capable>true</passivation-capable>
             </session>
             <session>
        -      <display-name xml:lang="en">StatefulTest2</display-name>
        +      <display-name>StatefulTest2</display-name>
               <ejb-name>StatefulTest2</ejb-name>
               <business-remote>test.ejb.stateful.SFHello</business-remote>
               <ejb-class>StatefulTest2</ejb-class>
        @@ -48,7 +48,7 @@
               <passivation-capable>true</passivation-capable>
             </session>
             <session>
        -      <display-name xml:lang="en">myStatelessTest1</display-name>
        +      <display-name>myStatelessTest1</display-name>
               <ejb-name>myStatelessTest1</ejb-name>
               <business-local>test.ejb.stateless.SLHello</business-local>
               <ejb-class>test.ejb.stateless.StatelessTest1</ejb-class>
        @@ -86,7 +86,7 @@
               </security-identity>
             </session>
             <session>
        -      <display-name xml:lang="en">StatelessTest2</display-name>
        +      <display-name>StatelessTest2</display-name>
               <ejb-name>StatelessTest2</ejb-name>
               <business-local>test.ejb.stateless.SLHello</business-local>
               <ejb-class>test.ejb.stateless.StatelessTest2</ejb-class>
        Index: inheritance/goldenfiles/ejb-jar.xml
        ===================================================================
        --- inheritance/goldenfiles/ejb-jar.xml	(revision 61221)
        +++ inheritance/goldenfiles/ejb-jar.xml	(working copy)
        @@ -2,7 +2,7 @@
         <ejb-jar xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" metadata-complete="true" version="3.2" xsi:schemaLocation="http://xmlns.jcp.org/xml/ns/javaee http://xmlns.jcp.org/xml/ns/javaee/ejb-jar_3_2.xsd" xmlns="http://xmlns.jcp.org/xml/ns/javaee">
           <enterprise-beans>
             <session>
        -      <display-name xml:lang="en">StatefulTest2</display-name>
        +      <display-name>StatefulTest2</display-name>
               <ejb-name>StatefulTest2</ejb-name>
               <business-remote>test.ejb.SFHello1</business-remote>
               <ejb-class>StatefulTest2</ejb-class>
        @@ -27,7 +27,7 @@
                 <lookup-name>java:comp/DefaultDataSource</lookup-name>
               </resource-ref>
               <resource-env-ref>
        -        <description xml:lang="en">testing</description>
        +        <description>testing</description>
                 <resource-env-ref-name>test.ejb.StatefulTest/ejbContext</resource-env-ref-name>
                 <resource-env-ref-type>javax.ejb.EJBContext</resource-env-ref-type>
                 <injection-target>
        @@ -75,7 +75,7 @@
               <passivation-capable>true</passivation-capable>
             </session>
             <session>
        -      <display-name xml:lang="en">myStatefulTest</display-name>
        +      <display-name>myStatefulTest</display-name>
               <ejb-name>myStatefulTest</ejb-name>
               <business-remote>test.ejb.SFHello1</business-remote>
               <ejb-class>test.ejb.StatefulTest1</ejb-class>
        @@ -117,7 +117,7 @@
                 <lookup-name>java:comp/DefaultDataSource</lookup-name>
               </resource-ref>
               <resource-env-ref>
        -        <description xml:lang="en">testing</description>
        +        <description>testing</description>
                 <resource-env-ref-name>test.ejb.StatefulTest/ejbContext</resource-env-ref-name>
                 <resource-env-ref-type>javax.ejb.EJBContext</resource-env-ref-type>
                 <injection-target>
        @@ -155,7 +155,7 @@
               <passivation-capable>true</passivation-capable>
             </session>
             <session>
        -      <display-name xml:lang="en">StatefulTest</display-name>
        +      <display-name>StatefulTest</display-name>
               <ejb-name>StatefulTest</ejb-name>
               <business-local>test.ejb.SFHello</business-local>
               <ejb-class>test.ejb.StatefulTest</ejb-class>
        @@ -180,7 +180,7 @@
                 <lookup-name>java:comp/DefaultDataSource</lookup-name>
               </resource-ref>
               <resource-env-ref>
        -        <description xml:lang="en">testing</description>
        +        <description>testing</description>
                 <resource-env-ref-name>test.ejb.StatefulTest/ejbContext</resource-env-ref-name>
                 <resource-env-ref-type>javax.ejb.EJBContext</resource-env-ref-type>
                 <injection-target>
        
        Hong Zhang added a comment -

        I see. I guess the localization part of the description is not generated the same on all platforms.
        You can go ahead and check in your fixes once you confirm the tests run successfully on windows as well as other platform.
        Thanks for your investigation on this and solving the mystery!

        Jeremy_Lv added a comment -

        The changes has been checked in, the committed revision is 61247...


          People

          • Assignee:
            Jeremy_Lv
            Reporter:
            Jeremy_Lv
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: