Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.0_b85
    • Component/s: None
    • Labels:
      None

      Description

      javax.persistence.schema-generation-action=drop-and-create does not actually drop tables. This seems to be an issue of EclipseLink not getting a shutdown/undeploy callback from GlassFish in time. I am using the default Derby database through NetBeans.

      The app can be found here: http://java.net/projects/cargotracker/downloads.

        Issue Links

          Activity

          Hide
          reza_rahman added a comment -

          I have not been able to get the standard schema generation drop to work at all. Here is what I have:

          <property name="javax.persistence.schema-generation.database.action"
          value="drop-and-create" />
          <property name="javax.persistence.schema-generation.create-database-schemas"
          value="true" />

          Any guidance is appreciated, I'd prefer to stick to the standard for this application. To get a copy of the application, please email me at reza.rahman@oracle.com.

          Show
          reza_rahman added a comment - I have not been able to get the standard schema generation drop to work at all. Here is what I have: <property name="javax.persistence.schema-generation.database.action" value="drop-and-create" /> <property name="javax.persistence.schema-generation.create-database-schemas" value="true" /> Any guidance is appreciated, I'd prefer to stick to the standard for this application. To get a copy of the application, please email me at reza.rahman@oracle.com.
          Hide
          Mitesh Meswani added a comment -

          Fixed with recent integration of EclipseLink

          Show
          Mitesh Meswani added a comment - Fixed with recent integration of EclipseLink
          Hide
          reza_rahman added a comment -

          It still does not work for me on build 87.

          Show
          reza_rahman added a comment - It still does not work for me on build 87.
          Hide
          reza_rahman added a comment -

          Still does not work. The problems seems to be that constraints aren't dropped before tables are wiped?

          Show
          reza_rahman added a comment - Still does not work. The problems seems to be that constraints aren't dropped before tables are wiped?
          Hide
          Mitesh Meswani added a comment -

          Reza and me discussed this and it looks like this might be a NetBeans issue. During Reza's workflow, NetBeans indicates that app is being redeployed however it actually does not happen and hence tables are not being dropped. Marking the bug as FIXED. Reza will open a separate bug against NetBeans

          Show
          Mitesh Meswani added a comment - Reza and me discussed this and it looks like this might be a NetBeans issue. During Reza's workflow, NetBeans indicates that app is being redeployed however it actually does not happen and hence tables are not being dropped. Marking the bug as FIXED. Reza will open a separate bug against NetBeans

            People

            • Assignee:
              Mitesh Meswani
              Reporter:
              reza_rahman
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: