glassfish
  1. glassfish
  2. GLASSFISH-20244

Strange error message on <f:viewAction>

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 4.0_b82_EE7MS7
    • Fix Version/s: None
    • Component/s: jsf
    • Labels:
      None

      Description

      I get an error message at the bottom of the page: The metadata component needs to be nested within a f:metadata tag. Suggestion: enclose the necessary components within <f:metadata>. The message seems wrong. Here is my code:

      <ui:define name="content">
      <f:metadata>
      <f:viewParam name="trackingId" value="#

      {cargoDetails.trackingId}

      " />
      <f:viewAction action="#

      {cargoDetails.load}

      " />
      </f:metadata>

      Even more strangely, the code actually works. Also, removing the <f:viewAction> makes the error go away although <f:viewParam> is still in <f:metadata>. The problem is demonstrated in this application: http://java.net/projects/cargotracker/downloads/download/cargotracker.zip.

      To reproduce:

      • Build the application in Maven and deploy.
      • Open the application in a browser: http://localhost:8080/cargo-tracker/.
      • Click on booking and routing
      • Click on either of the cargos for details.

      Please advise. Perhaps I am doing something wrong?

        Issue Links

          Activity

          Manfred Riem added a comment -

          Are you running this application in Development or Production mode?

          Ed Burns added a comment -

          Because this is related to an error message, can we consider this one not a showstopper?

          reza_rahman added a comment -

          Yes, please re-prioritize as needed. Although the message is confusing, it does not affect functionality. I'll track the bug this duplicates.


            People

            • Assignee:
              Manfred Riem
              Reporter:
              reza_rahman
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: