glassfish
  1. glassfish
  2. GLASSFISH-20248

Regression: @Interceptors on method in a superclass of @ManagedBean is ignored

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 4.0_b83
    • Fix Version/s: 4.0_b84_RC1
    • Component/s: deployment
    • Labels:
      None

      Description

      This is a regression from early versions introduced by changes to support lifecycle callback method-level interceptors. The change is to restore previous iteration on all public methods of the managed bean (getMethods() vs. getDeclaredMethods()).

      • What is the impact on the customer of the bug?
        Interceptors spec non-compliant behavior, and the previous changes were not correct as they caused CTS regressions
      • How likely is it that a customer will see the bug and how serious is the bug?
        It will break existing applications with superclasses in @ManagedBean's
      • What CTS failures are caused by this bug?
        MB interceptors tests
      • What is the cost/risk of fixing the bug?
        1 line change
      • Is there an impact on documentation or message strings?
        no
      • Which tests should QA (re)run to verify the fix did not destabilize GlassFish?
        ManagedBean tests in CTS, QA regression tests
      • Which is the targeted build of 4.0 for this fix?
        the next
      • Is this an integration of a new version of a component from another project?
        no

        Activity

        marina vatkina added a comment -

        Sending dol/src/main/java/com/sun/enterprise/deployment/annotation/handlers/ManagedBeanHandler.java
        Committed revision 61282.


          People

          • Assignee:
            marina vatkina
            Reporter:
            marina vatkina
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: