glassfish
  1. glassfish
  2. GLASSFISH-20252

Module "AS-WEB-GLUE-00198" reports invalid hostname in the server log

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Works as designed
    • Affects Version/s: 4.0_b83
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:

      Windows 7 SP1 & Mac OS X 10.8.3
      Glassfish 4 b83

      Description

      While starting up the server the AS-WEB-GLUE-00198 module reports invalid hostname as the following /0.0.0.0

      producing the following in the server log:

      [2013-04-10T01:05:44.839+0200] [glassfish 4.0] [INFO] [AS-WEB-GLUE-00198] [javax.enterprise.web] [tid: _ThreadID=126 _ThreadName=Thread-16] [timeMillis: 1365548744839] [levelValue: 800] [[
        Created HTTP listener http-listener-1 on host/port 0.0.0.0:8080]]
      
      [2013-04-10T01:05:44.862+0200] [glassfish 4.0] [INFO] [AS-WEB-GLUE-00198] [javax.enterprise.web] [tid: _ThreadID=126 _ThreadName=Thread-16] [timeMillis: 1365548744862] [levelValue: 800] [[
        Created HTTP listener http-listener-2 on host/port 0.0.0.0:8181]]
      
      [2013-04-10T01:05:44.868+0200] [glassfish 4.0] [INFO] [AS-WEB-GLUE-00198] [javax.enterprise.web] [tid: _ThreadID=126 _ThreadName=Thread-16] [timeMillis: 1365548744868] [levelValue: 800] [[
        Created HTTP listener admin-listener on host/port 0.0.0.0:4848]]
      

        Activity

        shreedhar_ganapathy added a comment -

        Hello Taman
        What was the expected value you were looking for?
        From the log message, the listeners are defaulting to listening on all interfaces which is what the 0.0.0.0 refers to.

        The responses to the above will help us understand what the issue is.
        =====
        Reassigned to Tom Mueller for further follow up.

        Mohamed Taman added a comment -

        Hi Shreedhar,

        Instead http-listener-2 on host/port 0.0.0.0:8181, I expect to show something like one of the following:

        http-listener-2 on host/port 127.0.0.1:8181
        http-listener-2 on host/port localhost:8181
        http-listener-2 on host/port [current machine IP]:8181

        As 0.0.0.0 is an invalid IP address for communication,

        Computers normally show an address of 0.0.0.0 when they are not connected to a TCP/IP network. Having this address, a computer cannot be reached or communicate with any other devices over IP.

        TCP/IP software applications also use 0.0.0.0 as a programming technique to monitor network traffic from any valid IP address. While connected computers do not use this address, messages carried over IP sometimes include 0.0.0.0 inside the header when the source of the message is unknown.

        And as I understand this is the network address listener for communication to the server via HTTP, HTTPS and admin console ports.

        Tom Mueller added a comment -

        Here, the 0.0.0.0 is used to indicate that the socket is bound to all interfaces on the system. It isn't just localhost or 127.0.0.1 but all interface. If there were 10 interfaces on the system, we don't want the log message to list all interfaces, so 0.0.0.0 is used to indicate that. Also, this is the default value for the hosts attribute in the configuration.

        Resolving this as "works as designed".


          People

          • Assignee:
            Tom Mueller
            Reporter:
            Mohamed Taman
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: