glassfish
  1. glassfish
  2. GLASSFISH-20277

GF4 installer: Using older Update Center bootstrap / java client (regression)

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 4.0_b84_RC1
    • Fix Version/s: 4.0_b85
    • Component/s: installation
    • Labels:
      None

      Description

      When running the B84 GF installer I bootstrapped UC from the command line by running the "pkg" wrapper script. It looks old, because it refers to wikis.sun.com:

      http://wikis.sun.com/display/updatecenter/UsageMetricsUC2

      Also, the Java client appears to be pretty old too because:

      1) It is slower than the B56 client. The GF4.0 bootstrap of pkg took over a minute for me, but with UC B56 it took less than 40s.

      2) B56 has much improved progress feedback.

      So it looks like we are using an old wrapper script for "pkg" (and I assume "updatetool") and the Java client is old too.

      FYI, I checked the GF 3.1.2 GF installer, and it appears to be using the B56 version (it has the correct URL and download is fast) – so this looks like a regression.

        Activity

        Snjezana Sevo-Zenzerovic added a comment -

        It looks like this slipped through the cracks during 3.1.2 changes merge, probably because of whole nucleus/appserver pom split going on...

        Yes, trunk contains B54 client and bootstrap and should be upgraded to b56.

        Snjezana Sevo-Zenzerovic added a comment -
        • What is the impact on the customer of the bug?

        This is a regression compared to 3.1.2 release. Performance and user experience for UC client bootstrap is affected due to old bootstrap/Java client version. Also, branding issues since integrated release is not Oracle branded.

        • What is the cost/risk of fixing the bug?

        Low risk. Two line fix to update pkg and bootstrap jar versions in top level pom.xml. New versions have been tested in the field in 3.1.2 and 3.1.2.2 releases so low regression risk.

        • Is there an impact on documentation or message strings?

        No.

        • Which tests should QA (re)run to verify the fix did not destabilize GlassFish?

        Regular installer and UC integration testing will be sufficient.

        • Which is the targeted build of 4.0 for this fix?

        b85

        • If this an integration of a new version of a component from another project,
          what are the changes that are being brought in? This might be list of
          Jira issues from that project or a list of revision messages.

        Not exactly new integration, but delayed merge of the 3.1.2 branch integration.

        Tom Mueller added a comment -

        Approved for 4.0.

        Snjezana Sevo-Zenzerovic added a comment -

        Integrated updated client jars.


          People

          • Assignee:
            Snjezana Sevo-Zenzerovic
            Reporter:
            Joe Di Pol
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: