glassfish
  1. glassfish
  2. GLASSFISH-20289

None of the javax.* packages have their OSGi versions specified, they are left as "default" which is "0.0.0"

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Works as designed
    • Affects Version/s: 4.0_b84_RC1
    • Fix Version/s: None
    • Component/s: OSGi
    • Labels:
      None

      Description

      None of the javax.* packages have their OSGi versions exported, they are left as "default" which is "0.0.0"

      This makes deploying bundles like dom4j impossible.

              <dependency>
                  <groupId>org.dom4j</groupId>
                  <artifactId>com.springsource.org.dom4j</artifactId>
                  <version>1.6.1</version>
              </dependency>
      

      Other containers like JBoss 7, Aries, etc export the javax.* packages with the correct versions based on the JDK running the container.

      I can see that these should be added so osgi.properties but are currently not present.

        Activity

        Hide
        aaronjwhiteside added a comment -
        [2013-04-11T13:04:01.551-0400] [glassfish 4.0] [INFO] [] [] [tid: _ThreadID=88 _ThreadName=Thread-4] [timeMillis: 1365699841551] [levelValue: 800] [[
          org.osgi.framework.BundleException: Unresolved constraint in bundle com.springsource.org.dom4j [354]: Unable to resolve 354.0: missing requirement [354.0] osgi.wiring.package; (&(osgi.wiring.package=javax.xml.stream)(version>=1.0.1)(!(version>=2.0.0)))
        	at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3974)
        	at org.apache.felix.framework.Felix.startBundle(Felix.java:2037)
        	at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:955)
        	at org.apache.felix.fileinstall.internal.DirectoryWatcher.process(DirectoryWatcher.java:1175)
        	at org.apache.felix.fileinstall.internal.DirectoryWatcher.process(DirectoryWatcher.java:1153)
        	at org.apache.felix.fileinstall.internal.DirectoryWatcher.processAllBundles(DirectoryWatcher.java:1146)
        	at org.apache.felix.fileinstall.internal.DirectoryWatcher.process(DirectoryWatcher.java:456)
        	at org.apache.felix.fileinstall.internal.DirectoryWatcher.run(DirectoryWatcher.java:263)]]
        
        Show
        aaronjwhiteside added a comment - [2013-04-11T13:04:01.551-0400] [glassfish 4.0] [INFO] [] [] [tid: _ThreadID=88 _ThreadName= Thread -4] [timeMillis: 1365699841551] [levelValue: 800] [[ org.osgi.framework.BundleException: Unresolved constraint in bundle com.springsource.org.dom4j [354]: Unable to resolve 354.0: missing requirement [354.0] osgi.wiring. package ; (&(osgi.wiring. package =javax.xml.stream)(version>=1.0.1)(!(version>=2.0.0))) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3974) at org.apache.felix.framework.Felix.startBundle(Felix.java:2037) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:955) at org.apache.felix.fileinstall.internal.DirectoryWatcher.process(DirectoryWatcher.java:1175) at org.apache.felix.fileinstall.internal.DirectoryWatcher.process(DirectoryWatcher.java:1153) at org.apache.felix.fileinstall.internal.DirectoryWatcher.processAllBundles(DirectoryWatcher.java:1146) at org.apache.felix.fileinstall.internal.DirectoryWatcher.process(DirectoryWatcher.java:456) at org.apache.felix.fileinstall.internal.DirectoryWatcher.run(DirectoryWatcher.java:263)]]
        Hide
        Sanjeeb Sahoo added a comment -

        This is by design. We don't assign versions to Java SE packages, because their versions are not documented anywhere.

        Show
        Sanjeeb Sahoo added a comment - This is by design. We don't assign versions to Java SE packages, because their versions are not documented anywhere.
        Hide
        aaronjwhiteside added a comment -

        JAXB is bundled with Java and is documented.

        http://jaxb.java.net/guide/Which_JAXB_RI_is_included_in_which_JDK_.html

        You could use the minimum version of 2.0.3 for Java 6 and 2.2.4 for Java 7.
        If this is not fixed valid OSGi bundles will not deploy.

        JAXP is also bundled with Java and is documented
        http://en.wikipedia.org/wiki/Java_API_for_XML_Processing

        JAX-WS 2.0 (minimum version) is also bundled with Java 6+.

        What you say is true for a lot of packages but not most under javax.xml* which I guess is all I'm concerned with at the moment.

        Show
        aaronjwhiteside added a comment - JAXB is bundled with Java and is documented. http://jaxb.java.net/guide/Which_JAXB_RI_is_included_in_which_JDK_.html You could use the minimum version of 2.0.3 for Java 6 and 2.2.4 for Java 7. If this is not fixed valid OSGi bundles will not deploy. JAXP is also bundled with Java and is documented http://en.wikipedia.org/wiki/Java_API_for_XML_Processing JAX-WS 2.0 (minimum version) is also bundled with Java 6+. What you say is true for a lot of packages but not most under javax.xml* which I guess is all I'm concerned with at the moment.
        Hide
        aaronjwhiteside added a comment -

        SJSXP 1.0.1 is bundled with Java 6 since the first release, http://sjsxp.java.net/.

        Which includes the javax.xml.stream package among others..

        I don't wish to be rude but a lot can be found out about various libraries that are bundled with the java with a quick google search..

        Show
        aaronjwhiteside added a comment - SJSXP 1.0.1 is bundled with Java 6 since the first release, http://sjsxp.java.net/ . Which includes the javax.xml.stream package among others.. I don't wish to be rude but a lot can be found out about various libraries that are bundled with the java with a quick google search..

          People

          • Assignee:
            Sanjeeb Sahoo
            Reporter:
            aaronjwhiteside
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: