glassfish
  1. glassfish
  2. GLASSFISH-20291

Embedded GlassFish copies domain.xml to default-web.xml

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0_b84_RC1
    • Fix Version/s: 4.0_b85
    • Component/s: embedded
    • Labels:
      None

      Description

      The root cause of the problem described in http://java.net/jira/browse/GLASSFISH-20270 seems to be that Embedded GlassFish tries to parse my domain.xml as default-web.xml and then obviously fails.

      This is how I start Embedded GlassFish:

              File domainConfig = new File(configDirName, "domain.xml");
              GlassFishProperties gfProps = new GlassFishProperties();
              if (domainConfig.exists()) {
                  gfProps.setConfigFileURI(domainConfig.toURI().toString());
              }
      
              try {
                  glassFish = GlassFishRuntime.bootstrap().newGlassFish(gfProps);
                  glassFish.start();
                  // ...
      

      In the config directory

      /tmp/gfembed6394395759171343973tmp/config

      I can see two files domain.xml and default-web.xml with identical content.

        Activity

        Bhavanishankar added a comment -

        This issue is caused due to the following check-in 56069. I am working on a fix for this.

        Bhavanishankar added a comment -

        This has been fixed with check-in rev 61551. Refer the following link for fix details:

        http://java.net/projects/glassfish/lists/commits/archive/2013-04/message/460


          People

          • Assignee:
            Bhavanishankar
            Reporter:
            Harald Wellmann
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: