glassfish
  1. glassfish
  2. GLASSFISH-20292

html_basic.taglib.xml and facelets_jsf_core.taglib.xml are not complete in JSF2.2

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.0_b85
    • Component/s: jsf
    • Labels:
      None

      Description

      The issue from http://java.net/jira/browse/JAVASERVERFACES-2756 still remains and we had reported also additional missing tags from users. Please can I ask you for completion of following attributes and tags into html_basic.taglib.xml and facelets_jsf_core.taglib.xml files:

      facelets_jsf_core.taglib.xml:
      f:attributes - MISSING WHOLE TAG
      f:passThroughAttribute - MISSING WHOLE TAG
      f:passThroughAttributes - MISSING WHOLE TAG
      f:ajax - MISSING delay, resetValues ATTR
      f:view - MISSING transient, contracts ATTR
      f:selectItems - MISSING rendered, actionListener ATTR

      html_basic.taglib.xml:
      h:inputFile - MISSING WHOLE TAG
      h:button - MISSING role, disableClientWindow ATTR
      h:commandButton - MISSING role ATTR
      h:commandLink - MISSING role ATTR
      h:link - MISSING role, disableClientWindow ATTR

      Sorry for annoyances but we need to have these files completed for purposes of JSF editor since it's only way how to get list of tags, their attributes and their documentation. Thanks a lot!

      Links to corresponding NetBeans issues:
      https://netbeans.org/bugzilla/show_bug.cgi?id=228288
      https://netbeans.org/bugzilla/show_bug.cgi?id=228287

        Activity

        marfous added a comment -

        Also these two fixes would be appreciated and the #2637 is also already fixed now without fixing in the taglib metadata:

        http://java.net/jira/browse/JAVASERVERFACES-2637
        h:doctype - MISSING WHOLE TAG

        http://java.net/jira/browse/JAVASERVERFACES_SPEC_PUBLIC-1131
        h:outputScript - name ATTR is not required
        h:outputStylesheet - name ATTR is not required

        Thanks...

        Ed Burns added a comment -

        I'm sorry, but I didn't get to JAVASERVERFACES_SPEC_PUBLIC-1131, and it's too late to get it for 2.2, since we handed off the final spec. I can fix it in the html_basic.taglib.xml file though because that is an impl detail.

        Ed Burns added a comment -

        What is the impact on the customer of the bug?

        NetBeans IDE displays incorrect and incomplete documentation for JSF taglibs.

        How likely is it that a customer will see the bug and how serious is the bug?

        100%

        Is it a regression?

        No

        Does it meet other bug fix criteria (security, performance, etc.)?

        Yes

        What CTS failures are caused by this bug?

        None known.

        What is the cost/risk of fixing the bug

        How risky is the fix? How much work is the fix? Is the fix complicated?

        These files are only used for documentation purposes and not by the runtime. Therefore, there is no risk to the runtime.

        Is there an impact on documentation or message strings?

        No.

        Which tests should QA (re)run to verify the fix did not destabilize GlassFish?

        None, dev tests are sufficient.

        Which is the targeted build of 4.0 for this fix?

        TBD

        Tom Mueller added a comment -

        Approved for 4.0.

        Ed Burns added a comment -

        M jsf-ri/conf/share/facelets_jsf_core.taglib.xml
        M jsf-ri/conf/share/html_basic.taglib.xml

        • Had to revert this because it was causing quicklook tests to fail.
          Sending jsf-ri/conf/share/facelets_jsf_core.taglib.xml
          Sending jsf-ri/conf/share/html_basic.taglib.xml
          Transmitting file data ..
          Committed revision 11867.
        Ed Burns added a comment -

        Your recent checkin of the taglib files for JAVASERVERFACES-2836 /
        GLASSFISH-20294
        breaks some of the JSF quicklook tests. Namely it is the *
        Glassfish* *Profile with Security Manager Turned On
        *test.
        *
        *Here is the test output:

        1.
        [testng] FAILED: jsfIndexPageBasicTest
        2.
        [testng] java.lang.Exception: java.io.FileNotFoundException:
        http://localhost:8080/jsfastrologer/index.jsp
        3.
        [testng] at
        test.jsf.astrologer.JSFWebTestNG.jsfIndexPageBasicTest(JSFWebTestNG.java:166)
        4.
        [testng] Caused by: java.io.FileNotFoundException:
        http://localhost:8080/jsfastrologer/index.jsp
        5.
        [testng] at
        sun.net.www.protocol.http.HttpURLConnection$6.run(HttpURLConnection.java:1664)
        6.
        [testng] at
        sun.net.www.protocol.http.HttpURLConnection$6.run(HttpURLConnection.java:1662)
        7.
        [testng] at java.security.AccessController.doPrivileged(Native
        Method)
        8.
        [testng] at
        sun.net.www.protocol.http.HttpURLConnection.getChainedException(HttpURLConnection.java:1660)
        9.
        [testng] at
        sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1243)
        10.
        [testng] at
        test.jsf.astrologer.JSFWebTestNG.jsfIndexPageBasicTest(JSFWebTestNG.java:147)
        11.
        [testng] ... 22 more
        12.
        [testng] Caused by: java.io.FileNotFoundException:
        http://localhost:8080/jsfastrologer/index.jsp
        13.
        [testng] at
        sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1613)
        14.
        [testng] at
        java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:468)
        15.
        [testng] at
        test.jsf.astrologer.JSFWebTestNG.jsfIndexPageBasicTest(JSFWebTestNG.java:144)
        16.
        [testng] ... 22 more
        17.
        [testng] ... Removed 26 stack frames
        18.
        [testng] FAILED: jsfAppDeployedFirstPagetest
        19.
        [testng] java.lang.Exception: java.io.FileNotFoundException:
        http://localhost:8080/jsfastrologer/faces/greetings.jsp
        20.
        [testng] at
        test.jsf.astrologer.JSFWebTestNG.jsfAppDeployedFirstPagetest(JSFWebTestNG.java:125)
        21.
        [testng] Caused by: java.io.FileNotFoundException:
        http://localhost:8080/jsfastrologer/faces/greetings.jsp
        22.
        [testng] at
        sun.net.www.protocol.http.HttpURLConnection$6.run(HttpURLConnection.java:1664)
        23.
        [testng] at
        sun.net.www.protocol.http.HttpURLConnection$6.run(HttpURLConnection.java:1662)
        24.
        [testng] at java.security.AccessController.doPrivileged(Native
        Method)
        25.
        [testng] at
        sun.net.www.protocol.http.HttpURLConnection.getChainedException(HttpURLConnection.java:1660)
        26.
        [testng] at
        sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1243)
        27.
        [testng] at
        test.jsf.astrologer.JSFWebTestNG.jsfAppDeployedFirstPagetest(JSFWebTestNG.java:105)
        28.
        [testng] ... 22 more
        29.
        [testng] Caused by: java.io.FileNotFoundException:
        http://localhost:8080/jsfastrologer/faces/greetings.jsp
        30.
        [testng] at
        sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1613)
        31.
        [testng] at
        java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:468)
        32.
        [testng] at
        test.jsf.astrologer.JSFWebTestNG.jsfAppDeployedFirstPagetest(JSFWebTestNG.java:102)
        33.
        [testng] ... 22 more
        34.
        [testng] ... Removed 26 stack frames
        35.
        [testng]
        36.
        [testng] ===============================================
        37.
        [testng] jsf_hello_world
        38.
        [testng] Tests run: 2, Failures: 2, Skips: 0
        39.
        [testng] ===============================================

        When I replace the taglib files with 2.2.0-m13 versions (before your
        change) all tests pass.
        One option is to go ahead with 2.2.0-m14 without this change, then do
        2.2.0-m15 when this is ready.

        -roger

        marfous added a comment -

        No worries about JAVASERVERFACES_SPEC_PUBLIC-1131, the implementation change in the doc without the spec definition sounds well to us.
        And when it would not be possible I think that the most important are the JSF2.2 related changes, thanks!

        Ed Burns added a comment -

        This will be in GlassFish 4.0 promoted build 85.

        Ed

        Ed Burns added a comment -

        Integrated with 2.2.0-m14, committed as

        r61425 | rogerk | 2013-04-15 09:06:17 -0400 (Mon, 15 Apr 2013) | 213 lines

        http://java.net/jira/browse/GLASSFISH-20292 http://java.net/jira/browse/GLASSFISH-20232 http://java.net/jira/browse/GLASSFISH-20123 http://java.net/jira/browse/GLASSFISH-20122

        http://java.net/jira/browse/GLASSFISH-20292

        M jsf-ri/conf/share/facelets_jsf_core.taglib.xml

        f:attributes - MISSING WHOLE TAG
        f:passThroughAttribute - MISSING WHOLE TAG
        f:passThroughAttributes - MISSING WHOLE TAG
        f:ajax - MISSING delay, resetValues ATTR
        f:view - MISSING transient, contracts ATTR
        f:selectItems - MISSING rendered, actionListener ATTR

        M jsf-ri/conf/share/html_basic.taglib.xml

        h:inputFile - MISSING WHOLE TAG
        h:button - MISSING role, disableClientWindow ATTR
        h:commandButton - MISSING role ATTR
        h:commandLink - MISSING role ATTR
        h:link - MISSING role, disableClientWindow ATTR
        h:doctype - MISSING WHOLE TAG

        Sending jsf-ri/conf/share/facelets_jsf_core.taglib.xml
        Sending jsf-ri/conf/share/html_basic.taglib.xml
        Transmitting file data ..
        Committed revision 11873.

        http://java.net/jira/browse/GLASSFISH-20232

        M jsf-ri/src/main/java/com/sun/faces/flow/FlowHandlerImpl.java

        • Instead of polling the config manager to see if there are flows, use
          the addFlow() method.
          Sending jsf-ri/src/main/java/com/sun/faces/flow/FlowHandlerImpl.java
          Transmitting file data .
          Committed revision 11852.

        http://java.net/jira/browse/GLASSFISH-20123

        M jsf-ri/build-pre-maven-rename.xml
        M jsf-api/build-pre-maven-rename.xml

        • Apply the changes from "svn diff -r 11859:11860" to the
          "pre-maven-rename" variant.

        Sending jsf-api/build-pre-maven-rename.xml
        Sending jsf-ri/build-pre-maven-rename.xml
        Transmitting file data ..
        Committed revision 11872.

        M jsf-ri/build.xml

        • change mvn.deploy.release.local and mvn.deploy.release to depend on m14.

        M jsf-ri/mojarra-jsf-impl.bnd

        • change OSGi Implementation-Version to be 2.2.0-m14.
        • change OSGi Bundle-Version to be 2.1.99.b14

        M common/ant/maven.xml

        • If the build.type is not -SNAPSHOT, activate the check-module property
          when invoking maven. This causes the

        <groupId>org.glassfish.build</groupId>
        <artifactId>spec-version-maven-plugin</artifactId>
        <version>1.1</version>

        plugin to be invoked, as shown in this output

        [INFO] Building jar: /Users/ejburns/Documents/JavaEE/workareas/mojarra-MOJARRA_2_2_0_GLASSFISH_4_0/jsf-api/build/mvn/target/javax.faces-api-2.2-m14.jar
        [INFO] [build-helper:attach-artifact

        {execution: attach-artifacts}

        ]
        [INFO] [spec-version:check-module

        {execution: default}

        ]
        [INFO] [source:jar-no-fork

        {execution: attach-sources}

        ]
        [INFO] Building jar: /Users/ejburns/Documents/JavaEE/workareas/mojarra-MOJARRA_2_2_0_GLASSFISH_4_0/jsf-ri/build/mvn/target/javax.faces-2.2.0-m14.jar
        [INFO] [build-helper:attach-artifact

        {execution: attach-artifacts}

        ]
        [INFO] [spec-version:check-module

        {execution: default}

        ]
        [INFO] [source:jar-no-fork

        {execution: attach-sources}

        ]

        M common/ant/template/jsf-impl-pom-template.xml
        M common/ant/template/jsf-api-pom-template.xml

        • invoke the spec-version-maven-plugin if the check-module property is
          activated.

        M jsf-api/mojarra-jsf-api.bnd

        • Change OSGi Implementation-Version to be 2.2.0-m14
        • Change OSGi Bundle-Version to be 2.1.99.b14

        M jsf-api/build.xml

        • change mvn.deploy.release.local and mvn.deploy.release to depend on m14
          Sending common/ant/maven.xml
          Sending common/ant/template/jsf-api-pom-template.xml
          Sending common/ant/template/jsf-impl-pom-template.xml
          Sending jsf-api/build.xml
          Sending jsf-api/mojarra-jsf-api.bnd
          Sending jsf-ri/build.xml
          Sending jsf-ri/mojarra-jsf-impl.bnd
          Transmitting file data .......
          Committed revision 11860.

        To preverve backward compatibility with the now deprecated Facelets
        ResourceResolver, ensure it gets consulted on ViewHandler0.viewExists().

        r=mriem

        SECTION: Modified Files
        ----------------------------
        M jsf-ri/src/main/java/com/sun/faces/facelets/impl/DefaultFaceletFactory.java
        M jsf-ri/src/main/java/com/sun/faces/application/view/FaceletViewHandlingStrategy.java
        M jsf-demo/sandbox/flow_and_contract/app/pom.xml
        M jsf-ri/src/main/java/com/sun/faces/renderkit/html_basic/OutcomeTargetRenderer.java

        • Unrelated change. Don't renderd the flow attributes on outcomeTarget
          components unless there are flows.

        D jsf-demo/sandbox/flow_and_contract/app/src/main/webapp/contracts
        D jsf-demo/sandbox/flow_and_contract/app/src/main/webapp/contracts/leftNav
        D jsf-demo/sandbox/flow_and_contract/app/src/main/webapp/contracts/topNav

        • Unrelated change, the focus of this demo changed so that now the flows
          and contracts are bundled in jars, not with the app.

        A test/agnostic/vdl/facelets/resource-resolver
        A test/agnostic/vdl/facelets/resource-resolver/nbactions.xml
        A test/agnostic/vdl/facelets/resource-resolver/src
        A test/agnostic/vdl/facelets/resource-resolver/src/test
        A test/agnostic/vdl/facelets/resource-resolver/src/test/java
        A test/agnostic/vdl/facelets/resource-resolver/src/test/java/com
        A test/agnostic/vdl/facelets/resource-resolver/src/test/java/com/sun
        A test/agnostic/vdl/facelets/resource-resolver/src/test/java/com/sun/faces
        A test/agnostic/vdl/facelets/resource-resolver/src/test/java/com/sun/faces/test
        A test/agnostic/vdl/facelets/resource-resolver/src/test/java/com/sun/faces/test/agnostic
        A test/agnostic/vdl/facelets/resource-resolver/src/test/java/com/sun/faces/test/agnostic/vdl
        A test/agnostic/vdl/facelets/resource-resolver/src/test/java/com/sun/faces/test/agnostic/vdl/facelets
        A test/agnostic/vdl/facelets/resource-resolver/src/test/java/com/sun/faces/test/agnostic/vdl/facelets/resource_resolver
        A test/agnostic/vdl/facelets/resource-resolver/src/test/java/com/sun/faces/test/agnostic/vdl/facelets/resource_resolver/VerifyResourceResolverUsageIT.java
        A test/agnostic/vdl/facelets/resource-resolver/src/main
        A test/agnostic/vdl/facelets/resource-resolver/src/main/java
        A test/agnostic/vdl/facelets/resource-resolver/src/main/java/com
        A test/agnostic/vdl/facelets/resource-resolver/src/main/java/com/sun
        A test/agnostic/vdl/facelets/resource-resolver/src/main/java/com/sun/faces
        A test/agnostic/vdl/facelets/resource-resolver/src/main/java/com/sun/faces/test
        A test/agnostic/vdl/facelets/resource-resolver/src/main/java/com/sun/faces/test/agnostic
        A test/agnostic/vdl/facelets/resource-resolver/src/main/java/com/sun/faces/test/agnostic/vdl
        A test/agnostic/vdl/facelets/resource-resolver/src/main/java/com/sun/faces/test/agnostic/vdl/facelets
        A test/agnostic/vdl/facelets/resource-resolver/src/main/java/com/sun/faces/test/agnostic/vdl/facelets/resource_resolver
        A test/agnostic/vdl/facelets/resource-resolver/src/main/java/com/sun/faces/test/agnostic/vdl/facelets/resource_resolver/TestResolver.java
        A test/agnostic/vdl/facelets/resource-resolver/src/main/resources
        A test/agnostic/vdl/facelets/resource-resolver/src/main/webapp
        A test/agnostic/vdl/facelets/resource-resolver/src/main/webapp/WEB-INF
        A test/agnostic/vdl/facelets/resource-resolver/src/main/webapp/WEB-INF/web.xml
        A test/agnostic/vdl/facelets/resource-resolver/src/main/webapp/WEB-INF/glassfish-web.xml
        A test/agnostic/vdl/facelets/resource-resolver/src/main/webapp/a.xhtml
        A test/agnostic/vdl/facelets/resource-resolver/pom.xml

        • New test
          Sending jsf-demo/sandbox/flow_and_contract/app/pom.xml
          Deleting jsf-demo/sandbox/flow_and_contract/app/src/main/webapp/contracts
          Sending jsf-ri/src/main/java/com/sun/faces/application/view/FaceletViewHandlingStrategy.java
          Sending jsf-ri/src/main/java/com/sun/faces/facelets/impl/DefaultFaceletFactory.java
          Sending jsf-ri/src/main/java/com/sun/faces/renderkit/html_basic/OutcomeTargetRenderer.java
          Adding test/agnostic/vdl/facelets/resource-resolver
          Adding test/agnostic/vdl/facelets/resource-resolver/nbactions.xml
          Adding test/agnostic/vdl/facelets/resource-resolver/pom.xml
          Adding test/agnostic/vdl/facelets/resource-resolver/src
          Adding test/agnostic/vdl/facelets/resource-resolver/src/main
          Adding test/agnostic/vdl/facelets/resource-resolver/src/main/java
          Adding test/agnostic/vdl/facelets/resource-resolver/src/main/java/com
          Adding test/agnostic/vdl/facelets/resource-resolver/src/main/java/com/sun
          Adding test/agnostic/vdl/facelets/resource-resolver/src/main/java/com/sun/faces
          Adding test/agnostic/vdl/facelets/resource-resolver/src/main/java/com/sun/faces/test
          Adding test/agnostic/vdl/facelets/resource-resolver/src/main/java/com/sun/faces/test/agnostic
          Adding test/agnostic/vdl/facelets/resource-resolver/src/main/java/com/sun/faces/test/agnostic/vdl
          Adding test/agnostic/vdl/facelets/resource-resolver/src/main/java/com/sun/faces/test/agnostic/vdl/facelets
          Adding test/agnostic/vdl/facelets/resource-resolver/src/main/java/com/sun/faces/test/agnostic/vdl/facelets/resource_resolver
          Adding test/agnostic/vdl/facelets/resource-resolver/src/main/java/com/sun/faces/test/agnostic/vdl/facelets/resource_resolver/TestResolver.java
          Adding test/agnostic/vdl/facelets/resource-resolver/src/main/resources
          Adding test/agnostic/vdl/facelets/resource-resolver/src/main/webapp
          Adding test/agnostic/vdl/facelets/resource-resolver/src/main/webapp/WEB-INF
          Adding test/agnostic/vdl/facelets/resource-resolver/src/main/webapp/WEB-INF/glassfish-web.xml
          Adding test/agnostic/vdl/facelets/resource-resolver/src/main/webapp/WEB-INF/web.xml
          Adding test/agnostic/vdl/facelets/resource-resolver/src/main/webapp/a.xhtml
          Adding test/agnostic/vdl/facelets/resource-resolver/src/test
          Adding test/agnostic/vdl/facelets/resource-resolver/src/test/java
          Adding test/agnostic/vdl/facelets/resource-resolver/src/test/java/com
          Adding test/agnostic/vdl/facelets/resource-resolver/src/test/java/com/sun
          Adding test/agnostic/vdl/facelets/resource-resolver/src/test/java/com/sun/faces
          Adding test/agnostic/vdl/facelets/resource-resolver/src/test/java/com/sun/faces/test
          Adding test/agnostic/vdl/facelets/resource-resolver/src/test/java/com/sun/faces/test/agnostic
          Adding test/agnostic/vdl/facelets/resource-resolver/src/test/java/com/sun/faces/test/agnostic/vdl
          Adding test/agnostic/vdl/facelets/resource-resolver/src/test/java/com/sun/faces/test/agnostic/vdl/facelets
          Adding test/agnostic/vdl/facelets/resource-resolver/src/test/java/com/sun/faces/test/agnostic/vdl/facelets/resource_resolver
          Adding test/agnostic/vdl/facelets/resource-resolver/src/test/java/com/sun/faces/test/agnostic/vdl/facelets/resource_resolver/VerifyResourceResolverUsageIT.java
          Transmitting file data ...........
          Committed revision 11850.

        SECTION: Modified Files
        ----------------------------
        M jsf-ri/src/main/java/com/sun/faces/application/view/FaceletViewHandlingStrategy.java

        • Found by jsp-flash systest-per-webapp.

        Sending jsf-ri/src/main/java/com/sun/faces/application/view/FaceletViewHandlingStrategy.java
        Transmitting file data .
        Committed revision 11851.


          People

          • Assignee:
            Ed Burns
            Reporter:
            marfous
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - Not Specified
              Not Specified
              Remaining:
              Remaining Estimate - 0 minutes
              0m
              Logged:
              Time Spent - 2 hours, 39 minutes
              2h 39m