Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 4.0_b84_RC1
    • Fix Version/s: 4.0_b85
    • Component/s: bean-validator
    • Labels:
      None

      Description

      In build 83, online help works fine.
      In build 84, none of the help pages *.html is included in the console jars. eg console-common.jar, console-ejb-plugin.jar ...

      This means OLH is completely broken.
      Not sure if this is a build issue or not. Assign to doc now, if nothing is changed by the doc team, he can reassign to Romain for a look.

        Activity

        Mike Fitch added a comment -

        The last change to main-docs was svn revision 61142. It was used to build version 4.0-b27 of main-docs.

        There have been no changes to main-docs since.

        GlassFish was updated to start picking up version 4.0-b27 of main-docs in svn revision 61152. The April 5, 2013 nightly build demonstrates successful incorporation and display of main-docs 4.0-b27 in GlassFish. You can pick up this build here: http://dlc.sun.com.edgesuite.net/glassfish/4.0/nightly/glassfish-4.0-b84-04_05_2013.zip.

        Since this past build was working and there have been no changes to main-docs since, this issue must in some way related to GlassFish product build. Therefore, I am setting the Component to build_system and assigning the issue to Romain.

        Romain Grécourt added a comment -

        This is actually because claire duplicated the plugin element for maven-dependency-plugin, which resulted into no unpacking of OLH zip artifacts.
        See: Index: ../pom.xml
        ===================================================================
        — ../pom.xml (revision 61196)
        +++ ../pom.xml (revision 61197)
        @@ -156,6 +156,23 @@
        </execution>
        </executions>
        </plugin>
        + <plugin>
        + <groupId>org.apache.maven.plugins</groupId>
        + <artifactId>maven-dependency-plugin</artifactId>
        + <executions>
        + <execution>
        + <id>unpack-dependencies</id>
        + <goals>
        + <goal>unpack-dependencies</goal>
        + </goals>
        + <configuration>
        + <includeGroupIds>org.glassfish.docs-l10n.help-l10n</includeGroupIds>
        + <excludeTransitive>true</excludeTransitive>
        + <outputDirectory>$

        {project.build.outputDirectory}

        </outputDirectory>
        + </configuration>
        + </execution>
        + </executions>
        + </plugin>
        </plugins>
        </build>

        Log message:

        Log Message:
        ------------
        GLASSFISH-18266 - incorporate the localized version of on-line help and man pages into Glassfish workspace

        Romain Grécourt added a comment -
        • What is the impact on the customer of the bug?
          No online hep available

        How likely is it that a customer will see the bug and how serious is the bug?
        Very serious, customer will see it every time.

        Is it a regression? Does it meet other bug fix criteria (security, performance, etc.)?
        Yes, regression.

        What CTS failures are caused by this bug?
        None. this is OLH / l10n issue

        • What is the cost/risk of fixing the bug?
          low.

        How risky is the fix? How much work is the fix? Is the fix complicated?
        a few lines in a parent pom, very easy.

        • Is there an impact on documentation or message strings?
          Yes, no OLH
        • Which tests should QA (re)run to verify the fix did not destabilize GlassFish?
          None.
        • Which is the targeted build of 4.0 for this fix?
          b85
        • If this an integration of a new version of a component from another project,
          what are the changes that are being brought in? This might be list of
          Jira issues from that project or a list of revision messages.
        Romain Grécourt added a comment - - edited

        changes:

        Index: appserver/admingui/pom.xml
        ===================================================================
        --- appserver/admingui/pom.xml	(revision 61436)
        +++ appserver/admingui/pom.xml	(working copy)
        @@ -149,52 +149,15 @@
                           <goal>unpack-dependencies</goal>
                         </goals>
                         <configuration>
        -                  <includeGroupIds>org.glassfish.docs.help</includeGroupIds>
        +                  <includeGroupIds>org.glassfish.docs.help,org.glassfish.docs-l10n.help-l10n</includeGroupIds>
                           <excludeTransitive>true</excludeTransitive>
                           <outputDirectory>${project.build.outputDirectory}</outputDirectory>
                         </configuration>
                       </execution>
                     </executions>
                   </plugin>
        -          <plugin>
        -            <groupId>org.apache.maven.plugins</groupId>
        -            <artifactId>maven-dependency-plugin</artifactId>
        -            <executions>
        -              <execution>
        -                <id>unpack-dependencies</id>
        -                <goals>
        -                  <goal>unpack-dependencies</goal>
        -                </goals>
        -                <configuration>
        -                  <includeGroupIds>org.glassfish.docs-l10n.help-l10n</includeGroupIds>
        -                  <excludeTransitive>true</excludeTransitive>
        -                  <outputDirectory>${project.build.outputDirectory}</outputDirectory>
        -                </configuration>
        -              </execution>
        -            </executions>
        -          </plugin>
                 </plugins>
               </build>
        -<!--
        -    <build>
        -        <plugins>
        -            <plugin>
        -                <groupId>org.glassfish.hk2</groupId>
        -                <artifactId>hk2-maven-plugin</artifactId>
        -                <configuration>
        -                    <processors>
        -                        <processor>
        -                            <groupId>com.sun.jsftemplating</groupId>
        -                            <artifactId>jsftemplating-dt</artifactId>
        -                            <version>${jsftemplating.version}</version>
        -                        </processor>
        -                    </processors>
        -                </configuration>
        -                <extensions>true</extensions>
        -            </plugin>
        -        </plugins>
        -    </build>
        - -->
         
             <dependencies>
                 <dependency>
        
        Tom Mueller added a comment -

        Approved for 4.0.

        Romain Grécourt added a comment -

        fix with svn rev #61438


          People

          • Assignee:
            Romain Grécourt
            Reporter:
            Anissa Lam
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: