glassfish
  1. glassfish
  2. GLASSFISH-20305

Deployment module, deploy any (war or ear) with invalid content structure.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Invalid
    • Affects Version/s: 4.0_b84_RC1
    • Fix Version/s: None
    • Component/s: web_container
    • Labels:
      None
    • Environment:

      Windows 7 SP1 x64 bit
      Mac OS X 10.8.3
      Glassfish v4_b84

      Description

      I have zipped a file.pdf as war file, and deploy it through the admin console and the result was:

      It successfully deployed the application.

      whilst the war file contains an invalid contents structure, more precisely the deployment module doesn't check the war file contents structure, and in this case it should deny the deployment of invalid war files.

        Activity

        Jeremy_Lv added a comment -

        Mohamed:
        Could you clarify about this phenomenon?(pl. list your contents structure, or send the test mail to me, my mail address is lvsongping@cn.fujitsu.com .) I have tried to compress the pdf file into a war file and deployed it through the admin console and the results seems as follows

        remote failure: Error during authorization
        java.lang.RuntimeException: java.lang.IllegalArgumentException: MALFORMED
        Command deploy failed.
        

        Here's server.log:

        [2013-04-15T09:41:28.600+0900] [glassfish 4.0] [SEVERE] [NCLS-ADMIN-00011] [javax.enterprise.system.tools.admin.security.authorization] [tid: _ThreadID=34 _ThreadName=admin-listener(1)] [timeMillis: 1365986488600] [levelValue: 1000] [[
          An unexpected exception occurred.
        java.lang.RuntimeException: java.lang.IllegalArgumentException: MALFORMED
        	at org.glassfish.deployment.admin.DeployCommand.preAuthorization(DeployCommand.java:314)
        	at com.sun.enterprise.admin.util.CommandSecurityChecker$1.run(CommandSecurityChecker.java:184)
        	at com.sun.enterprise.admin.util.CommandSecurityChecker$1.run(CommandSecurityChecker.java:180)
        	at java.security.AccessController.doPrivileged(Native Method)
        	at javax.security.auth.Subject.doAs(Subject.java:356)
        	at com.sun.enterprise.admin.util.CommandSecurityChecker.authorize(CommandSecurityChecker.java:180)
        	at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:1203)
        	at com.sun.enterprise.v3.admin.CommandRunnerImpl.access$1500(CommandRunnerImpl.java:108)
        	at com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java:1762)
        	at com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java:1674)
        	at org.glassfish.admin.rest.resources.admin.CommandResource.executeCommand(CommandResource.java:396)
        	at org.glassfish.admin.rest.resources.admin.CommandResource.execCommandSimpInMultOut(CommandResource.java:234)
        	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        	at java.lang.reflect.Method.invoke(Method.java:601)
        	at org.glassfish.jersey.server.model.internal.ResourceMethodInvocationHandlerFactory$1.invoke(ResourceMethodInvocationHandlerFactory.java:81)
        	at org.glassfish.jersey.server.model.internal.AbstractJavaResourceMethodDispatcher.invoke(AbstractJavaResourceMethodDispatcher.java:125)
        	at org.glassfish.jersey.server.model.internal.JavaResourceMethodDispatcherProvider$ResponseOutInvoker.doDispatch(JavaResourceMethodDispatcherProvider.java:152)
        	at org.glassfish.jersey.server.model.internal.AbstractJavaResourceMethodDispatcher.dispatch(AbstractJavaResourceMethodDispatcher.java:91)
        	at org.glassfish.jersey.server.model.ResourceMethodInvoker.invoke(ResourceMethodInvoker.java:346)
        	at org.glassfish.jersey.server.model.ResourceMethodInvoker.apply(ResourceMethodInvoker.java:341)
        	at org.glassfish.jersey.server.model.ResourceMethodInvoker.apply(ResourceMethodInvoker.java:101)
        	at org.glassfish.jersey.server.ServerRuntime$1.run(ServerRuntime.java:217)
        	at org.glassfish.jersey.internal.Errors$1.call(Errors.java:231)
        	at org.glassfish.jersey.internal.Errors$1.call(Errors.java:227)
        	at org.glassfish.jersey.internal.Errors.process(Errors.java:275)
        	at org.glassfish.jersey.internal.Errors.process(Errors.java:257)
        	at org.glassfish.jersey.internal.Errors.process(Errors.java:227)
        	at org.glassfish.jersey.process.internal.RequestScope.runInScope(RequestScope.java:317)
        	at org.glassfish.jersey.server.ServerRuntime.process(ServerRuntime.java:191)
        	at org.glassfish.jersey.server.ApplicationHandler.handle(ApplicationHandler.java:819)
        	at org.glassfish.jersey.grizzly2.httpserver.GrizzlyHttpContainer.service(GrizzlyHttpContainer.java:325)
        	at org.glassfish.admin.rest.adapter.JerseyContainerCommandService$3.service(JerseyContainerCommandService.java:161)
        	at org.glassfish.admin.rest.adapter.RestAdapter.service(RestAdapter.java:181)
        	at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:246)
        	at org.glassfish.grizzly.http.server.HttpHandler.runService(HttpHandler.java:191)
        	at org.glassfish.grizzly.http.server.HttpHandler.doHandle(HttpHandler.java:168)
        	at org.glassfish.grizzly.http.server.HttpServerFilter.handleRead(HttpServerFilter.java:189)
        	at org.glassfish.grizzly.filterchain.ExecutorResolver$9.execute(ExecutorResolver.java:119)
        	at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeFilter(DefaultFilterChain.java:288)
        	at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeChainPart(DefaultFilterChain.java:206)
        	at org.glassfish.grizzly.filterchain.DefaultFilterChain.execute(DefaultFilterChain.java:136)
        	at org.glassfish.grizzly.filterchain.DefaultFilterChain.process(DefaultFilterChain.java:114)
        	at org.glassfish.grizzly.ProcessorExecutor.execute(ProcessorExecutor.java:77)
        	at org.glassfish.grizzly.nio.transport.TCPNIOTransport.fireIOEvent(TCPNIOTransport.java:838)
        	at org.glassfish.grizzly.strategies.AbstractIOStrategy.fireIOEvent(AbstractIOStrategy.java:113)
        	at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.run0(WorkerThreadIOStrategy.java:115)
        	at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.access$100(WorkerThreadIOStrategy.java:55)
        	at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy$WorkerThreadRunnable.run(WorkerThreadIOStrategy.java:135)
        	at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:564)
        	at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.run(AbstractThreadPool.java:544)
        	at java.lang.Thread.run(Thread.java:722)
        Caused by: java.lang.IllegalArgumentException: MALFORMED
        	at java.util.zip.ZipCoder.toString(ZipCoder.java:58)
        	at java.util.zip.ZipFile.getZipEntry(ZipFile.java:529)
        	at java.util.zip.ZipFile.access$900(ZipFile.java:56)
        	at java.util.zip.ZipFile$1.nextElement(ZipFile.java:511)
        	at java.util.zip.ZipFile$1.nextElement(ZipFile.java:481)
        	at java.util.jar.JarFile$1.nextElement(JarFile.java:242)
        	at java.util.jar.JarFile$1.nextElement(JarFile.java:237)
        	at com.sun.enterprise.deployment.deploy.shared.InputJarArchive$ArchiveJarEntrySource.getNextJarEntry(InputJarArchive.java:587)
        	at com.sun.enterprise.deployment.deploy.shared.InputJarArchive$EntryEnumeration.getNextJarEntry(InputJarArchive.java:513)
        	at com.sun.enterprise.deployment.deploy.shared.InputJarArchive$TopLevelDirectoryEntryEnumeration.skipToNextMatchingEntry(InputJarArchive.java:643)
        	at com.sun.enterprise.deployment.deploy.shared.InputJarArchive$EntryEnumeration.completeInit(InputJarArchive.java:494)
        	at com.sun.enterprise.deployment.deploy.shared.InputJarArchive$TopLevelDirectoryEntryEnumeration.<init>(InputJarArchive.java:630)
        	at com.sun.enterprise.deployment.deploy.shared.InputJarArchive$TopLevelDirectoryEntryEnumeration.<init>(InputJarArchive.java:626)
        	at com.sun.enterprise.deployment.deploy.shared.InputJarArchive.createEntryEnumeration(InputJarArchive.java:456)
        	at com.sun.enterprise.deployment.deploy.shared.InputJarArchive.entries(InputJarArchive.java:203)
        	at com.sun.enterprise.deployment.deploy.shared.InputJarArchive.access$100(InputJarArchive.java:74)
        	at com.sun.enterprise.deployment.deploy.shared.InputJarArchive$1.enumeration(InputJarArchive.java:166)
        	at com.sun.enterprise.deployment.deploy.shared.InputJarArchive$CollectionWrappedEnumeration.<init>(InputJarArchive.java:725)
        	at com.sun.enterprise.deployment.deploy.shared.InputJarArchive.getDirectories(InputJarArchive.java:161)
        	at org.glassfish.javaee.full.deployment.EarDetector.isEARFromIntrospecting(EarDetector.java:142)
        	at org.glassfish.javaee.full.deployment.EarDetector.handles(EarDetector.java:110)
        	at com.sun.enterprise.v3.server.ApplicationLifecycle.getArchiveHandler(ApplicationLifecycle.java:211)
        	at org.glassfish.deployment.admin.DeployCommand.preAuthorization(DeployCommand.java:246)
        	... 52 more
        ]]
        
        Mohamed Taman added a comment -

        Hi Jeremy,

        I have sent you an email with title "(GLASSFISH-20305) Deployment module, deploy any (war or ear) with invalid content structure. uploaded documents"
        that contains all screenshots of correctly deployed application and the wrong war file as well that was deployed.

        Note That this issue happened when deploying the application from admin console and putting the war file in the auto deployment folder.

        Here is the log file

        [2013-04-15T12:18:45.868+0200] [glassfish 4.0] [INFO] [] [org.glassfish.admingui] [tid: _ThreadID=125 _ThreadName=admin-listener(6)] [timeMillis: 1366021125868] [levelValue: 800] [[
          GUI deployment: uploadToTempfile]]
        
        [2013-04-15T12:18:45.884+0200] [glassfish 4.0] [INFO] [] [org.glassfish.admingui] [tid: _ThreadID=125 _ThreadName=admin-listener(6)] [timeMillis: 1366021125884] [levelValue: 800] [[
          uploadFileName=FileToUpload.war]]
        
        [2013-04-15T12:18:46.092+0200] [glassfish 4.0] [INFO] [] [javax.enterprise.system.tools.deployment.common] [tid: _ThreadID=128 _ThreadName=admin-listener(8)] [timeMillis: 1366021126092] [levelValue: 800] [[
          visiting unvisited references]]
        
        [2013-04-15T12:18:46.102+0200] [glassfish 4.0] [INFO] [] [javax.enterprise.system.tools.deployment.common] [tid: _ThreadID=128 _ThreadName=admin-listener(8)] [timeMillis: 1366021126102] [levelValue: 800] [[
          visiting unvisited references]]
        
        [2013-04-15T12:18:46.103+0200] [glassfish 4.0] [INFO] [] [javax.enterprise.system.tools.deployment.common] [tid: _ThreadID=128 _ThreadName=admin-listener(8)] [timeMillis: 1366021126103] [levelValue: 800] [[
          visiting unvisited references]]
        
        [2013-04-15T12:18:46.212+0200] [glassfish 4.0] [INFO] [AS-WEB-GLUE-00172] [javax.enterprise.web] [tid: _ThreadID=128 _ThreadName=admin-listener(8)] [timeMillis: 1366021126212] [levelValue: 800] [[
          Loading application [FileToUpload] at [/FileToUpload]]]
        
        [2013-04-15T12:18:46.262+0200] [glassfish 4.0] [INFO] [] [javax.enterprise.system.core] [tid: _ThreadID=128 _ThreadName=admin-listener(8)] [timeMillis: 1366021126262] [levelValue: 800] [[
          FileToUpload was successfully deployed in 271 milliseconds.]]
        
        [2013-04-15T12:21:43.009+0200] [glassfish 4.0] [INFO] [] [] [tid: _ThreadID=128 _ThreadName=Thread-3] [timeMillis: 1366021303009] [levelValue: 800] [[
          com.sun.webui.jsf.component.DropDown::The current value of component propertyForm:deployTable:topActionsGroup1:filter does not match any of the selections. 
        Did you forget to reset the value after changing the options?]]
        
        [2013-04-15T12:22:10.247+0200] [glassfish 4.0] [INFO] [NCLS-DEPLOYMENT-00027] [javax.enterprise.system.tools.deployment.autodeploy] [tid: _ThreadID=55 _ThreadName=AutoDeployer] [timeMillis: 1366021330247] [levelValue: 800] [[
          Selecting file E:\Utilities\Glassfish_v4\glassfish\domains\domain1\autodeploy\FileToUpload.war for autodeployment]]
        
        [2013-04-15T12:22:10.307+0200] [glassfish 4.0] [INFO] [] [javax.enterprise.system.tools.deployment.common] [tid: _ThreadID=55 _ThreadName=AutoDeployer] [timeMillis: 1366021330307] [levelValue: 800] [[
          visiting unvisited references]]
        
        [2013-04-15T12:22:10.314+0200] [glassfish 4.0] [INFO] [] [javax.enterprise.system.tools.deployment.common] [tid: _ThreadID=55 _ThreadName=AutoDeployer] [timeMillis: 1366021330314] [levelValue: 800] [[
          visiting unvisited references]]
        
        [2013-04-15T12:22:10.316+0200] [glassfish 4.0] [INFO] [] [javax.enterprise.system.tools.deployment.common] [tid: _ThreadID=55 _ThreadName=AutoDeployer] [timeMillis: 1366021330316] [levelValue: 800] [[
          visiting unvisited references]]
        
        [2013-04-15T12:22:10.398+0200] [glassfish 4.0] [INFO] [AS-WEB-GLUE-00172] [javax.enterprise.web] [tid: _ThreadID=55 _ThreadName=AutoDeployer] [timeMillis: 1366021330398] [levelValue: 800] [[
          Loading application [FileToUpload] at [/FileToUpload]]]
        
        [2013-04-15T12:22:10.417+0200] [glassfish 4.0] [INFO] [] [javax.enterprise.system.core] [tid: _ThreadID=55 _ThreadName=AutoDeployer] [timeMillis: 1366021330417] [levelValue: 800] [[
          FileToUpload was successfully deployed in 129 milliseconds.]]
        
        [2013-04-15T12:22:10.420+0200] [glassfish 4.0] [INFO] [NCLS-DEPLOYMENT-00035] [javax.enterprise.system.tools.deployment.autodeploy] [tid: _ThreadID=55 _ThreadName=AutoDeployer] [timeMillis: 1366021330420] [levelValue: 800] [[
          [AutoDeploy] Successfully autodeployed : E:\Utilities\Glassfish_v4\glassfish\domains\domain1\autodeploy\FileToUpload.war.]]
        
        
        Hong Zhang added a comment -

        Can you please send me the "war" application you tried to deploy (it is a hassle that we could not attach the application to the issue tracker)? Note, if your application is named with suffix ".war", the deployment infrastructure will deploy the archive as a web archive (based on the EE spec) and hand off to the web container to load web components. As it's possible for a web application to just contain static contents like .jsp, .html, I don't think the web container does any validation against negative contents.

        Jeremy_Lv added a comment -

        Hong:
        I have just send the application to you.

        Hong Zhang added a comment -

        Thanks Jeremy.

        The war file just contains a .txt file at root directory. As I mentioned earlier, the deployment infrastructure sees the .war suffix and deploys it as a web archive based on the spec. And I don't think web container does not any check for negative static contents as a web application can contain all kinds of static contents. But I will let web team check if there is any validation we want to do here..

        Shing Wai Chan added a comment -

        In the given war file, we have the following:
        jar tvf FileToUpload.war
        13 Mon Apr 15 12:10:54 PDT 2013 FileToUpload.txt

        This is a valid war file structure.


          People

          • Assignee:
            Shing Wai Chan
            Reporter:
            Mohamed Taman
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: