glassfish
  1. glassfish
  2. GLASSFISH-20306

Server monitoring module throws "java.lang.NullPointerException" in the log.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0_b84_RC1
    • Fix Version/s: 4.0_b85
    • Component/s: monitoring
    • Labels:
      None
    • Environment:

      Windows 7 SP1 x64 bit
      Mac OS X 10.8.3
      Glassfish v4_b84

      Description

      Reproduce Scenario:

      1. From admin console --> common tasks --> choose server (Admin Server) node.
      2. From right pan --> choose Monitor.
      3. Choose any other child buttons as (Application, Server, or resources).
      4. Check server.log and you will see the following errors:

        [2013-04-13T03:00:11.945+0200] [glassfish 4.0] [INFO] [NCLS-REST-00003] [javax.enterprise.admin.rest] 
        [tid: _ThreadID=34 _ThreadName=admin-listener(1)] [timeMillis: 1365814811945] [levelValue: 800] 
        [[
          An error occurred while processing the request. Please see the server logs for details.
        java.lang.NullPointerException
        	at org.glassfish.admin.rest.resources.MonitoringResource.getChildNodes(MonitoringResource.java:131)
        	at sun.reflect.GeneratedMethodAccessor327.invoke(Unknown Source)
        	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        	at java.lang.reflect.Method.invoke(Method.java:601)
        	at org.glassfish.jersey.server.model.internal.ResourceMethodInvocationHandlerFactory$1.invoke(ResourceMethodInvocationHandlerFactory.java:81)
        	at org.glassfish.jersey.server.model.internal.AbstractJavaResourceMethodDispatcher.invoke(AbstractJavaResourceMethodDispatcher.java:125)
        	at org.glassfish.jersey.server.model.internal.JavaResourceMethodDispatcherProvider$ResponseOutInvoker.doDispatch(JavaResourceMethodDispatcherProvider.java:152)
        	at org.glassfish.jersey.server.model.internal.AbstractJavaResourceMethodDispatcher.dispatch(AbstractJavaResourceMethodDispatcher.java:91)
        	at org.glassfish.jersey.server.model.ResourceMethodInvoker.invoke(ResourceMethodInvoker.java:346)
        	at org.glassfish.jersey.server.model.ResourceMethodInvoker.apply(ResourceMethodInvoker.java:341)
        	at org.glassfish.jersey.server.model.ResourceMethodInvoker.apply(ResourceMethodInvoker.java:101)
        	at org.glassfish.jersey.server.ServerRuntime$1.run(ServerRuntime.java:217)
        	at org.glassfish.jersey.internal.Errors$1.call(Errors.java:231)
        	at org.glassfish.jersey.internal.Errors$1.call(Errors.java:227)
        	at org.glassfish.jersey.internal.Errors.process(Errors.java:275)
        	at org.glassfish.jersey.internal.Errors.process(Errors.java:257)
        	at org.glassfish.jersey.internal.Errors.process(Errors.java:227)
        	at org.glassfish.jersey.process.internal.RequestScope.runInScope(RequestScope.java:317)
        	at org.glassfish.jersey.server.ServerRuntime.process(ServerRuntime.java:191)
        	at org.glassfish.jersey.server.ApplicationHandler.handle(ApplicationHandler.java:819)
        	at org.glassfish.jersey.grizzly2.httpserver.GrizzlyHttpContainer.service(GrizzlyHttpContainer.java:325)
        	at org.glassfish.admin.rest.adapter.RestAdapter$2.service(RestAdapter.java:318)
        	at org.glassfish.admin.rest.adapter.RestAdapter.service(RestAdapter.java:181)
        	at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:246)
        	at org.glassfish.grizzly.http.server.HttpHandler.runService(HttpHandler.java:191)
        	at org.glassfish.grizzly.http.server.HttpHandler.doHandle(HttpHandler.java:168)
        	at org.glassfish.grizzly.http.server.HttpServerFilter.handleRead(HttpServerFilter.java:189)
        	at org.glassfish.grizzly.filterchain.ExecutorResolver$9.execute(ExecutorResolver.java:119)
        	at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeFilter(DefaultFilterChain.java:288)
        	at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeChainPart(DefaultFilterChain.java:206)
        	at org.glassfish.grizzly.filterchain.DefaultFilterChain.execute(DefaultFilterChain.java:136)
        	at org.glassfish.grizzly.filterchain.DefaultFilterChain.process(DefaultFilterChain.java:114)
        	at org.glassfish.grizzly.ProcessorExecutor.execute(ProcessorExecutor.java:77)
        	at org.glassfish.grizzly.nio.transport.TCPNIOTransport.fireIOEvent(TCPNIOTransport.java:838)
        	at org.glassfish.grizzly.strategies.AbstractIOStrategy.fireIOEvent(AbstractIOStrategy.java:113)
        	at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.run0(WorkerThreadIOStrategy.java:115)
        	at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.access$100(WorkerThreadIOStrategy.java:55)
        	at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy$WorkerThreadRunnable.run(WorkerThreadIOStrategy.java:135)
        	at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:564)
        	at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.run(AbstractThreadPool.java:544)
        	at java.lang.Thread.run(Thread.java:722)
        ]]
        
        [2013-04-13T03:00:11.967+0200] [glassfish 4.0] [INFO] [NCLS-REST-00003] [javax.enterprise.admin.rest] 
        [tid: _ThreadID=37 _ThreadName=admin-listener(4)] [timeMillis: 1365814811967] [levelValue: 800] 
        [[
          An error occurred while processing the request. Please see the server logs for details.
        java.lang.NullPointerException
        	at org.glassfish.admin.rest.resources.MonitoringResource.getChildNodes(MonitoringResource.java:131)
        	at sun.reflect.GeneratedMethodAccessor327.invoke(Unknown Source)
        	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        	at java.lang.reflect.Method.invoke(Method.java:601)
        	at org.glassfish.jersey.server.model.internal.ResourceMethodInvocationHandlerFactory$1.invoke(ResourceMethodInvocationHandlerFactory.java:81)
        	at org.glassfish.jersey.server.model.internal.AbstractJavaResourceMethodDispatcher.invoke(AbstractJavaResourceMethodDispatcher.java:125)
        	at org.glassfish.jersey.server.model.internal.JavaResourceMethodDispatcherProvider$ResponseOutInvoker.doDispatch(JavaResourceMethodDispatcherProvider.java:152)
        	at org.glassfish.jersey.server.model.internal.AbstractJavaResourceMethodDispatcher.dispatch(AbstractJavaResourceMethodDispatcher.java:91)
        	at org.glassfish.jersey.server.model.ResourceMethodInvoker.invoke(ResourceMethodInvoker.java:346)
        	at org.glassfish.jersey.server.model.ResourceMethodInvoker.apply(ResourceMethodInvoker.java:341)
        	at org.glassfish.jersey.server.model.ResourceMethodInvoker.apply(ResourceMethodInvoker.java:101)
        	at org.glassfish.jersey.server.ServerRuntime$1.run(ServerRuntime.java:217)
        	at org.glassfish.jersey.internal.Errors$1.call(Errors.java:231)
        	at org.glassfish.jersey.internal.Errors$1.call(Errors.java:227)
        	at org.glassfish.jersey.internal.Errors.process(Errors.java:275)
        	at org.glassfish.jersey.internal.Errors.process(Errors.java:257)
        	at org.glassfish.jersey.internal.Errors.process(Errors.java:227)
        	at org.glassfish.jersey.process.internal.RequestScope.runInScope(RequestScope.java:317)
        	at org.glassfish.jersey.server.ServerRuntime.process(ServerRuntime.java:191)
        	at org.glassfish.jersey.server.ApplicationHandler.handle(ApplicationHandler.java:819)
        	at org.glassfish.jersey.grizzly2.httpserver.GrizzlyHttpContainer.service(GrizzlyHttpContainer.java:325)
        	at org.glassfish.admin.rest.adapter.RestAdapter$2.service(RestAdapter.java:318)
        	at org.glassfish.admin.rest.adapter.RestAdapter.service(RestAdapter.java:181)
        	at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:246)
        	at org.glassfish.grizzly.http.server.HttpHandler.runService(HttpHandler.java:191)
        	at org.glassfish.grizzly.http.server.HttpHandler.doHandle(HttpHandler.java:168)
        	at org.glassfish.grizzly.http.server.HttpServerFilter.handleRead(HttpServerFilter.java:189)
        	at org.glassfish.grizzly.filterchain.ExecutorResolver$9.execute(ExecutorResolver.java:119)
        	at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeFilter(DefaultFilterChain.java:288)
        	at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeChainPart(DefaultFilterChain.java:206)
        	at org.glassfish.grizzly.filterchain.DefaultFilterChain.execute(DefaultFilterChain.java:136)
        	at org.glassfish.grizzly.filterchain.DefaultFilterChain.process(DefaultFilterChain.java:114)
        	at org.glassfish.grizzly.ProcessorExecutor.execute(ProcessorExecutor.java:77)
        	at org.glassfish.grizzly.nio.transport.TCPNIOTransport.fireIOEvent(TCPNIOTransport.java:838)
        	at org.glassfish.grizzly.strategies.AbstractIOStrategy.fireIOEvent(AbstractIOStrategy.java:113)
        	at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.run0(WorkerThreadIOStrategy.java:115)
        	at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.access$100(WorkerThreadIOStrategy.java:55)
        	at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy$WorkerThreadRunnable.run(WorkerThreadIOStrategy.java:135)
        	at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:564)
        	at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.run(AbstractThreadPool.java:544)
        	at java.lang.Thread.run(Thread.java:722)
        ]]
        ..................
        

        Activity

        Tom Mueller added a comment -
        • What is the impact on the customer of the bug?

        How likely is it that a customer will see the bug and how serious is the bug?
        Is it a regression? Does it meet other bug fix criteria (security, performance, etc.)?
        What CTS failures are caused by this bug?

        This is a regression caused by a previous performance fix to the MonitoringBootstrap service.

        • What is the cost/risk of fixing the bug?

        How risky is the fix? How much work is the fix? Is the fix complicated?

        Low cost, low risk. Just adding a null check in one place.

        • Is there an impact on documentation or message strings?
          No
        • Which tests should QA (re)run to verify the fix did not destabilize GlassFish?
          Tests that access the monitoring feature of the console.
        • Which is the targeted build of 4.0 for this fix?
          b85.
        • If this an integration of a new version of a component from another project,
          what are the changes that are being brought in? This might be list of
          Jira issues from that project or a list of revision messages.
          N/A
        Tom Mueller added a comment -

        Approved for 4.0.

        Tom Mueller added a comment -

        Fixed in revision 61421.


          People

          • Assignee:
            Tom Mueller
            Reporter:
            Mohamed Taman
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: