glassfish
  1. glassfish
  2. GLASSFISH-20312

com/sun/ts/tests/ejb30/bb/mdb/interceptor/listener/* cts tests are failing when running imq.xml target in CTS.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 4.0_b84_RC1
    • Fix Version/s: 4.0
    • Component/s: cdi
    • Labels:
      None

      Description

      com/sun/ts/tests/ejb30/bb/mdb/interceptor/listener/ CTS tests are failing when run imq.xml target in CTS.

      steps to reproduce the problem:

      1. Download CTS bundle & internal bundle.
      2. Follow the CTS instructions to set the variables.
      3. cd $TS_HOME/bin
      4. Run ant -f imq.xml smoke (this target runs all jms related tests across the CTS bundle).

      Tests results are not consistent.
      com/sun/ts/tests/ejb30/bb/mdb/interceptor/listener/ tests are failing in the test run. Test prints "Fail: we didnt get the expected msg back!" error.

        Activity

        saradak created issue -
        saradak made changes -
        Field Original Value New Value
        Description
        com/sun/ts/tests/ejb30/bb/mdb/interceptor/listener/ CTS tests are failing when run imq.xml target in CTS.

        steps to reproduce the problem:

        1. Download CTS bundle & internal bundle.
        2. Follow the CTS instructions to set the variables.
        3. cd $TS_HOME/bin
        4. Run ant -f imq.xml smoke (this target runs all jms related tests across the CTS bundle).

        Tests results are not consistent.
        com/sun/ts/tests/ejb30/bb/mdb/interceptor/listener/ tests are failing in the test run. It doesn't give any error just prints "message not received" error.

        com/sun/ts/tests/ejb30/bb/mdb/interceptor/listener/ CTS tests are failing when run imq.xml target in CTS.

        steps to reproduce the problem:

        1. Download CTS bundle & internal bundle.
        2. Follow the CTS instructions to set the variables.
        3. cd $TS_HOME/bin
        4. Run ant -f imq.xml smoke (this target runs all jms related tests across the CTS bundle).

        Tests results are not consistent.
        com/sun/ts/tests/ejb30/bb/mdb/interceptor/listener/ tests are failing in the test run. Test prints "Fail: we didnt get the expected msg back!" error.
        marina vatkina made changes -
        Assignee marina vatkina [ mvatkina ] David Zhao [ liang.x.zhao ]
        Component/s jms [ 10604 ]
        Component/s ejb_container [ 10596 ]
        David Zhao made changes -
        Assignee David Zhao [ liang.x.zhao ] marina vatkina [ mvatkina ]
        marina vatkina made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Works as designed [ 7 ]
        saradak made changes -
        Resolution Works as designed [ 7 ]
        Status Resolved [ 5 ] Reopened [ 4 ]
        marina vatkina made changes -
        Assignee marina vatkina [ mvatkina ] jjsnyder83 [ jjsnyder83 ]
        Component/s cdi [ 10637 ]
        Component/s jms [ 10604 ]
        jjsnyder83 made changes -
        Assignee jjsnyder83 [ jjsnyder83 ] phil.zampino [ phil.zampino ]
        tlcksnyder made changes -
        Fix Version/s 4.0 [ 10970 ]
        arjavdesai made changes -
        Comment [ We are on waiting on WELD to fix https://issues.jboss.org/browse/WELD-1410. ]
        arjavdesai made changes -
        Status Reopened [ 4 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        phil.zampino made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            phil.zampino
            Reporter:
            saradak
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: