glassfish
  1. glassfish
  2. GLASSFISH-20343

Only required attributes of JMSDestinationDefinition should be required

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Works as designed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: jms
    • Labels:
      None

      Description

      > @Stateless
      > @JMSDestinationDefinitions(

      {@JMSDestinationDefinition(name = "java:global/jms/myQueue", > interfaceName = "javax.jms.Queue") > }

      )
      > public class MessageSender

      { > ... > }

      >
      > fails with the following error:
      >
      > Caused by: javax.resource.NotSupportedException: MQRA:EC:No destination configured in ActivationSpec of MDB

      is a bug as discussed with Bill, Linda, and Nigel.

        Activity

        arungupta created issue -
        David Zhao added a comment -

        Arun,

        Could you please share the reply from Bill, Linda and Nigel with me? I would like to know what's the expected behavior.

        Nigel Deakin added a comment -

        That error message (javax.resource.NotSupportedException: MQRA:EC:No destination configured in ActivationSpec of MDB) means that you're attempting to deploy a MDB but you haven't specified the queue or topic that the you want it to receive the messages from.

        You don't show how your MDB was configured, but if it was configured to use the queue defined by the @JMSDestinationDefinition entry then I would expect to see this error. You need to specify the destinationName property.

        This is the expected behaviour and is not a bug.

        Nigel Deakin made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Works as designed [ 7 ]

          People

          • Assignee:
            David Zhao
            Reporter:
            arungupta
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: