glassfish
  1. glassfish
  2. GLASSFISH-20346

csfFLOWDISCOVERYCDIHELPER registered multiple times causing ambiguous resolution

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.0
    • Component/s: jsf
    • Labels:
      None

      Description

      FlowDiscoveryCDIHelper is both deployed in an explicit bean archive and registered by FlowDiscoveryCDIExtension. This causes the bean to be registered twice which results in the deployment exception.

        Activity

        Manfred Riem added a comment -

        Applied to 2.2.0 branch,

        svn commit -m "Removing unnecessary beans.xml file, which will prevent double registration of the csfFLOWDISCOVERYCDIHELPER"
        Deleting share\beans.xml

        Committed revision 11888.

        Ed Burns added a comment -
        • What is the impact on the customer of the bug?

        A customer is seeing this bug when running Mojarra in JBoss AS. The impact is that apps fail to deploy.

        • What CTS failures are caused by this bug?

        No known.

        • What is the cost/risk of fixing the bug?

        Cost: remove beans.xml from javax.faces.jar. Risk: destabilize weld integration.

        • Is there an impact on documentation or message strings?

        No.

        • Which tests should QA (re)run to verify the fix did not destabilize GlassFish?

        Tests that show weld working with JSF.

        • Which is the targeted build of 4.0 for this fix?

        b86.

        • If this an integration of a new version of a component from another project,
          what are the changes that are being brought in? This might be list of
          Jira issues from that project or a list of revision messages.
        Tom Mueller added a comment -

        Approved for 4.0.

        Ed Burns added a comment -

        This will be in 2.2.0-m15, due for integration on Monday 29 April 2013.

        Manfred Riem added a comment -

        Verified the tests are all still passing.


          People

          • Assignee:
            Manfred Riem
            Reporter:
            Jozef Hartinger
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: