glassfish
  1. glassfish
  2. GLASSFISH-20356

JPA remote SLSB tests failed with CDI enabled

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0_b85
    • Fix Version/s: 4.0_b87_RC3
    • Component/s: entity-persistence
    • Labels:
      None
    • Environment:

      OEL6, JDK1.7.0_10

      Description

      JPA remote SLSB tests failed with CDI enabled
      glassfish-4.0-b85.zip
      appserver-sqe/pe/ejb/ejb30/issue/1153/basic
      Testing EJB3 Issue 1153
      appserver-sqe/pe/ejb/ejb30/issue/1251
      Testing EJB 3.0 Issue 1251 Multiple PUs

      Tests failed on b85 promoted, but passed on b84 promoted.

      Thanks Mitesh for the initial analysis:
      Injection of EntityManager not happening into a remote SLSB.
      The tests started to fail with nightly of Apr 12 and pass
      after disabling implicit-cdi (using asadmin set configs.config.server-config.cdi-service.enable-implicit-cdi=false).

        Activity

        Mitesh Meswani added a comment -

        Assigning to JJ since this issue is due to enable-implicit-cdi

        tlcksnyder added a comment -

        Exception from 1153 log ftp://adc2120166.us.oracle.com/pub/tmp/appserver-sqe_130418_EJB3_six_test_failure/issue_1153_basic.server.log.txt:
        java.lang.NullPointerException
        at SessionBean.findPerson(SessionBean.java:52)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:601)
        at org.glassfish.ejb.security.application.EJBSecurityManager.runMethod(EJBSecurityManager.java:1081)
        at org.glassfish.ejb.security.application.EJBSecurityManager.invoke(EJBSecurityManager.java:1153)
        at com.sun.ejb.containers.BaseContainer.invokeBeanMethod(BaseContainer.java:4695)
        at com.sun.ejb.EjbInvocation.invokeBeanMethod(EjbInvocation.java:630)
        at com.sun.ejb.containers.interceptors.AroundInvokeChainImpl.invokeNext(InterceptorManager.java:822)
        at com.sun.ejb.EjbInvocation.proceed(EjbInvocation.java:582)
        at org.jboss.weld.ejb.AbstractEJBRequestScopeActivationInterceptor.aroundInvoke(AbstractEJBRequestScopeActivationInterceptor.java:55)
        at sun.reflect.GeneratedMethodAccessor53.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:601)
        at com.sun.ejb.containers.interceptors.AroundInvokeInterceptor.intercept(InterceptorManager.java:883)
        at com.sun.ejb.containers.interceptors.AroundInvokeChainImpl.invokeNext(InterceptorManager.java:822)
        at com.sun.ejb.EjbInvocation.proceed(EjbInvocation.java:582)
        at com.sun.ejb.containers.interceptors.SystemInterceptorProxy.doCall(SystemInterceptorProxy.java:163)
        at com.sun.ejb.containers.interceptors.SystemInterceptorProxy.aroundInvoke(SystemInterceptorProxy.java:140)
        at sun.reflect.GeneratedMethodAccessor85.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:601)
        at com.sun.ejb.containers.interceptors.AroundInvokeInterceptor.intercept(InterceptorManager.java:883)
        at com.sun.ejb.containers.interceptors.AroundInvokeChainImpl.invokeNext(InterceptorManager.java:822)
        at com.sun.ejb.containers.interceptors.InterceptorManager.intercept(InterceptorManager.java:369)
        at com.sun.ejb.containers.BaseContainer.__intercept(BaseContainer.java:4667)
        at com.sun.ejb.containers.BaseContainer.intercept(BaseContainer.java:4655)
        at com.sun.ejb.containers.EJBObjectInvocationHandler.invoke(EJBObjectInvocationHandler.java:205)
        at com.sun.ejb.containers.EJBObjectInvocationHandlerDelegate.invoke(EJBObjectInvocationHandlerDelegate.java:79)
        at $Proxy400.findPerson(Unknown Source)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:601)
        at com.sun.corba.ee.impl.presentation.rmi.ReflectiveTie.dispatchToMethod(ReflectiveTie.java:143)
        at com.sun.corba.ee.impl.presentation.rmi.ReflectiveTie._invoke(ReflectiveTie.java:173)
        at com.sun.corba.ee.impl.protocol.ServerRequestDispatcherImpl.dispatchToServant(ServerRequestDispatcherImpl.java:528)
        at com.sun.corba.ee.impl.protocol.ServerRequestDispatcherImpl.dispatch(ServerRequestDispatcherImpl.java:199)
        at com.sun.corba.ee.impl.protocol.MessageMediatorImpl.handleRequestRequest(MessageMediatorImpl.java:1549)
        at com.sun.corba.ee.impl.protocol.MessageMediatorImpl.handleRequest(MessageMediatorImpl.java:1425)
        at com.sun.corba.ee.impl.protocol.MessageMediatorImpl.handleInput(MessageMediatorImpl.java:930)
        at com.sun.corba.ee.impl.protocol.giopmsgheaders.RequestMessage_1_2.callback(RequestMessage_1_2.java:213)
        at com.sun.corba.ee.impl.protocol.MessageMediatorImpl.handleRequest(MessageMediatorImpl.java:694)
        at com.sun.corba.ee.impl.protocol.MessageMediatorImpl.dispatch(MessageMediatorImpl.java:496)
        at com.sun.corba.ee.impl.protocol.MessageMediatorImpl.doWork(MessageMediatorImpl.java:2222)
        at com.sun.corba.ee.impl.threadpool.ThreadPoolImpl$WorkerThread.performWork(ThreadPoolImpl.java:497)
        at com.sun.corba.ee.impl.threadpool.ThreadPoolImpl$WorkerThread.run(ThreadPoolImpl.java:540)]]

        Exception for 1251 ftp://adc2120166.us.oracle.com/pub/tmp/appserver-sqe_130418_EJB3_six_test_failure/issue_1251_server_log.txt

        jjsnyder83 added a comment -

        Can you provide info on how to download and execute the tests?

        sherryshen added a comment - - edited

        1) To set up test env, please reference the instruction section I, IIa
        http://aseng-wiki.us.oracle.com/asengwiki/display/ASQA/4.0+Core+Test+Instructions
        (use co-ejb instead of co-core to save check out time).

        After check out, do

        $ ant start-domain
        $ ant startDerby

        in $SPS_HOME to start glassfish and derby.

        2) To run test suite, do "ant all" in test suite dir, e.g.
        appserver-sqe/pe/ejb/ejb30/issue/1153/basic
        appserver-sqe/pe/ejb/ejb30/issue/1251

        jjsnyder83 added a comment -

        What is the impact on the customer of the bug?
        EJB's won't work.

        How likely is it that a customer will see the bug and how serious is the bug?
        Is it a regression? Does it meet other bug fix criteria (security, performance, etc.)?
        What CTS failures are caused by this bug?
        The tests listed in this jira.

        What is the cost/risk of fixing the bug?
        N/A

        How risky is the fix? How much work is the fix? Is the fix complicated?
        N/A

        Is there an impact on documentation or message strings?
        No

        Which tests should QA (re)run to verify the fix did not destabilize GlassFish?
        The tests in this jira

        Which is the targeted build of 4.0 for this fix?
        4.0_b86_RC2

        If this an integration of a new version of a component from another project,
        what are the changes that are being brought in? This might be list of
        Jira issues from that project or a list of revision messages.
        N/A

        jjsnyder83 added a comment -

        Committed revision 61664.

        sherryshen added a comment -

        Verified the fix on build 87 promoted on May 1, 2013.


          People

          • Assignee:
            jjsnyder83
            Reporter:
            sherryshen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: