glassfish
  1. glassfish
  2. GLASSFISH-20358

Intermittent issues stopping and starting the server with "java.lang.IllegalStateException: Service already unregistered."

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0_b85
    • Fix Version/s: None
    • Component/s: admin
    • Labels:
      None

      Description

      Web devtests perform many stop/start for functionality testings that require server restart and failing to do so is affecting test results. This intermittent issue is causing multiple failures in web devtests.

      The server fails to shut down with an error "java.lang.IllegalStateException: Service already unregistered." and subsequent restart fails since the shutdown did not happen.

      According to Sahoo, "it will surely impact embeddability of glassfish which is leveraged in cloudlogic and other places".

      [2013-04-25T20:22:24.190-0700] [glassfish 4.0] [INFO] [] [javax.enterprise.system.core] [tid: _ThreadID=63 _ThreadName=Thread-16] [timeMillis: 1366946544190] [levelValue: 800] [[
      Server shutdown initiated]]

      [2013-04-25T20:22:24.191-0700] [glassfish 4.0] [WARNING] [NCLS-BOOTSTRAP-00029] [javax.enterprise.bootstrap] [tid: _ThreadID=63 _ThreadName=Thread-16] [timeMillis: 1366946544191] [levelValue: 900] [[
      Exception while unregistering:
      java.lang.IllegalStateException: Service already unregistered.
      at org.apache.felix.framework.ServiceRegistrationImpl.unregister(ServiceRegistrationImpl.java:123)
      at com.sun.enterprise.glassfish.bootstrap.osgi.EmbeddedOSGiGlassFishImpl.unregisterService(EmbeddedOSGiGlassFishImpl.java:93)
      at com.sun.enterprise.glassfish.bootstrap.osgi.EmbeddedOSGiGlassFishImpl.stop(EmbeddedOSGiGlassFishImpl.java:81)
      at com.sun.enterprise.v3.admin.StopServer.doExecute(StopServer.java:79)
      at com.sun.enterprise.v3.admin.StopDomainCommand.execute(StopDomainCommand.java:96)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl$2$1.run(CommandRunnerImpl.java:527)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl$2$1.run(CommandRunnerImpl.java:523)
      at java.security.AccessController.doPrivileged(Native Method)
      at javax.security.auth.Subject.doAs(Subject.java:356)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl$2.execute(CommandRunnerImpl.java:522)
      at org.glassfish.api.AsyncImpl$1$1.run(AsyncImpl.java:76)
      ]]

      .....

      [2013-04-25T20:22:47.601-0700] [glassfish 4.0] [INFO] [NCLS-CORE-00017] [javax.enterprise.system.core] [tid: _ThreadID=1 _ThreadName=main] [timeMillis: 1366946567601] [levelValue: 800] [[
      GlassFish Server Open Source Edition 4.0 (re-continuous) startup time : Felix (3,641ms), startup services(3,534ms), total(7,175ms)]]

      [2013-04-25T20:22:47.601-0700] [glassfish 4.0] [SEVERE] [NCLS-CORE-00019] [javax.enterprise.system.core] [tid: _ThreadID=1 _ThreadName=main] [timeMillis: 1366946567601] [levelValue: 1000] [[
      Shutting down server due to startup exception
      java.net.BindException: Address already in use
      at sun.nio.ch.Net.bind0(Native Method)
      at sun.nio.ch.Net.bind(Net.java:344)
      at sun.nio.ch.Net.bind(Net.java:336)
      at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:199)
      at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74)
      at org.glassfish.grizzly.nio.transport.TCPNIOBindingHandler.bindToChannelAndAddress(TCPNIOBindingHandler.java:131)
      at org.glassfish.grizzly.nio.transport.TCPNIOBindingHandler.bind(TCPNIOBindingHandler.java:87)
      at org.glassfish.grizzly.nio.transport.TCPNIOTransport.bind(TCPNIOTransport.java:450)
      at org.glassfish.grizzly.nio.transport.TCPNIOTransport.bind(TCPNIOTransport.java:439)
      at org.glassfish.grizzly.nio.transport.TCPNIOTransport.bind(TCPNIOTransport.java:95)
      at org.glassfish.grizzly.config.GenericGrizzlyListener.start(GenericGrizzlyListener.java:168)
      at com.sun.enterprise.v3.services.impl.GlassfishNetworkListener.start(GlassfishNetworkListener.java:94)
      at com.sun.enterprise.v3.services.impl.GrizzlyProxy.start(GrizzlyProxy.java:230)
      at com.sun.enterprise.v3.services.impl.GrizzlyService.createNetworkProxy(GrizzlyService.java:470)
      at com.sun.enterprise.v3.services.impl.GrizzlyService.postConstruct(GrizzlyService.java:393)
      at org.jvnet.hk2.internal.ClazzCreator.postConstructMe(ClazzCreator.java:281)
      at org.jvnet.hk2.internal.ClazzCreator.create(ClazzCreator.java:328)
      at org.jvnet.hk2.internal.SystemDescriptor.create(SystemDescriptor.java:448)
      at org.glassfish.hk2.runlevel.internal.AsyncRunLevelContext.findOrCreate(AsyncRunLevelContext.java:158)
      at org.jvnet.hk2.internal.Utilities.createService(Utilities.java:2203)
      at org.jvnet.hk2.internal.ServiceHandleImpl.getService(ServiceHandleImpl.java:93)
      at org.glassfish.hk2.runlevel.internal.CurrentTaskFuture$QueueRunner.oneJob(CurrentTaskFuture.java:673)
      at org.glassfish.hk2.runlevel.internal.CurrentTaskFuture$QueueRunner.run(CurrentTaskFuture.java:660)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
      at java.lang.Thread.run(Thread.java:722)
      ]]

      [2013-04-25T20:22:47.640-0700] [glassfish 4.0] [INFO] [] [javax.enterprise.system.core] [tid: _ThreadID=51 _ThreadName=Thread-13] [timeMillis: 1366946567640] [levelValue: 800] [[
      Server shutdown initiated]]

        Activity

        Amy Roh created issue -
        Amy Roh added a comment -

        The server.log can be viewed from http://hudson-sca.us.oracle.com/job/webtier-dev-tests-bg/3047/artifact/glassfish-v3-image/glassfish4/glassfish/domains/domain1/logs/server.log.save. FYI, this intermittent issue started happening more consistently from 4/17.

        jwells added a comment -

        So the exception itself is innocuous, right? I mean, it just means that whatever service it is has already been removed which may happen if Felix comes down before this code is run. There must be some other underlying issue, as this one isn't going to stop any subsequent shutdown processing. This is the code printing out that error:

        try

        { reg.unregister(); logger.log(Level.INFO, LogFacade.SERVICE_UNREGISTERED, this); }

        catch (IllegalStateException e)

        { LogFacade.log(logger, Level.WARNING, LogFacade.SERVICE_UNREGISTRATION_EXCEPTION, e, e); }

        Now, this could be indicative of some race condition that is not fully understood, but this particular warning is not serious. Is the process that had this still running when this happens? Can we get a jstack?

        Amy Roh added a comment -

        The server does fail to shut down and restart. The ISE is the only exception/error displayed in the server.log. It is possible that some race condition is happening. A jstack isn't available since the hanging issue is no longer happening, the process continues, and finishes the test suite.

        Amy Roh added a comment -

        This stack trace is sent to interested parties before. Including in the bug report for future reference since java.net is back up.

        [2013-04-26T05:45:57.122-0700] [glassfish 4.0] [WARNING] [resources.resource-manager.connector-descriptor.bind.failure] [LogStrings.com.sun.appserv.connectors.internal.api] [tid: _ThreadID=16 _ThreadName=RunLevelControllerThread-1366980356771] [timeMillis: 1366980357122] [levelValue: 900] [[
        RAR8706: Unable to bind connector descriptor for resource-adapter [ jaxr-ra ]. Following exception occurred : javax.naming.NamingException: Unable to acquire SerialContextProvider for SerialContext[myEnv=

        {java.naming.factory.initial=com.sun.enterprise.naming.impl.SerialInitContextFactory, java.naming.factory.state=com.sun.corba.ee.impl.presentation.rmi.JNDIStateFactoryImpl, java.naming.factory.url.pkgs=com.sun.enterprise.naming} [Root exception is java.lang.NullPointerException]]]

        [2013-04-26T05:45:57.121-0700] [glassfish 4.0] [SEVERE] [] [] [tid: _ThreadID=16 _ThreadName=Thread-8] [timeMillis: 1366980357121] [levelValue: 1000] [[
        java.lang.NullPointerException
        at com.sun.enterprise.naming.impl.SerialContext.getORB(SerialContext.java:347)
        at com.sun.enterprise.naming.impl.SerialContext.getProviderCacheKey(SerialContext.java:354)
        at com.sun.enterprise.naming.impl.SerialContext.getRemoteProvider(SerialContext.java:384)
        at com.sun.enterprise.naming.impl.SerialContext.getProvider(SerialContext.java:329)
        at com.sun.enterprise.naming.impl.SerialContext.rebind(SerialContext.java:675)
        at com.sun.enterprise.naming.impl.SerialContext.rebind(SerialContext.java:692)
        at javax.naming.InitialContext.rebind(InitialContext.java:431)
        at javax.naming.InitialContext.rebind(InitialContext.java:431)
        at com.sun.enterprise.naming.impl.GlassfishNamingManagerImpl.publishObject(GlassfishNamingManagerImpl.java:210)
        at com.sun.enterprise.naming.impl.GlassfishNamingManagerImpl.publishObject(GlassfishNamingManagerImpl.java:196)
        at com.sun.appserv.connectors.internal.ConnectorResourceManagerLifecycleListener.bindConnectorDescriptorProxies(ConnectorResourceManagerLifecycleListener.java:147)
        at com.sun.appserv.connectors.internal.ConnectorResourceManagerLifecycleListener.bindConnectorDescriptors(ConnectorResourceManagerLifecycleListener.java:136)
        at com.sun.appserv.connectors.internal.ConnectorResourceManagerLifecycleListener.resourceManagerStarted(ConnectorResourceManagerLifecycleListener.java:184)
        at com.sun.appserv.connectors.internal.ConnectorResourceManagerLifecycleListener.resourceManagerLifecycleEvent(ConnectorResourceManagerLifecycleListener.java:177)
        at org.glassfish.resourcebase.resources.listener.ResourceManager.notifyListeners(ResourceManager.java:132)
        at org.glassfish.resourcebase.resources.listener.ResourceManager.postConstruct(ResourceManager.java:123)
        at org.jvnet.hk2.internal.ClazzCreator.postConstructMe(ClazzCreator.java:281)
        at org.jvnet.hk2.internal.ClazzCreator.create(ClazzCreator.java:328)
        at org.jvnet.hk2.internal.SystemDescriptor.create(SystemDescriptor.java:448)
        at org.glassfish.hk2.runlevel.internal.AsyncRunLevelContext.findOrCreate(AsyncRunLevelContext.java:158)
        at org.jvnet.hk2.internal.Utilities.createService(Utilities.java:2203)
        at org.jvnet.hk2.internal.ServiceHandleImpl.getService(ServiceHandleImpl.java:93)
        at org.glassfish.hk2.runlevel.internal.CurrentTaskFuture$QueueRunner.oneJob(CurrentTaskFuture.java:673)
        at org.glassfish.hk2.runlevel.internal.CurrentTaskFuture$QueueRunner.run(CurrentTaskFuture.java:660)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
        at java.lang.Thread.run(Thread.java:722)]]

        [2013-04-26T05:45:58.958-0700] [glassfish 4.0] [INFO] [NCLS-CORE-00015] [javax.enterprise.system.core] [tid: _ThreadID=13 _ThreadName=RunLevelControllerThread-1366980356767] [timeMillis: 1366980358958] [levelValue: 800] [[
        Shutdown requested
        MultiException stack 1 of 1
        MultiException stack 1 of 4
        java.lang.RuntimeException: javax.naming.NamingException: Unable to acquire SerialContextProvider for SerialContext[myEnv={java.naming.factory.initial=com.sun.enterprise.naming.impl.SerialInitContextFactory, java.naming.factory.state=com.sun.corba.ee.impl.presentation.rmi.JNDIStateFactoryImpl, java.naming.factory.url.pkgs=com.sun.enterprise.naming}

        [Root exception is java.lang.NullPointerException]
        at com.sun.enterprise.container.common.impl.util.InjectionManagerImpl.postConstruct(InjectionManagerImpl.java:117)
        at org.jvnet.hk2.internal.ClazzCreator.postConstructMe(ClazzCreator.java:281)
        at org.jvnet.hk2.internal.ClazzCreator.create(ClazzCreator.java:328)
        at org.jvnet.hk2.internal.SystemDescriptor.create(SystemDescriptor.java:448)
        at org.jvnet.hk2.internal.SingletonContext.findOrCreate(SingletonContext.java:107)
        at org.jvnet.hk2.internal.Utilities.createService(Utilities.java:2203)
        at org.jvnet.hk2.internal.ServiceHandleImpl.getService(ServiceHandleImpl.java:93)
        at org.jvnet.hk2.internal.ServiceLocatorImpl.getService(ServiceLocatorImpl.java:558)
        at org.jvnet.hk2.internal.ThreeThirtyResolver.resolve(ThreeThirtyResolver.java:77)
        at org.jvnet.hk2.internal.ClazzCreator.resolve(ClazzCreator.java:191)
        at org.jvnet.hk2.internal.ClazzCreator.resolveAllDependencies(ClazzCreator.java:214)
        at org.jvnet.hk2.internal.ClazzCreator.create(ClazzCreator.java:311)
        at org.jvnet.hk2.internal.SystemDescriptor.create(SystemDescriptor.java:448)
        at org.glassfish.hk2.runlevel.internal.AsyncRunLevelContext.findOrCreate(AsyncRunLevelContext.java:158)
        at org.jvnet.hk2.internal.Utilities.createService(Utilities.java:2203)
        at org.jvnet.hk2.internal.ServiceHandleImpl.getService(ServiceHandleImpl.java:93)
        at org.glassfish.hk2.runlevel.internal.CurrentTaskFuture$QueueRunner.oneJob(CurrentTaskFuture.java:673)
        at org.glassfish.hk2.runlevel.internal.CurrentTaskFuture$QueueRunner.run(CurrentTaskFuture.java:660)
        at org.glassfish.hk2.runlevel.internal.CurrentTaskFuture$UpOneJob.run(CurrentTaskFuture.java:490)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
        at java.lang.Thread.run(Thread.java:722)
        Caused by: javax.naming.NamingException: Unable to acquire SerialContextProvider for SerialContext[myEnv=

        {java.naming.factory.initial=com.sun.enterprise.naming.impl.SerialInitContextFactory, java.naming.factory.state=com.sun.corba.ee.impl.presentation.rmi.JNDIStateFactoryImpl, java.naming.factory.url.pkgs=com.sun.enterprise.naming} [Root exception is java.lang.NullPointerException]
        at com.sun.enterprise.naming.impl.SerialContext.getProvider(SerialContext.java:334)
        at com.sun.enterprise.naming.impl.SerialContext.rebind(SerialContext.java:675)
        at com.sun.enterprise.naming.impl.SerialContext.rebind(SerialContext.java:692)
        at javax.naming.InitialContext.rebind(InitialContext.java:431)
        at javax.naming.InitialContext.rebind(InitialContext.java:431)
        at com.sun.enterprise.naming.impl.GlassfishNamingManagerImpl.publishObject(GlassfishNamingManagerImpl.java:210)
        at com.sun.enterprise.naming.impl.GlassfishNamingManagerImpl.publishObject(GlassfishNamingManagerImpl.java:196)
        at com.sun.enterprise.container.common.impl.util.InjectionManagerImpl.postConstruct(InjectionManagerImpl.java:114)
        ... 21 more
        Caused by: java.lang.NullPointerException
        at com.sun.enterprise.naming.impl.SerialContext.getORB(SerialContext.java:347)
        at com.sun.enterprise.naming.impl.SerialContext.getProviderCacheKey(SerialContext.java:354)
        at com.sun.enterprise.naming.impl.SerialContext.getRemoteProvider(SerialContext.java:384)
        at com.sun.enterprise.naming.impl.SerialContext.getProvider(SerialContext.java:329)
        ... 28 more
        MultiException stack 2 of 4
        java.lang.IllegalStateException: Unable to perform operation: post construct on com.sun.enterprise.container.common.impl.util.InjectionManagerImpl
        at org.jvnet.hk2.internal.ClazzCreator.create(ClazzCreator.java:346)
        at org.jvnet.hk2.internal.SystemDescriptor.create(SystemDescriptor.java:448)
        at org.jvnet.hk2.internal.SingletonContext.findOrCreate(SingletonContext.java:107)
        at org.jvnet.hk2.internal.Utilities.createService(Utilities.java:2203)
        at org.jvnet.hk2.internal.ServiceHandleImpl.getService(ServiceHandleImpl.java:93)
        at org.jvnet.hk2.internal.ServiceLocatorImpl.getService(ServiceLocatorImpl.java:558)
        at org.jvnet.hk2.internal.ThreeThirtyResolver.resolve(ThreeThirtyResolver.java:77)
        at org.jvnet.hk2.internal.ClazzCreator.resolve(ClazzCreator.java:191)
        at org.jvnet.hk2.internal.ClazzCreator.resolveAllDependencies(ClazzCreator.java:214)
        at org.jvnet.hk2.internal.ClazzCreator.create(ClazzCreator.java:311)
        at org.jvnet.hk2.internal.SystemDescriptor.create(SystemDescriptor.java:448)
        at org.glassfish.hk2.runlevel.internal.AsyncRunLevelContext.findOrCreate(AsyncRunLevelContext.java:158)
        at org.jvnet.hk2.internal.Utilities.createService(Utilities.java:2203)
        at org.jvnet.hk2.internal.ServiceHandleImpl.getService(ServiceHandleImpl.java:93)
        at org.glassfish.hk2.runlevel.internal.CurrentTaskFuture$QueueRunner.oneJob(CurrentTaskFuture.java:673)
        at org.glassfish.hk2.runlevel.internal.CurrentTaskFuture$QueueRunner.run(CurrentTaskFuture.java:660)
        at org.glassfish.hk2.runlevel.internal.CurrentTaskFuture$UpOneJob.run(CurrentTaskFuture.java:490)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
        at java.lang.Thread.run(Thread.java:722)
        MultiException stack 3 of 4
        java.lang.IllegalArgumentException: While attempting to resolve the dependencies of com.sun.enterprise.container.common.impl.managedbean.ManagedBeanManagerImpl errors were found
        at org.jvnet.hk2.internal.ClazzCreator.resolveAllDependencies(ClazzCreator.java:226)
        at org.jvnet.hk2.internal.ClazzCreator.create(ClazzCreator.java:311)
        at org.jvnet.hk2.internal.SystemDescriptor.create(SystemDescriptor.java:448)
        at org.glassfish.hk2.runlevel.internal.AsyncRunLevelContext.findOrCreate(AsyncRunLevelContext.java:158)
        at org.jvnet.hk2.internal.Utilities.createService(Utilities.java:2203)
        at org.jvnet.hk2.internal.ServiceHandleImpl.getService(ServiceHandleImpl.java:93)
        at org.glassfish.hk2.runlevel.internal.CurrentTaskFuture$QueueRunner.oneJob(CurrentTaskFuture.java:673)
        at org.glassfish.hk2.runlevel.internal.CurrentTaskFuture$QueueRunner.run(CurrentTaskFuture.java:660)
        at org.glassfish.hk2.runlevel.internal.CurrentTaskFuture$UpOneJob.run(CurrentTaskFuture.java:490)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
        at java.lang.Thread.run(Thread.java:722)
        MultiException stack 4 of 4
        java.lang.IllegalStateException: Unable to perform operation: resolve on com.sun.enterprise.container.common.impl.managedbean.ManagedBeanManagerImpl
        at org.jvnet.hk2.internal.ClazzCreator.create(ClazzCreator.java:340)
        at org.jvnet.hk2.internal.SystemDescriptor.create(SystemDescriptor.java:448)
        at org.glassfish.hk2.runlevel.internal.AsyncRunLevelContext.findOrCreate(AsyncRunLevelContext.java:158)
        at org.jvnet.hk2.internal.Utilities.createService(Utilities.java:2203)
        at org.jvnet.hk2.internal.ServiceHandleImpl.getService(ServiceHandleImpl.java:93)
        at org.glassfish.hk2.runlevel.internal.CurrentTaskFuture$QueueRunner.oneJob(CurrentTaskFuture.java:673)
        at org.glassfish.hk2.runlevel.internal.CurrentTaskFuture$QueueRunner.run(CurrentTaskFuture.java:660)
        at org.glassfish.hk2.runlevel.internal.CurrentTaskFuture$UpOneJob.run(CurrentTaskFuture.java:490)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
        at java.lang.Thread.run(Thread.java:722)

        [2013-04-26T05:45:59.018-0700] [glassfish 4.0] [SEVERE] [NCLS-CORE-00016] [javax.enterprise.system.core] [tid: _ThreadID=13 _ThreadName=RunLevelControllerThread-1366980356767] [timeMillis: 1366980359018] [levelValue: 1000] [[
        Startup service failed to start
        MultiException stack 1 of 1
        MultiException stack 1 of 4
        java.lang.RuntimeException: javax.naming.NamingException: Unable to acquire SerialContextProvider for SerialContext[myEnv={java.naming.factory.initial=com.sun.enterprise.naming.impl.SerialInitContextFactory, java.naming.factory.state=com.sun.corba.ee.impl.presentation.rmi.JNDIStateFactoryImpl, java.naming.factory.url.pkgs=com.sun.enterprise.naming}

        [Root exception is java.lang.NullPointerException]
        at com.sun.enterprise.container.common.impl.util.InjectionManagerImpl.postConstruct(InjectionManagerImpl.java:117)
        at org.jvnet.hk2.internal.ClazzCreator.postConstructMe(ClazzCreator.java:281)
        at org.jvnet.hk2.internal.ClazzCreator.create(ClazzCreator.java:328)
        at org.jvnet.hk2.internal.SystemDescriptor.create(SystemDescriptor.java:448)
        at org.jvnet.hk2.internal.SingletonContext.findOrCreate(SingletonContext.java:107)
        at org.jvnet.hk2.internal.Utilities.createService(Utilities.java:2203)
        at org.jvnet.hk2.internal.ServiceHandleImpl.getService(ServiceHandleImpl.java:93)
        at org.jvnet.hk2.internal.ServiceLocatorImpl.getService(ServiceLocatorImpl.java:558)
        at org.jvnet.hk2.internal.ThreeThirtyResolver.resolve(ThreeThirtyResolver.java:77)
        at org.jvnet.hk2.internal.ClazzCreator.resolve(ClazzCreator.java:191)
        at org.jvnet.hk2.internal.ClazzCreator.resolveAllDependencies(ClazzCreator.java:214)
        at org.jvnet.hk2.internal.ClazzCreator.create(ClazzCreator.java:311)
        at org.jvnet.hk2.internal.SystemDescriptor.create(SystemDescriptor.java:448)
        at org.glassfish.hk2.runlevel.internal.AsyncRunLevelContext.findOrCreate(AsyncRunLevelContext.java:158)
        at org.jvnet.hk2.internal.Utilities.createService(Utilities.java:2203)
        at org.jvnet.hk2.internal.ServiceHandleImpl.getService(ServiceHandleImpl.java:93)
        at org.glassfish.hk2.runlevel.internal.CurrentTaskFuture$QueueRunner.oneJob(CurrentTaskFuture.java:673)
        at org.glassfish.hk2.runlevel.internal.CurrentTaskFuture$QueueRunner.run(CurrentTaskFuture.java:660)
        at org.glassfish.hk2.runlevel.internal.CurrentTaskFuture$UpOneJob.run(CurrentTaskFuture.java:490)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
        at java.lang.Thread.run(Thread.java:722)
        Caused by: javax.naming.NamingException: Unable to acquire SerialContextProvider for SerialContext[myEnv=

        {java.naming.factory.initial=com.sun.enterprise.naming.impl.SerialInitContextFactory, java.naming.factory.state=com.sun.corba.ee.impl.presentation.rmi.JNDIStateFactoryImpl, java.naming.factory.url.pkgs=com.sun.enterprise.naming}

        [Root exception is java.lang.NullPointerException]
        at com.sun.enterprise.naming.impl.SerialContext.getProvider(SerialContext.java:334)
        at com.sun.enterprise.naming.impl.SerialContext.rebind(SerialContext.java:675)
        at com.sun.enterprise.naming.impl.SerialContext.rebind(SerialContext.java:692)
        at javax.naming.InitialContext.rebind(InitialContext.java:431)
        at javax.naming.InitialContext.rebind(InitialContext.java:431)
        at com.sun.enterprise.naming.impl.GlassfishNamingManagerImpl.publishObject(GlassfishNamingManagerImpl.java:210)
        at com.sun.enterprise.naming.impl.GlassfishNamingManagerImpl.publishObject(GlassfishNamingManagerImpl.java:196)
        at com.sun.enterprise.container.common.impl.util.InjectionManagerImpl.postConstruct(InjectionManagerImpl.java:114)
        ... 21 more
        Caused by: java.lang.NullPointerException
        at com.sun.enterprise.naming.impl.SerialContext.getORB(SerialContext.java:347)
        at com.sun.enterprise.naming.impl.SerialContext.getProviderCacheKey(SerialContext.java:354)
        at com.sun.enterprise.naming.impl.SerialContext.getRemoteProvider(SerialContext.java:384)
        at com.sun.enterprise.naming.impl.SerialContext.getProvider(SerialContext.java:329)
        ... 28 more
        MultiException stack 2 of 4
        java.lang.IllegalStateException: Unable to perform operation: post construct on com.sun.enterprise.container.common.impl.util.InjectionManagerImpl
        at org.jvnet.hk2.internal.ClazzCreator.create(ClazzCreator.java:346)
        at org.jvnet.hk2.internal.SystemDescriptor.create(SystemDescriptor.java:448)
        at org.jvnet.hk2.internal.SingletonContext.findOrCreate(SingletonContext.java:107)
        at org.jvnet.hk2.internal.Utilities.createService(Utilities.java:2203)
        at org.jvnet.hk2.internal.ServiceHandleImpl.getService(ServiceHandleImpl.java:93)
        at org.jvnet.hk2.internal.ServiceLocatorImpl.getService(ServiceLocatorImpl.java:558)
        at org.jvnet.hk2.internal.ThreeThirtyResolver.resolve(ThreeThirtyResolver.java:77)
        at org.jvnet.hk2.internal.ClazzCreator.resolve(ClazzCreator.java:191)
        at org.jvnet.hk2.internal.ClazzCreator.resolveAllDependencies(ClazzCreator.java:214)
        at org.jvnet.hk2.internal.ClazzCreator.create(ClazzCreator.java:311)
        at org.jvnet.hk2.internal.SystemDescriptor.create(SystemDescriptor.java:448)
        at org.glassfish.hk2.runlevel.internal.AsyncRunLevelContext.findOrCreate(AsyncRunLevelContext.java:158)
        at org.jvnet.hk2.internal.Utilities.createService(Utilities.java:2203)
        at org.jvnet.hk2.internal.ServiceHandleImpl.getService(ServiceHandleImpl.java:93)
        at org.glassfish.hk2.runlevel.internal.CurrentTaskFuture$QueueRunner.oneJob(CurrentTaskFuture.java:673)
        at org.glassfish.hk2.runlevel.internal.CurrentTaskFuture$QueueRunner.run(CurrentTaskFuture.java:660)
        at org.glassfish.hk2.runlevel.internal.CurrentTaskFuture$UpOneJob.run(CurrentTaskFuture.java:490)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
        at java.lang.Thread.run(Thread.java:722)
        MultiException stack 3 of 4
        java.lang.IllegalArgumentException: While attempting to resolve the dependencies of com.sun.enterprise.container.common.impl.managedbean.ManagedBeanManagerImpl errors were found
        at org.jvnet.hk2.internal.ClazzCreator.resolveAllDependencies(ClazzCreator.java:226)
        at org.jvnet.hk2.internal.ClazzCreator.create(ClazzCreator.java:311)
        at org.jvnet.hk2.internal.SystemDescriptor.create(SystemDescriptor.java:448)
        at org.glassfish.hk2.runlevel.internal.AsyncRunLevelContext.findOrCreate(AsyncRunLevelContext.java:158)
        at org.jvnet.hk2.internal.Utilities.createService(Utilities.java:2203)
        at org.jvnet.hk2.internal.ServiceHandleImpl.getService(ServiceHandleImpl.java:93)
        at org.glassfish.hk2.runlevel.internal.CurrentTaskFuture$QueueRunner.oneJob(CurrentTaskFuture.java:673)
        at org.glassfish.hk2.runlevel.internal.CurrentTaskFuture$QueueRunner.run(CurrentTaskFuture.java:660)
        at org.glassfish.hk2.runlevel.internal.CurrentTaskFuture$UpOneJob.run(CurrentTaskFuture.java:490)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
        at java.lang.Thread.run(Thread.java:722)
        MultiException stack 4 of 4
        java.lang.IllegalStateException: Unable to perform operation: resolve on com.sun.enterprise.container.common.impl.managedbean.ManagedBeanManagerImpl
        at org.jvnet.hk2.internal.ClazzCreator.create(ClazzCreator.java:340)
        at org.jvnet.hk2.internal.SystemDescriptor.create(SystemDescriptor.java:448)
        at org.glassfish.hk2.runlevel.internal.AsyncRunLevelContext.findOrCreate(AsyncRunLevelContext.java:158)
        at org.jvnet.hk2.internal.Utilities.createService(Utilities.java:2203)
        at org.jvnet.hk2.internal.ServiceHandleImpl.getService(ServiceHandleImpl.java:93)
        at org.glassfish.hk2.runlevel.internal.CurrentTaskFuture$QueueRunner.oneJob(CurrentTaskFuture.java:673)
        at org.glassfish.hk2.runlevel.internal.CurrentTaskFuture$QueueRunner.run(CurrentTaskFuture.java:660)
        at org.glassfish.hk2.runlevel.internal.CurrentTaskFuture$UpOneJob.run(CurrentTaskFuture.java:490)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
        at java.lang.Thread.run(Thread.java:722)
        ]]

        [2013-04-26T05:45:59.133-0700] [glassfish 4.0] [INFO] [] [javax.enterprise.system.core] [tid: _ThreadID=57 _ThreadName=Thread-12] [timeMillis: 1366980359133] [levelValue: 800] [[
        Server shutdown initiated]]

        [2013-04-26T05:45:59.138-0700] [glassfish 4.0] [INFO] [] [javax.enterprise.system.core] [tid: _ThreadID=58 _ThreadName=Thread-13] [timeMillis: 1366980359138] [levelValue: 800] [[
        Server shutdown initiated]]

        [2013-04-26T05:45:59.141-0700] [glassfish 4.0] [INFO] [NCLS-BOOTSTRAP-00027] [javax.enterprise.bootstrap] [tid: _ThreadID=1 _ThreadName=main] [timeMillis: 1366980359141] [levelValue: 800] [[
        Registered com.sun.enterprise.glassfish.bootstrap.osgi.EmbeddedOSGiGlassFishImpl@66e9d9f0 as OSGi service registration: org.apache.felix.framework.ServiceRegistrationImpl@5cf33dce.]]

        [2013-04-26T05:45:59.401-0700] [glassfish 4.0] [INFO] [NCLS-JMX-00005] [javax.enterprise.system.jmx] [tid: _ThreadID=52 _ThreadName=Thread-11] [timeMillis: 1366980359401] [levelValue: 800] [[
        JMXStartupService has started JMXConnector on JMXService URL service:jmx:rmi://don-vm2.us.oracle.com:53510/jndi/rmi://don-vm2.us.oracle.com:53510/jmxrmi]]

        [2013-04-26T05:46:00.150-0700] [glassfish 4.0] [INFO] [NCLS-BOOTSTRAP-00028] [javax.enterprise.bootstrap] [tid: _ThreadID=57 _ThreadName=Thread-12] [timeMillis: 1366980360150] [levelValue: 800] [[
        Unregistered com.sun.enterprise.glassfish.bootstrap.osgi.EmbeddedOSGiGlassFishImpl@66e9d9f0 from service registry.]]

        [2013-04-26T05:46:00.151-0700] [glassfish 4.0] [INFO] [] [] [tid: _ThreadID=57 _ThreadName=Thread-7] [timeMillis: 1366980360151] [levelValue: 800] [[
        FileMonitoring shutdown]]

        [2013-04-26T05:46:00.155-0700] [glassfish 4.0] [WARNING] [NCLS-BOOTSTRAP-00029] [javax.enterprise.bootstrap] [tid: _ThreadID=58 _ThreadName=Thread-13] [timeMillis: 1366980360155] [levelValue: 900] [[
        Exception while unregistering:
        java.lang.IllegalStateException: Service already unregistered.
        at org.apache.felix.framework.ServiceRegistrationImpl.unregister(ServiceRegistrationImpl.java:123)
        at com.sun.enterprise.glassfish.bootstrap.osgi.EmbeddedOSGiGlassFishImpl.unregisterService(EmbeddedOSGiGlassFishImpl.java:93)
        at com.sun.enterprise.glassfish.bootstrap.osgi.EmbeddedOSGiGlassFishImpl.stop(EmbeddedOSGiGlassFishImpl.java:81)
        at com.sun.enterprise.v3.admin.StopServer.doExecute(StopServer.java:79)
        at com.sun.enterprise.v3.admin.StopDomainCommand.execute(StopDomainCommand.java:96)
        at com.sun.enterprise.v3.admin.CommandRunnerImpl$2.execute(CommandRunnerImpl.java:537)
        at org.glassfish.api.AsyncImpl$1$1.run(AsyncImpl.java:76)

        jwells made changes -
        Field Original Value New Value
        jwells added a comment -

        I have fixed two deadlocks in logging by adding dependencies in the services and have also ensured that the Globals service has been moved to start level 0 to ensure that it comes up prior to any services at level 1 get started (which will get rid of the NPE reported in this bug).

        I have run quicklook and the EJB devtests...

        jwells added a comment -

        The change number that I believe fixes this is 61580.

        jwells made changes -
        Tom Mueller made changes -
        Tags 4_0-review
        Tom Mueller made changes -
        Tags 4_0-approved
        jwells added a comment -

        This has broken some upstream Hudsons. I have a fix, so I'll re-open this until the new and improved fix is in.

        jwells made changes -
        Resolution Fixed [ 1 ]
        Status Closed [ 6 ] Reopened [ 4 ]
        jwells added a comment -

        Change 61582 uses a common API interface rather than the services themselves which is a better solution and should fix the upstream Hudsons.

        jwells made changes -
        Status Reopened [ 4 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]

          People

          • Assignee:
            jwells
            Reporter:
            Amy Roh
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: