glassfish
  1. glassfish
  2. GLASSFISH-20368

[Regression] ManagedExecutorService instance is being shut down then registered ManagedTaskListeners are not getting invoked.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 4.0_b85
    • Fix Version/s: 4.0
    • Component/s: concurrency
    • Labels:
      None
    • Environment:

      Ubuntu

      Description

      When ManagedExecutorService instance is being shut down then registered ManagedTaskListeners are not getting invoked.

        Activity

        Alex Pineda added a comment -

        Assigning to Concurrency Dev lead.

        anthony.lai added a comment -

        Section 3.1.6.1 in the JSR 236 spec states:

        When a ManagedExecutorService instance is being shutdown by the Java EE Product Provider:
        1. All attempts to submit new tasks are rejected
        2. All submitted tasks are cancelled if not running
        3. All running task threads are interrupted
        4. All registered ManagedTaskListeners are invoked
        -----------------

        When I tried the scenario:

        • thread of the running task is interrupted as expected. No ManagedTaskListener callback is invoked due to the shutdown call because the running task is neither aborted, cancelled, or completed.
        • submitted tasks that are queued up and not started running are cancelled, and taskAborted() of their ManagedTaskListener instances are invoked as expected

        Closing this as "Cannot Reproduce" for now. If you have a test case that can reproduce the problem, please send it to me. Thanks.


          People

          • Assignee:
            anthony.lai
            Reporter:
            shobhit.singh
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: