Issue Details (XML | Word | Printable)

Key: GLASSFISH-20369
Type: Bug Bug
Status: Resolved Resolved
Resolution: Fixed
Priority: Major Major
Assignee: Amy Roh
Reporter: Amy Roh
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
glassfish

The I/O streams should be closed before resuming since they might not be available after resume in upgrade.

Created: 22/Apr/13 04:14 PM   Updated: 22/Apr/13 06:40 PM   Resolved: 22/Apr/13 06:40 PM
Component/s: web_container
Affects Version/s: 4.0_b85
Fix Version/s: 4.0_b86_RC2

Time Tracking:
Not Specified

Tags: 4_0-approved
Participants: Amy Roh and Tom Mueller


 Description  « Hide

The I/O streams should be closed before resuming since they might not be available after resume in upgrade. This can cause NPE when WebConnection#close is performed in ReadListener#onDataAvailable.

Caused by: java.lang.NullPointerException
    at org.apache.catalina.connector.OutputBuffer.close(OutputBuffer.java:261)
    at org.apache.catalina.connector.CoyoteOutputStream.close(CoyoteOutputStream.java:186)
    at org.apache.catalina.connector.WebConnectionImpl.close(WebConnectionImpl.java:126)



Amy Roh added a comment - 22/Apr/13 06:40 PM

Fixed in 61581.


Tom Mueller added a comment - 22/Apr/13 04:47 PM

Approved for 4.0.


Amy Roh added a comment - 22/Apr/13 04:18 PM

What is the impact on the customer of the bug?

Users will see the NPE and stacktrace.

What is the cost/risk of fixing the bug?

Low risk. I have ran web devtests and checked with web socket team to make sure there is no regression.

Is there an impact on documentation or message strings?

No.

Which tests should QA (re)run to verify the fix did not destabilize GlassFish?

web/web socket tests

Which is the targeted build of 4.0 for this fix?

4.0_b86_RC2

If this an integration of a new version of a component from another project, what are the changes that are being brought in? This might be list of Jira issues from that project or a list of revision messages.

na