glassfish
  1. glassfish
  2. GLASSFISH-20432

integrate javax.ejb-api:3.2 javax.transaction-api:1.2

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0_b86_RC2
    • Fix Version/s: 4.0_b87_RC3
    • Component/s: None
    • Labels:
      None

      Description

      Integrate final version of ejb-api and transaction-api.
      This requires CCP as we re-inlined the jaxrpc that ejb depends on inside the ejb-api jar. Hence we can get rid of javax.xml.rpc-api.jar in the webprofile.

      Also, javax.management-j2ee-api had to be relaxed and javax.xml.rpc.jar was not importing its exported package making the OSGi runtime resolving improper wirings. (javax.ejb used instead of javax.xml.rpc jar)

      Full diff:

      Index: appserver/pom.xml
      ===================================================================
      --- appserver/pom.xml	(revision 61733)
      +++ appserver/pom.xml	(working copy)
      @@ -70,15 +70,15 @@
               <mojarra.version>2.2.0-m15</mojarra.version>
               <jsf-ext.version>0.2</jsf-ext.version>
               <woodstock.version>4.0.2.10</woodstock.version>
      -        <javax.ejb-api.version>3.2-b02</javax.ejb-api.version>
      +        <javax.ejb-api.version>3.2</javax.ejb-api.version>
               <javax.interceptor-api.version>1.2</javax.interceptor-api.version>
      -        <javax.xml.rpc-api.version>1.1</javax.xml.rpc-api.version>
      -        <javax.transaction-api.version>1.2-b03</javax.transaction-api.version>
      +        <javax.xml.rpc-api.version>1.1.1</javax.xml.rpc-api.version>
      +        <javax.transaction-api.version>1.2</javax.transaction-api.version>
               <jaxws-api.version>2.2.8</jaxws-api.version>
               <javax.faces-api.version>2.2-m12</javax.faces-api.version>
               <cdi-api.version>1.1-PRD</cdi-api.version>
               <javax.inject.version>1</javax.inject.version>
      -        <javax.resource-api.version>1.7-b05</javax.resource-api.version>
      +        <javax.resource-api.version>1.7</javax.resource-api.version>
               <javax.enterprise.deploy-api.version>1.6</javax.enterprise.deploy-api.version>
               <javax.security.jacc-api.version>1.5</javax.security.jacc-api.version>
               <javax.security.auth.message-api.version>1.1</javax.security.auth.message-api.version>
      @@ -129,7 +129,7 @@
               <com.ibm.jbatch-runtime-all.version>1.0-b26</com.ibm.jbatch-runtime-all.version>
               <com.ibm.jbatch-ri-spi.version>1.0-b26</com.ibm.jbatch-ri-spi.version>
       	<javax.xml.soap-api.version>1.3.5</javax.xml.soap-api.version>
      -	<javax.management.j2ee-api.version>1.1</javax.management.j2ee-api.version>
      +	<javax.management.j2ee-api.version>1.1.1</javax.management.j2ee-api.version>
           </properties>
       
           <modules>
      @@ -277,11 +277,10 @@
                                       <artifactId>javax.transaction-api</artifactId>
                                       <version>${javax.transaction-api.version}</version>
                                   </artifact>
      -                            <nonFinal>true</nonFinal>
      +                            <nonFinal>false</nonFinal>
                                   <jarType>api</jarType>     
      -                            <specVersion>1.1</specVersion>
      -                            <newSpecVersion>1.2</newSpecVersion>
      -                            <specBuild>03</specBuild>
      +                            <specVersion>${javax.transaction-api.version}</specVersion>
      +                            <specImplVersion>${javax.transaction-api.version}</specImplVersion>
                                   <apiPackage>javax.transaction</apiPackage>
                               </spec>
                               <spec>
      @@ -376,11 +375,10 @@
                                       <artifactId>javax.ejb-api</artifactId>
                                       <version>${javax.ejb-api.version}</version>
                                   </artifact>
      -                            <nonFinal>true</nonFinal>
      +                            <nonFinal>false</nonFinal>
                                   <jarType>api</jarType>
      -                            <specVersion>3.1</specVersion>
      -                            <newSpecVersion>3.2</newSpecVersion>
      -                            <specBuild>02</specBuild>
      +                            <specVersion>${javax.ejb-api.version}</specVersion>
      +			    <specImplVersion>${javax.ejb-api.version}</specImplVersion>
                                   <apiPackage>javax.ejb</apiPackage>
                               </spec>
                               <spec>
      @@ -401,11 +399,10 @@
                                       <artifactId>javax.resource-api</artifactId>
                                       <version>${javax.resource-api.version}</version>
                                   </artifact>
      -                            <nonFinal>true</nonFinal>
      +                            <nonFinal>false</nonFinal>
                                   <jarType>api</jarType>
      -                            <specVersion>1.6</specVersion>
      -                            <newSpecVersion>1.7</newSpecVersion>
      -                            <specBuild>05</specBuild>
      +                            <specVersion>${javax.resource-api.version}</specVersion>
      +			    <specImplVersion>${javax.resource-api.version}</specImplVersion>
                                   <apiPackage>javax.resource</apiPackage>
                               </spec>
                               <spec>
      @@ -429,7 +426,7 @@
                                   <nonFinal>false</nonFinal>
                                   <jarType>api</jarType>
                                   <specVersion>1.1</specVersion>
      -                            <specImplVersion>1.1</specImplVersion>
      +                            <specImplVersion>${javax.xml.rpc-api.version}</specImplVersion>
                                   <apiPackage>javax.xml.rpc</apiPackage>
                               </spec>
                               <spec>
      @@ -453,7 +450,7 @@
                                   <nonFinal>false</nonFinal>
                                   <jarType>api</jarType>
                                   <specVersion>1.1</specVersion>
      -                            <specImplVersion>1.1</specImplVersion>
      +                            <specImplVersion>${javax.management.j2ee-api.version}</specImplVersion>
                                   <apiPackage>javax.management.j2ee</apiPackage>
                               </spec>
                               <spec>
      Index: appserver/packager/glassfish-common-full/pom.xml
      ===================================================================
      --- appserver/packager/glassfish-common-full/pom.xml	(revision 61733)
      +++ appserver/packager/glassfish-common-full/pom.xml	(working copy)
      @@ -213,7 +213,10 @@
                   <groupId>org.glassfish</groupId>
                   <artifactId>javax.enterprise.concurrent</artifactId>
               </dependency>
      -       
      +        <dependency>
      +            <groupId>javax.xml.rpc</groupId>
      +            <artifactId>javax.xml.rpc-api</artifactId>
      +        </dependency>  
           </dependencies>
       </project>
       
      Index: appserver/packager/glassfish-common-web/pom.xml
      ===================================================================
      --- appserver/packager/glassfish-common-web/pom.xml	(revision 61733)
      +++ appserver/packager/glassfish-common-web/pom.xml	(working copy)
      @@ -337,11 +337,7 @@
               <dependency>
                   <groupId>javax.transaction</groupId>
                   <artifactId>javax.transaction-api</artifactId>
      -        </dependency>
      -        <dependency>
      -            <groupId>javax.xml.rpc</groupId>
      -            <artifactId>javax.xml.rpc-api</artifactId>
      -        </dependency>        
      +        </dependency>      
           </dependencies>
           
           <repositories>
      

        Activity

        Romain Grécourt added a comment -
        • What is the impact on the customer of the bug?
          No final API used in GF for EJB and Transaction

        How likely is it that a customer will see the bug and how serious is the bug?
        Quite hidden
        Is it a regression? Does it meet other bug fix criteria (security, performance, etc.)?
        No.
        What CTS failures are caused by this bug?
        none.

        • What is the cost/risk of fixing the bug?
          medium, it involves OSGi wiring solving + packaging change to have javax.xml.rpc-api.jar only in Full Profile.

        How risky is the fix? How much work is the fix? Is the fix complicated?
        Relatively easy.

        • Is there an impact on documentation or message strings?
        • Which tests should QA (re)run to verify the fix did not destabilize GlassFish?
          QL wp and GP.
        • Which is the targeted build of 4.0 for this fix?
          RC3.
        • If this an integration of a new version of a component from another project,
          what are the changes that are being brought in? This might be list of
          Jira issues from that project or a list of revision messages.
          osgi metadata, relaxing some imports and making sure bundles are well doing substitutable export.
        Tom Mueller added a comment -

        Approved for 4.0.

        Romain Grécourt added a comment -

        done with svn revision #61754


          People

          • Assignee:
            Romain Grécourt
            Reporter:
            Romain Grécourt
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: