glassfish
  1. glassfish
  2. GLASSFISH-20439

4.0SDkb86 : Installation fails with error on ubuntu

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 4.0_b86_RC2
    • Fix Version/s: None
    • Component/s: installation
    • Labels:
      None
    • Environment:

      Ubuntu 12.10

      Description

      Steps to reproduce :

      Install 32bit 4.0SDKB86 build("java_ee_sdk-7-web-b86-jdk7-linux.sh" or "java_ee_sdk-7-b86-jdk7-linux.sh" ) on ubuntu.

      Installation fails with below error.
      Issue is happening only on ubuntu.

      Console O/p :

      sh $BUNDLE -a statefile1.unix -s -j $JAVA_HOME
      Extracting the installer archive...
      Extracting the installer runtime...
      Extracting the installer resources...
      Extracting the installer metadata...

      Welcome to GlassFish installer

      Using the user defined JAVA_HOME : /localhome/hudson/tools/jdk1.7.0_21
      Entering setup...

      SETTING UP DOMAIN FOR SILENT INSTALL...
      Executing
      /localhome/hudson/workspace/GF4.0_sdk_bat_ubuntu/glassfish4/glassfish/bin/asadmin
      --user admin --passwordfile - create-domain
      --template=/localhome/hudson/workspace/GF4.0_sdk_bat_ubuntu/glassfish4/glassfish/common/templates/gf/appserver-domain.jar
      --savelogin --checkports=false --adminport 4848 --instanceport 8080
      --domainproperties=jms.port=7676:domain.jmxPort=8686:orb.listener.port=3700:http.ssl.port=8181:orb.ssl.port=3820:orb.mutualauth.port=3920
      domain1
      /localhome/hudson/workspace/GF4.0_sdk_bat_ubuntu/glassfish4/glassfish/bin/asadmin
      --user admin --passwordfile - create-domain
      --template=/localhome/hudson/workspace/GF4.0_sdk_bat_ubuntu/glassfish4/glassfish/common/templates/gf/appserver-domain.jar
      --savelogin --checkports=false --adminport 4848 --instanceport 8080
      --domainproperties=jms.port=7676:domain.jmxPort=8686:orb.listener.port=3700:http.ssl.port=8181:orb.ssl.port=3820:orb.mutualauth.port=3920
      domain1
      /localhome/hudson/workspace/GF4.0_sdk_bat_ubuntu/glassfish4/glassfish/bin/asadmin:
      54: exec:
      /localhome/hudson/workspace/GF4.0_sdk_bat_ubuntu/glassfish4/jdk7/bin/java:
      not found

      If I check for java version , though there is a java file , I get a
      error saying " no such file".

      hudson@sc11137376:~/workspace/GF4.0_sdk_bat_ubuntu/glassfish4/jdk7/bin$ pwd
      /localhome/hudson/workspace/GF4.0_sdk_bat_ubuntu/glassfish4/jdk7/bin

      hudson@sc11137376:~/workspace/GF4.0_sdk_bat_ubuntu/glassfish4/jdk7/bin$ ls
      appletviewer jar javafxpackager jcmd jinfo jstack
      native2ascii rmid tnameserv
      apt jarsigner javah jconsole jmap jstat orbd
      rmiregistry unpack200
      ControlPanel java javap jcontrol jps jstatd
      pack200 schemagen wsgen
      extcheck javac java-rmi.cgi jdb jrunscript jvisualvm
      policytool serialver wsimport
      idlj javadoc javaws jhat jsadebugd keytool
      rmic servertool xjc

      hudson@sc11137376:~/workspace/GF4.0_sdk_bat_ubuntu/glassfish4/jdk7/bin$
      ./java -version
      bash: ./java: No such file or directory

        Activity

        Gail Risdal added a comment -

        Added the following to the release notes:

        Installation fails with error on ubuntu (20439)

        Description
        Java installation fails when the 32-bit version of JDK 7 for Linux is installed on a 64-bit Ubuntu system. This is caused by missing 32-bit libraries.

        Workaround
        Run apt-get install libc6-i386 to install the required 32-bit libraries before installing the 32-bit version of JDK 7 for Linux on a 64-bit Ubuntu system.

        Snjezana Sevo-Zenzerovic added a comment -

        Googling the error shows that this is a known issue while trying to run 32-bit JDK on 64-bit Ubuntu system since some required 32 bit libraries are not installed out of the box:

        http://askubuntu.com/questions/207552/no-such-file-or-directory-when-invoking-java
        http://stackoverflow.com/questions/9081962/java-is-installed-in-listing-but-execution-produces-java-no-such-file-or-d

        While this is system configuration issue and there really isn't anything to fix, I am tagging the issue to be included in Java EE SDK release notes. The "fix" is to run 'apt-get install libc6-i386' in order to install required 32-bit libraries prior to installing Java EE 7 SDK cobundle with 32 bit JDK for Linux.


          People

          • Assignee:
            Snjezana Sevo-Zenzerovic
            Reporter:
            bhavya_h_s
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: