glassfish
  1. glassfish
  2. GLASSFISH-20442

restore BeanValidatorNamingProxy to nucleus

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0_b86_RC2
    • Fix Version/s: 4.0_b87_RC3
    • Component/s: bean-validator
    • Labels:
      None

      Description

      BeanValidatorNamingProxy was recently removed from nucleus, favoring an alternate implementation (in weld-integration) that integrates with CDI (since the Validator/ValidatorFactory needs to be retrieved from CDI when available). This is problematic in appclient distribution where the weld-integration module is not present.

      The solution is to restore BeanValidatorNamingProxy and delegate to the weld-integration if available (implemented with @Inject @Optional @Named(...)).. This way, CDI will be interrogated for Validator objects if CDI is available, but the object will be returned either way.

        Activity

        mtaube created issue -
        mtaube added a comment -

        This bug is causing the following CTS failure: com/sun/ts/tests/ejb30/misc/jndi/earjar/Client.java#beanValidator: Client_beanValidator

        mtaube added a comment -

        What is the impact on the customer of the bug?
        appclients cannot look up Validator/ValidatorFactory from jndi

        How likely is it that a customer will see the bug and how serious is the bug?
        certain

        Is it a regression?
        Yes.

        Does it meet other bug fix criteria (security, performance, etc.)?
        no.

        What CTS failures are caused by this bug?
        com/sun/ts/tests/ejb30/misc/jndi/earjar/Client.java#beanValidator: Client_beanValidator

        What is the cost/risk of fixing the bug?
        Low

        How risky is the fix? How much work is the fix? Is the fix complicated?
        Low – restores previous behavior and adds a delegation model

        Is there an impact on documentation or message strings?
        no.

        Which tests should QA (re)run to verify the fix did not destabilize GlassFish?
        EJB, EJB cts, bean-validation CTS

        Which is the targeted build of 4.0 for this fix?
        rc3.

        If this an integration of a new version of a component from another project,
        what are the changes that are being brought in? This might be list of
        Jira issues from that project or a list of revision messages.
        No.

        mtaube made changes -
        Field Original Value New Value
        Tags 4_0-review
        michael.y.chen made changes -
        Affects Version/s 4.0_b86_RC2 [ 16115 ]
        Tags 4_0-review 4_0-approved
        Component/s bean-validator [ 14031 ]
        michael.y.chen made changes -
        Fix Version/s 4.0 [ 10970 ]
        mtaube added a comment -

        Sending appserver/web/weld-integration/src/main/java/org/glassfish/weld/ValidationNamingProxy.java
        Adding nucleus/core/kernel/src/main/java/org/glassfish/kernel/bean_validator/BeanValidatorNamingProxy.java
        Transmitting file data ..
        Committed revision 61753.

        mtaube made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 4.0_b87_RC3 [ 16116 ]
        Fix Version/s 4.0 [ 10970 ]
        Resolution Fixed [ 1 ]
        mtaube made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            mtaube
            Reporter:
            mtaube
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: