glassfish
  1. glassfish
  2. GLASSFISH-20467

RuntimeException not logged on setMessageListener

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 4.0_b86_RC2
    • Fix Version/s: None
    • Component/s: jms
    • Labels:
      None

      Description

      The following RuntimeException is not being logged by GlassFish (had to try/catch RuntimeException):

      javax.jms.JMSRuntimeException: [C4306]: This method may not be called in a Java EE web or EJB container
      	at com.sun.messaging.jmq.jmsclient.JMSConsumerImpl.setMessageListener(JMSConsumerImpl.java:261)
      	at org.glassfish.javaee7wsjms.SampleWebSocket.onOpen(SampleWebSocket.java:55)
      

      This issue might appear at other places.

        Issue Links

          Activity

          Bruno Borges added a comment -

          See GLASSFISH-20371 for the discussion around this.

          David Zhao added a comment -

          The implementation class is in MQ. So it is better to file an issue for MQ to trace it.

          Bruno Borges added a comment -

          Issue created for MQ as MQ-297

          Nigel Deakin added a comment -

          I logged GLASSFISH-20481 before I saw this one. That issue explains how this is an issue with the WebSocket container. I will therefore close this issue as a duplicate of that one.


            People

            • Assignee:
              David Zhao
              Reporter:
              Bruno Borges
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: