Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Works as designed
    • Affects Version/s: 4.0_b87_RC3
    • Fix Version/s: None
    • Component/s: batch
    • Labels:
      None

      Description

      Hi,

      I was wondering if it could make sense to add a <properties> element to a <partition> <mapper ref="entriesPartitioner"> entry.
      E.g. if you have a large file to process and need to hand over the file url of that one ... at the moment something like this isn't possible with a mapper .. you have to manually add a plan (a plan knows properties)

      <partition>
      <mapper ref="entriesPartitioner">
      <properties>
      <property name="file.url" value="#

      {jobParameters['file.url']}

      " />
      </properties>
      </mapper>
      </partition>

        Activity

        myfear added a comment -

        Seems to be my error. It actually works. Sorry. Please close ...


          People

          • Assignee:
            michael.y.chen
            Reporter:
            myfear
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: