glassfish
  1. glassfish
  2. GLASSFISH-20478

PSR:FUNC Unable to deploy WebServices application: Illegal Class loader binding

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 4.0_b87_RC3
    • Fix Version/s: 4.0_b88_RC4
    • Component/s: deployment
    • Labels:
      None

      Description

      Starting in build 87, tests to deploy SPECjEnterprise fail; the WS stack is unable to create a DirContext:

      [2013-05-06T09:21:33.964-0700] [glassfish 4.0] [WARNING] [AS-WSJSR109IMPL-00082] [javax.enterprise.webservices] [tid: _ThreadID=32 _ThreadName=admin-listener(1)] [timeMillis: 1367857293964] [levelValue: 900] [[
      Deployment failed
      java.lang.IllegalStateException: Illegal class loader binding
      at org.apache.naming.resources.DirContextURLStreamHandler.get(DirContextURLStreamHandler.java:231)
      at org.apache.naming.resources.DirContextURLStreamHandler.openConnection(DirContextURLStreamHandler.java:131)
      at org.apache.naming.resources.DirContextURLStreamHandlerService$DelegatingDirContextURLStreamHandler.openConnection(DirContextURLStreamHandlerService.java:76)
      at org.apache.naming.resources.DirContextURLStreamHandlerService.openConnection(DirContextURLStreamHandlerService.java:86)
      at org.apache.felix.framework.URLHandlersStreamHandlerProxy.openConnection(URLHandlersStreamHandlerProxy.java:271)
      at java.net.URL.openConnection(URL.java:971)
      at java.net.URL.openStream(URL.java:1037)
      at com.sun.xml.ws.api.server.SDDocumentSource$1.read(SDDocumentSource.java:118)
      at com.sun.xml.ws.server.SDDocumentImpl.create(SDDocumentImpl.java:124)
      at com.sun.xml.ws.server.EndpointFactory.categoriseMetadata(EndpointFactory.java:669)
      at com.sun.xml.ws.server.EndpointFactory.create(EndpointFactory.java:244)
      at com.sun.xml.ws.server.EndpointFactory.createEndpoint(EndpointFactory.java:158)
      at com.sun.xml.ws.api.server.WSEndpoint.create(WSEndpoint.java:577)
      ...

      Instructions on running deployment of SPECj can be found at http://aseng-wiki.us.oracle.com/asengwiki/display/GlassFish/Running+the+startup+benchmark

        Activity

        jjsnyder83 added a comment -

        Updated on trunk, revision: 61898

        jjsnyder83 added a comment -

        What is the impact on the customer of the bug?
        CDI causing web services to not work. Specific case is the SpecJ benchmark in this bug.

        How likely is it that a customer will see the bug and how serious is the bug?
        Is it a regression? Does it meet other bug fix criteria (security, performance, etc.)?
        What CTS failures are caused by this bug?
        very

        What is the cost/risk of fixing the bug?
        low

        How risky is the fix? How much work is the fix? Is the fix complicated?
        low...Only a few lines of code changed.

        Is there an impact on documentation or message strings?
        No

        Which tests should QA (re)run to verify the fix did not destabilize GlassFish?
        The SpecJ benchmark in this issue.

        Which is the targeted build of 4.0 for this fix?
        4.0_b88_RC4

        If this an integration of a new version of a component from another project,
        what are the changes that are being brought in? This might be list of
        Jira issues from that project or a list of revision messages.
        N/A

        Tom Mueller added a comment -

        Approved for 4.0.

        jjsnyder83 added a comment -

        Updated on 4.0
        Committed revision 61902.

        Scott Oaks added a comment -

        Able to deploy on build 89.


          People

          • Assignee:
            jjsnyder83
            Reporter:
            Scott Oaks
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: