glassfish
  1. glassfish
  2. GLASSFISH-20480

TransactionalException with @Transactional

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 4.0_b87_RC3
    • Fix Version/s: None
    • Component/s: jts
    • Labels:
      None

      Description

      public class MyBean {
      @Transactional
      public void deleteMovie()

      { System.out.println("deleteMovie"); }

      }

      Invoking deleteMovie() method from a Serlvet throws the following exception:

      INFO: In MANDATORY TransactionalInterceptor
      WARNING: StandardWrapperValve[org.glassfish.sample.transactional.TestServlet]: Servlet.service() for servlet org.glassfish.sample.transactional.TestServlet threw exception
      javax.transaction.TransactionalException: TransactionRequiredException thrown from TxType.MANDATORY transactional interceptor.
      at org.glassfish.cdi.transaction.TransactionalInterceptorMandatory.transactional(TransactionalInterceptorMandatory.java:77)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

        Activity

        arungupta created issue -
        arungupta added a comment -

        Assigning to Paul

        arungupta made changes -
        Field Original Value New Value
        Assignee marina vatkina [ mvatkina ] paul_parkinson [ paul_parkinson ]
        Priority Major [ 3 ] Blocker [ 1 ]
        paul_parkinson made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        paul_parkinson added a comment -

        @ Issue is caused by TxType of Transactional annotation being/regressing to
        @ @NonBinding. The change to fix this has been committed. We are just waiting for it to be promoted...

        paul_parkinson added a comment -

        need Romain to promote.

        paul_parkinson made changes -
        Assignee paul_parkinson [ paul_parkinson ] Romain Grécourt [ romain_grecourt ]
        Romain Grécourt added a comment -

        resolved yesterday (13 may 2013)

        Romain Grécourt made changes -
        Status In Progress [ 3 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]

          People

          • Assignee:
            Romain Grécourt
            Reporter:
            arungupta
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: