glassfish
  1. glassfish
  2. GLASSFISH-20531

JSF can't find @Named beans after redeploy

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Cannot Reproduce
    • Affects Version/s: 4.0_b88_RC4
    • Fix Version/s: None
    • Component/s: cdi, jsf
    • Labels:
      None

      Description

      Playing with Arun's HOL (glassfish.org/hol).

      After a redeploy from NetBeans, JSF is not able to load a @Named bean anymore.

      /points/points.xhtml @16,69 value="#{sendPointsBean.message}": Target Unreachable, identifier 'sendPointsBean' resolved to null

      Full stacktrace:

      javax.el.PropertyNotFoundException: /points/points.xhtml @16,69 value="#{sendPointsBean.message}": Target Unreachable, identifier 'sendPointsBean' resolved to null
      	at com.sun.faces.facelets.el.TagValueExpression.getType(TagValueExpression.java:100)
      	at com.sun.faces.renderkit.html_basic.HtmlBasicInputRenderer.getConvertedValue(HtmlBasicInputRenderer.java:95)
      	at javax.faces.component.UIInput.getConvertedValue(UIInput.java:1046)
      	at javax.faces.component.UIInput.validate(UIInput.java:976)
      	at javax.faces.component.UIInput.executeValidate(UIInput.java:1249)
      	at javax.faces.component.UIInput.processValidators(UIInput.java:712)
      	at javax.faces.component.UIForm.processValidators(UIForm.java:253)
      	at javax.faces.component.UIComponentBase.processValidators(UIComponentBase.java:1261)
      	at javax.faces.component.UIComponentBase.processValidators(UIComponentBase.java:1261)
      	at javax.faces.component.UIViewRoot.processValidators(UIViewRoot.java:1195)
      	at com.sun.faces.lifecycle.ProcessValidationsPhase.execute(ProcessValidationsPhase.java:76)
      	at com.sun.faces.lifecycle.Phase.doPhase(Phase.java:101)
      	at com.sun.faces.lifecycle.LifecycleImpl.execute(LifecycleImpl.java:198)
      	at javax.faces.webapp.FacesServlet.service(FacesServlet.java:646)
      	at org.apache.catalina.core.StandardWrapper.service(StandardWrapper.java:1682)
      	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:344)
      	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:214)
      	at org.glassfish.tyrus.servlet.TyrusServletFilter.doFilter(TyrusServletFilter.java:253)
      	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:256)
      	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:214)
      	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:316)
      	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:160)
      	at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:734)
      	at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:673)
      	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:174)
      	at org.apache.catalina.connector.CoyoteAdapter.doService(CoyoteAdapter.java:357)
      	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:260)
      	at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:188)
      	at org.glassfish.grizzly.http.server.HttpHandler.runService(HttpHandler.java:191)
      	at org.glassfish.grizzly.http.server.HttpHandler.doHandle(HttpHandler.java:168)
      	at org.glassfish.grizzly.http.server.HttpServerFilter.handleRead(HttpServerFilter.java:189)
      	at org.glassfish.grizzly.filterchain.ExecutorResolver$9.execute(ExecutorResolver.java:119)
      	at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeFilter(DefaultFilterChain.java:288)
      	at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeChainPart(DefaultFilterChain.java:206)
      	at org.glassfish.grizzly.filterchain.DefaultFilterChain.execute(DefaultFilterChain.java:136)
      	at org.glassfish.grizzly.filterchain.DefaultFilterChain.process(DefaultFilterChain.java:114)
      	at org.glassfish.grizzly.ProcessorExecutor.execute(ProcessorExecutor.java:77)
      	at org.glassfish.grizzly.nio.transport.TCPNIOTransport.fireIOEvent(TCPNIOTransport.java:838)
      	at org.glassfish.grizzly.strategies.AbstractIOStrategy.fireIOEvent(AbstractIOStrategy.java:113)
      	at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.run0(WorkerThreadIOStrategy.java:115)
      	at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.access$100(WorkerThreadIOStrategy.java:55)
      	at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy$WorkerThreadRunnable.run(WorkerThreadIOStrategy.java:135)
      	at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:564)
      	at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.run(AbstractThreadPool.java:544)
      	at java.lang.Thread.run(Thread.java:722)
      Caused by: javax.el.PropertyNotFoundException: Target Unreachable, identifier 'sendPointsBean' resolved to null
      	at com.sun.el.parser.AstValue.getTarget(AstValue.java:174)
      	at com.sun.el.parser.AstValue.getType(AstValue.java:86)
      	at com.sun.el.ValueExpressionImpl.getType(ValueExpressionImpl.java:201)
      	at com.sun.faces.facelets.el.TagValueExpression.getType(TagValueExpression.java:98)
      	... 44 more
      

        Activity

        jjsnyder83 added a comment -

        Please provide an application with source code that illustrates the problem.

        jjsnyder83 added a comment -

        Please attach an application (ear/war) with source code so that we can try to reproduce the problem.


          People

          • Assignee:
            jjsnyder83
            Reporter:
            Bruno Borges
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: