glassfish
  1. glassfish
  2. GLASSFISH-20604

Intermittent error on a clustered instance: Unable to perform operation: resolve on com.sun.enterprise.web.WebContainer

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: 4.1
    • Component/s: hk2
    • Labels:
      None

      Description

      gf-ejb-timer-cluster-devtest fails at random points every other day with an exception that includes the following stack:

      MultiException stack 3 of 3
      java.lang.IllegalStateException: Unable to perform operation: resolve on com.sun.enterprise.web.WebContainer
      at org.jvnet.hk2.internal.ClazzCreator.create(ClazzCreator.java:340)
      at org.jvnet.hk2.internal.SystemDescriptor.create(SystemDescriptor.java:448)
      at org.jvnet.hk2.internal.SingletonContext.findOrCreate(SingletonContext.java:118)
      at org.jvnet.hk2.internal.Utilities.createService(Utilities.java:2204)
      at org.jvnet.hk2.internal.ServiceHandleImpl.getService(ServiceHandleImpl.java:93)
      at org.glassfish.internal.data.EngineInfo.getContainer(EngineInfo.java:86)
      at org.glassfish.kernel.javaee.WebContainerStarter.startWebContainer(WebContainerStarter.java:241)
      at org.glassfish.kernel.javaee.WebContainerStarter.postConstruct(WebContainerStarter.java:180)
      at org.jvnet.hk2.internal.ClazzCreator.postConstructMe(ClazzCreator.java:281)
      at org.jvnet.hk2.internal.ClazzCreator.create(ClazzCreator.java:328)
      at org.jvnet.hk2.internal.SystemDescriptor.create(SystemDescriptor.java:448)
      at org.glassfish.hk2.runlevel.internal.AsyncRunLevelContext.findOrCreate(AsyncRunLevelContext.java:180)
      at org.jvnet.hk2.internal.Utilities.createService(Utilities.java:2204)
      at org.jvnet.hk2.internal.ServiceHandleImpl.getService(ServiceHandleImpl.java:93)
      at org.glassfish.hk2.runlevel.internal.CurrentTaskFuture$QueueRunner.oneJob(CurrentTaskFuture.java:752)
      at org.glassfish.hk2.runlevel.internal.CurrentTaskFuture$QueueRunner.run(CurrentTaskFuture.java:737)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
      at java.lang.Thread.run(Thread.java:722)

        Issue Links

          Activity

          jwells added a comment -

          Duplicate of GLASSFISH-20617 which was fixed with hk2 2.2.0-b05

          marina vatkina added a comment -

          Tests failures are more often now. http://hudson-sca.us.oracle.com/job/gf-transaction-cluster-devtest/867/ failed for the same reason.


            People

            • Assignee:
              jwells
              Reporter:
              marina vatkina
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: