glassfish
  1. glassfish
  2. GLASSFISH-20654

EJB + JAX-RS don't work on the simplest example

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: 4.0_b89_RC5
    • Fix Version/s: None
    • Component/s: ejb_container
    • Labels:
      None

      Description

      /*
       * To change this template, choose Tools | Templates
       * and open the template in the editor.
       */
      package pcrl.model.services;
      
      import javax.annotation.ManagedBean;
      import javax.ejb.Stateless;
      import javax.enterprise.context.RequestScoped;
      import pcrl.model.entities.RepairLocation;
      import javax.persistence.EntityManager;
      import javax.persistence.PersistenceContext;
      import javax.persistence.PersistenceUnit;
      import javax.transaction.Transactional;
      import javax.ws.rs.BeanParam;
      import javax.ws.rs.POST;
      import javax.ws.rs.Path;
      
      
      /**
       *
       * @author walec51
       */
      @Stateless
      @Path("/api/RepairLocationRepository")
      public class RepairLocationRepository {
          
          @PersistenceContext
          private EntityManager em;
          
          @POST
          @Path("add")
          public void add(@BeanParam RepairLocation rl) {
              em.persist(rl);
          }
      }
      
      
      SEVERE:   WebModule[/PcRepairLocations]Exception starting filter pcrl.PcrlApplication
      java.lang.InstantiationException
      	at org.apache.catalina.core.ApplicationFilterConfig.<init>(ApplicationFilterConfig.java:135)
      	at org.apache.catalina.core.StandardContext.filterStart(StandardContext.java:5297)
      	at org.apache.catalina.core.StandardContext.start(StandardContext.java:5909)
      	at com.sun.enterprise.web.WebModule.start(WebModule.java:691)
      	at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:1041)
      	at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:1024)
      	at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:747)
      	at com.sun.enterprise.web.WebContainer.loadWebModule(WebContainer.java:2278)
      	at com.sun.enterprise.web.WebContainer.loadWebModule(WebContainer.java:1924)
      	at com.sun.enterprise.web.WebApplication.start(WebApplication.java:139)
      	at org.glassfish.internal.data.EngineRef.start(EngineRef.java:122)
      	at org.glassfish.internal.data.ModuleInfo.start(ModuleInfo.java:291)
      	at org.glassfish.internal.data.ApplicationInfo.start(ApplicationInfo.java:352)
      	at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:497)
      	at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:219)
      	at org.glassfish.deployment.admin.DeployCommand.execute(DeployCommand.java:491)
      	at com.sun.enterprise.v3.admin.CommandRunnerImpl$2.execute(CommandRunnerImpl.java:537)
      	at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:546)
      	at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:1423)
      	at com.sun.enterprise.v3.admin.CommandRunnerImpl.access$1500(CommandRunnerImpl.java:108)
      	at com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java:1762)
      	at com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java:1674)
      	at org.glassfish.deployment.admin.ReDeployCommand.execute(ReDeployCommand.java:131)
      	at com.sun.enterprise.v3.admin.CommandRunnerImpl$2$1.run(CommandRunnerImpl.java:527)
      	at com.sun.enterprise.v3.admin.CommandRunnerImpl$2$1.run(CommandRunnerImpl.java:523)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at javax.security.auth.Subject.doAs(Subject.java:356)
      	at com.sun.enterprise.v3.admin.CommandRunnerImpl$2.execute(CommandRunnerImpl.java:522)
      	at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:546)
      	at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:1423)
      	at com.sun.enterprise.v3.admin.CommandRunnerImpl.access$1500(CommandRunnerImpl.java:108)
      	at com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java:1762)
      	at com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java:1674)
      	at com.sun.enterprise.v3.admin.AdminAdapter.doCommand(AdminAdapter.java:534)
      	at com.sun.enterprise.v3.admin.AdminAdapter.onMissingResource(AdminAdapter.java:224)
      	at org.glassfish.grizzly.http.server.StaticHttpHandler.service(StaticHttpHandler.java:297)
      	at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:246)
      	at org.glassfish.grizzly.http.server.HttpHandler.runService(HttpHandler.java:191)
      	at org.glassfish.grizzly.http.server.HttpHandler.doHandle(HttpHandler.java:168)
      	at org.glassfish.grizzly.http.server.HttpServerFilter.handleRead(HttpServerFilter.java:189)
      	at org.glassfish.grizzly.filterchain.ExecutorResolver$9.execute(ExecutorResolver.java:119)
      	at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeFilter(DefaultFilterChain.java:288)
      	at org.glassfish.grizzly.filterchain.DefaultFilterChain.executeChainPart(DefaultFilterChain.java:206)
      	at org.glassfish.grizzly.filterchain.DefaultFilterChain.execute(DefaultFilterChain.java:136)
      	at org.glassfish.grizzly.filterchain.DefaultFilterChain.process(DefaultFilterChain.java:114)
      	at org.glassfish.grizzly.ProcessorExecutor.execute(ProcessorExecutor.java:77)
      	at org.glassfish.grizzly.nio.transport.TCPNIOTransport.fireIOEvent(TCPNIOTransport.java:838)
      	at org.glassfish.grizzly.strategies.AbstractIOStrategy.fireIOEvent(AbstractIOStrategy.java:113)
      	at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.run0(WorkerThreadIOStrategy.java:115)
      	at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy.access$100(WorkerThreadIOStrategy.java:55)
      	at org.glassfish.grizzly.strategies.WorkerThreadIOStrategy$WorkerThreadRunnable.run(WorkerThreadIOStrategy.java:135)
      	at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:564)
      	at org.glassfish.grizzly.threadpool.AbstractThreadPool$Worker.run(AbstractThreadPool.java:544)
      	at java.lang.Thread.run(Thread.java:722)
      Caused by: java.lang.IllegalStateException: Error when configuring to use the EJB interceptor binding API. JAX-RS EJB integration can not be supported.
      	at org.glassfish.jersey.gf.ejb.EjbComponentProvider.registerEjbInterceptor(EjbComponentProvider.java:168)
      	at org.glassfish.jersey.gf.ejb.EjbComponentProvider.bind(EjbComponentProvider.java:200)
      	at org.glassfish.jersey.server.ApplicationHandler.bindWithComponentProvider(ApplicationHandler.java:809)
      	at org.glassfish.jersey.server.ApplicationHandler.bindProvidersAndResources(ApplicationHandler.java:741)
      	at org.glassfish.jersey.server.ApplicationHandler.initialize(ApplicationHandler.java:388)
      	at org.glassfish.jersey.server.ApplicationHandler.access$500(ApplicationHandler.java:157)
      	at org.glassfish.jersey.server.ApplicationHandler$3.run(ApplicationHandler.java:280)
      	at org.glassfish.jersey.internal.Errors$2.call(Errors.java:289)
      	at org.glassfish.jersey.internal.Errors$2.call(Errors.java:286)
      	at org.glassfish.jersey.internal.Errors.process(Errors.java:315)
      	at org.glassfish.jersey.internal.Errors.process(Errors.java:297)
      	at org.glassfish.jersey.internal.Errors.processWithException(Errors.java:286)
      	at org.glassfish.jersey.server.ApplicationHandler.<init>(ApplicationHandler.java:277)
      	at org.glassfish.jersey.servlet.WebComponent.<init>(WebComponent.java:262)
      	at org.glassfish.jersey.servlet.ServletContainer.init(ServletContainer.java:167)
      	at org.glassfish.jersey.servlet.ServletContainer.init(ServletContainer.java:379)
      	at org.apache.catalina.core.ApplicationFilterConfig.getFilter(ApplicationFilterConfig.java:275)
      	at org.apache.catalina.core.ApplicationFilterConfig.<init>(ApplicationFilterConfig.java:131)
      	... 53 more
      Caused by: java.lang.reflect.InvocationTargetException
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:601)
      	at org.glassfish.jersey.gf.ejb.EjbComponentProvider.registerEjbInterceptor(EjbComponentProvider.java:163)
      	... 70 more
      Caused by: java.lang.NullPointerException
      	at com.sun.ejb.containers.InternalInterceptorBindingImpl.registerInterceptor(InternalInterceptorBindingImpl.java:97)
      	... 75 more
      

        Activity

        walec51 added a comment -

        after restarting the server this stopen happening and it worked

        marina vatkina added a comment -

        The NPE might be caused by an inconsistent state. We would need a test case/scenario to understand the cause.


          People

          • Assignee:
            marina vatkina
            Reporter:
            walec51
          • Votes:
            1 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: