glassfish
  1. glassfish
  2. GLASSFISH-2080

Build 31 WebStart fails horribly; admin GUI can't launch webstart clients; misspelled JMX operation to blame

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Duplicate
    • Affects Version/s: 9.1pe
    • Fix Version/s: 9.1pe
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      2,080

      Description

      (I'm not sure what subcomponent is responsible--it actually looks like something
      in the MBean infrastructure is ultimately responsible.)

      Take a JEE-compliant .ear with an application client component inside it.

      Deploy it normally using the admin GUI; make sure that webstart is enabled.

      Click on the "Launch" link.

      You get the following stack (stand back). Something somewhere is looking for a
      JMX operation called "listReferencees" [sic] complete with the extra "e". No
      such operation exists:

      [#|2007-01-17T09:57:57.093-0500|WARNING|sun-appserver9.1|javax.enterprise.resource.webcontainer.jsf.lifecycle|_ThreadID=12;_ThreadName=httpWorkerThread-4848-0;_RequestID=00f17569-4d18-4821-a814-f7e70fd17c2f;|executePhase(RESTORE_VIEW
      1,com.sun.faces.context.FacesContextImpl@1eb3926) threw exception

      java.lang.RuntimeException: java.lang.reflect.InvocationTargetException while
      attempting to process a 'beforeCreate' event for 'linksCluster'.

      at
      com.sun.jsftemplating.layout.descriptors.LayoutElementBase.dispatchHandlers(LayoutElementBase.java:344)

      at
      com.sun.jsftemplating.layout.descriptors.LayoutElementBase.dispatchHandlers(LayoutElementBase.java:316)

      at
      com.sun.jsftemplating.layout.descriptors.LayoutComponent.beforeCreate(LayoutComponent.java:331)

      at
      com.sun.jsftemplating.layout.descriptors.LayoutComponent.getChild(LayoutComponent.java:270)

      at
      com.sun.jsftemplating.layout.LayoutViewHandler.buildUIComponentTree(LayoutViewHandler.java:345)

      at
      com.sun.jsftemplating.layout.LayoutViewHandler.buildUIComponentTree(LayoutViewHandler.java:360)

      at
      com.sun.jsftemplating.layout.LayoutViewHandler.buildUIComponentTree(LayoutViewHandler.java:360)

      at
      com.sun.jsftemplating.layout.LayoutViewHandler.buildUIComponentTree(LayoutViewHandler.java:360)

      at
      com.sun.jsftemplating.layout.LayoutViewHandler.buildUIComponentTree(LayoutViewHandler.java:360)

      at
      com.sun.jsftemplating.layout.LayoutViewHandler.buildUIComponentTree(LayoutViewHandler.java:360)

      at
      com.sun.jsftemplating.layout.LayoutViewHandler.buildUIComponentTree(LayoutViewHandler.java:360)

      at
      com.sun.jsftemplating.layout.LayoutViewHandler.buildUIComponentTree(LayoutViewHandler.java:360)

      at
      com.sun.jsftemplating.layout.LayoutViewHandler.buildUIComponentTree(LayoutViewHandler.java:360)

      at
      com.sun.jsftemplating.layout.LayoutViewHandler.createView(LayoutViewHandler.java:177)

      at com.sun.faces.lifecycle.RestoreViewPhase.execute(RestoreViewPhase.java:196)

      at com.sun.faces.lifecycle.LifecycleImpl.phase(LifecycleImpl.java:248)

      at com.sun.faces.lifecycle.LifecycleImpl.execute(LifecycleImpl.java:117)

      at
      com.sun.faces.extensions.avatar.lifecycle.PartialTraversalLifecycle.execute(PartialTraversalLifecycle.java:79)

      at javax.faces.webapp.FacesServlet.service(FacesServlet.java:244)

      at
      org.apache.catalina.core.ApplicationFilterChain.servletService(ApplicationFilterChain.java:398)

      at
      org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:304)

      at
      org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:185)

      at com.sun.webui.jsf.util.UploadFilter.doFilter(UploadFilter.java:203)

      at
      org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:217)

      at
      org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:185)

      at
      org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:275)

      at
      org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:255)

      at
      org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:188)

      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:586)

      at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:73)

      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:186)

      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:586)

      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:556)

      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1067)

      at
      org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:137)

      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:586)

      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:556)

      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1067)

      at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:252)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.invokeAdapter(DefaultProcessorTask.java:618)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.doProcess(DefaultProcessorTask.java:549)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.process(DefaultProcessorTask.java:790)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.executeProcessorTask(DefaultReadTask.java:326)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:248)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:199)

      at com.sun.enterprise.web.connector.grizzly.TaskBase.run(TaskBase.java:252)

      at
      com.sun.enterprise.web.connector.grizzly.WorkerThreadImpl.run(WorkerThreadImpl.java:103)

      Caused by: java.lang.reflect.InvocationTargetException

      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

      at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

      at java.lang.reflect.Method.invoke(Method.java:585)

      at
      com.sun.jsftemplating.layout.descriptors.handler.Handler.invoke(Handler.java:421)

      at
      com.sun.jsftemplating.layout.descriptors.LayoutElementBase.dispatchHandlers(LayoutElementBase.java:342)

      ... 46 more

      Caused by: java.lang.RuntimeException:
      javax.management.ServiceNotFoundException: This operation failed, because it
      could not be handled by this domain.
      An example of such an operation is creating application server instances or
      clusters when they are not supported by the given domain.
      The actual error is: Operation :listReferencees is not found in applications MBean.

      at com.sun.enterprise.tools.admingui.util.JMXUtil.invoke(JMXUtil.java:104)

      at com.sun.enterprise.tools.admingui.util.JMXUtil.invoke(JMXUtil.java:58)

      at
      com.sun.enterprise.tools.admingui.handlers.ApplicationHandlers.getWebAppReferencees(ApplicationHandlers.java:1555)

      at
      com.sun.enterprise.tools.admingui.handlers.ApplicationHandlers.getAppClientLinks(ApplicationHandlers.java:1276)

      ... 52 more

      Caused by: javax.management.ServiceNotFoundException: This operation failed,
      because it could not be handled by this domain.
      An example of such an operation is creating application server instances or
      clusters when they are not supported by the given domain.
      The actual error is: Operation :listReferencees is not found in applications MBean.

      at com.sun.enterprise.admin.config.BaseConfigMBean.invoke(BaseConfigMBean.java:439)

      at com.sun.jmx.mbeanserver.DynamicMetaDataImpl.invoke(DynamicMetaDataImpl.java:213)

      at com.sun.jmx.mbeanserver.MetaDataImpl.invoke(MetaDataImpl.java:220)

      at
      com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.invoke(DefaultMBeanServerInterceptor.java:815)

      at com.sun.jmx.mbeanserver.JmxMBeanServer.invoke(JmxMBeanServer.java:784)

      at sun.reflect.GeneratedMethodAccessor23.invoke(Unknown Source)

      at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

      at java.lang.reflect.Method.invoke(Method.java:585)

      at com.sun.enterprise.admin.util.proxy.ProxyClass.invoke(ProxyClass.java:77)

      at $Proxy1.invoke(Unknown Source)

      at
      com.sun.enterprise.admin.server.core.jmx.SunoneInterceptor.invoke(SunoneInterceptor.java:297)

      at com.sun.enterprise.tools.admingui.util.JMXUtil.invoke(JMXUtil.java:101)

      ... 55 more

      #]

      [#|2007-01-17T09:57:57.093-0500|SEVERE|sun-appserver9.1|javax.enterprise.system.container.web|_ThreadID=12;_ThreadName=httpWorkerThread-4848-0;_RequestID=00f17569-4d18-4821-a814-f7e70fd17c2f;|StandardWrapperValve[FacesServlet]:
      PWC1406: Servlet.service() for servlet FacesServlet threw exception

      javax.management.ServiceNotFoundException: This operation failed, because it
      could not be handled by this domain.
      An example of such an operation is creating application server instances or
      clusters when they are not supported by the given domain.
      The actual error is: Operation :listReferencees is not found in applications MBean.

      at com.sun.enterprise.admin.config.BaseConfigMBean.invoke(BaseConfigMBean.java:439)

      at com.sun.jmx.mbeanserver.DynamicMetaDataImpl.invoke(DynamicMetaDataImpl.java:213)

      at com.sun.jmx.mbeanserver.MetaDataImpl.invoke(MetaDataImpl.java:220)

      at
      com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.invoke(DefaultMBeanServerInterceptor.java:815)

      at com.sun.jmx.mbeanserver.JmxMBeanServer.invoke(JmxMBeanServer.java:784)

      at sun.reflect.GeneratedMethodAccessor23.invoke(Unknown Source)

      at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

      at java.lang.reflect.Method.invoke(Method.java:585)

      at com.sun.enterprise.admin.util.proxy.ProxyClass.invoke(ProxyClass.java:77)

      at $Proxy1.invoke(Unknown Source)

      at
      com.sun.enterprise.admin.server.core.jmx.SunoneInterceptor.invoke(SunoneInterceptor.java:297)

      at com.sun.enterprise.tools.admingui.util.JMXUtil.invoke(JMXUtil.java:101)

      at com.sun.enterprise.tools.admingui.util.JMXUtil.invoke(JMXUtil.java:58)

      at
      com.sun.enterprise.tools.admingui.handlers.ApplicationHandlers.getWebAppReferencees(ApplicationHandlers.java:1555)

      at
      com.sun.enterprise.tools.admingui.handlers.ApplicationHandlers.getAppClientLinks(ApplicationHandlers.java:1276)

      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

      at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

      at java.lang.reflect.Method.invoke(Method.java:585)

      at
      com.sun.jsftemplating.layout.descriptors.handler.Handler.invoke(Handler.java:421)

      at
      com.sun.jsftemplating.layout.descriptors.LayoutElementBase.dispatchHandlers(LayoutElementBase.java:342)

      at
      com.sun.jsftemplating.layout.descriptors.LayoutElementBase.dispatchHandlers(LayoutElementBase.java:316)

      at
      com.sun.jsftemplating.layout.descriptors.LayoutComponent.beforeCreate(LayoutComponent.java:331)

      at
      com.sun.jsftemplating.layout.descriptors.LayoutComponent.getChild(LayoutComponent.java:270)

      at
      com.sun.jsftemplating.layout.LayoutViewHandler.buildUIComponentTree(LayoutViewHandler.java:345)

      at
      com.sun.jsftemplating.layout.LayoutViewHandler.buildUIComponentTree(LayoutViewHandler.java:360)

      at
      com.sun.jsftemplating.layout.LayoutViewHandler.buildUIComponentTree(LayoutViewHandler.java:360)

      at
      com.sun.jsftemplating.layout.LayoutViewHandler.buildUIComponentTree(LayoutViewHandler.java:360)

      at
      com.sun.jsftemplating.layout.LayoutViewHandler.buildUIComponentTree(LayoutViewHandler.java:360)

      at
      com.sun.jsftemplating.layout.LayoutViewHandler.buildUIComponentTree(LayoutViewHandler.java:360)

      at
      com.sun.jsftemplating.layout.LayoutViewHandler.buildUIComponentTree(LayoutViewHandler.java:360)

      at
      com.sun.jsftemplating.layout.LayoutViewHandler.buildUIComponentTree(LayoutViewHandler.java:360)

      at
      com.sun.jsftemplating.layout.LayoutViewHandler.buildUIComponentTree(LayoutViewHandler.java:360)

      at
      com.sun.jsftemplating.layout.LayoutViewHandler.createView(LayoutViewHandler.java:177)

      at com.sun.faces.lifecycle.RestoreViewPhase.execute(RestoreViewPhase.java:196)

      at com.sun.faces.lifecycle.LifecycleImpl.phase(LifecycleImpl.java:248)

      at com.sun.faces.lifecycle.LifecycleImpl.execute(LifecycleImpl.java:117)

      at
      com.sun.faces.extensions.avatar.lifecycle.PartialTraversalLifecycle.execute(PartialTraversalLifecycle.java:79)

      at javax.faces.webapp.FacesServlet.service(FacesServlet.java:244)

      at
      org.apache.catalina.core.ApplicationFilterChain.servletService(ApplicationFilterChain.java:398)

      at
      org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:304)

      at
      org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:185)

      at com.sun.webui.jsf.util.UploadFilter.doFilter(UploadFilter.java:203)

      at
      org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:217)

      at
      org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:185)

      at
      org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:275)

      at
      org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:255)

      at
      org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:188)

      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:586)

      at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:73)

      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:186)

      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:586)

      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:556)

      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1067)

      at
      org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:137)

      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:586)

      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:556)

      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1067)

      at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:252)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.invokeAdapter(DefaultProcessorTask.java:618)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.doProcess(DefaultProcessorTask.java:549)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.process(DefaultProcessorTask.java:790)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.executeProcessorTask(DefaultReadTask.java:326)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:248)

      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:199)

      at com.sun.enterprise.web.connector.grizzly.TaskBase.run(TaskBase.java:252)

      at
      com.sun.enterprise.web.connector.grizzly.WorkerThreadImpl.run(WorkerThreadImpl.java:103)

      #]

        Activity

        ljnelson added a comment -

        The problem is in
        glassfish/admin-gui/admin-jsf/src/java/com/sun/enterprise/tools/admingui/handlers/ApplicationHandlers.java,
        line 1557. Change "listReferencees" to "listReferences" and I bet you'll be all
        set.

        Anissa Lam added a comment -

        This is duplicate of #1970.
        The issue has been resolved, build 32 will have the fix.

            • This issue has been marked as a duplicate of 1970 ***

          People

          • Assignee:
            Anissa Lam
            Reporter:
            ljnelson
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: