glassfish
  1. glassfish
  2. GLASSFISH-20875

SSL Failure When Accessing GlassFish 4 b89 Remotely

    Details

    • Type: Bug Bug
    • Status: Open
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: 4.0_b89_RC5
    • Fix Version/s: None
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      JDK 1.7.0_40
      RHEL 5.8
      FireFox 17.0.9ESR

      Description

      Attempting to connect remotely to GlassFish 4 secure admin interface fails. This issue was supposed to be fixed in this bug: https://java.net/jira/browse/GLASSFISH-17844 and I didn't have this problem in GlassFish 3.1.2.2.

      In my instance, I have http2 disabled:

      .network-listener.http-listener-2.enabled=false

      Removed weak ciphers:

      network-config.protocols.protocol.sec-admin-listener.ssl.ssl3-tls-ciphers="+SS_RSA_WITH_RC4_128_MD5,+SSL_RSA_WITH_RC4_128_SHA,+TLS_RSA_WITH_AES_128_CBC_SHA,+TLS+DHE_RSA_WITH_AES_128_CBC_SHA,+TLS_DHE_DSS_WITH_AES_128_CBC_SHA"

      Admin port is 4848.

      http port is 8080.

      I am running the patch here: https://java.net/jira/browse/GLASSFISH-20681

      But I have the problem regardless.

        Activity

        Hide
        bw22942 added a comment - - edited

        A blank screen results (the URL reflects the j_security_check destination).

        When I execute:

        asadmin get server-config.security-service.audit-module.default.*

        it returns

        classname=com.sun.enterprise.security.Audit
        default.name=default
        default.property.auditOn=false

        However in the server.log, it states:

        "Cannot load AuditModule = default"

        Show
        bw22942 added a comment - - edited A blank screen results (the URL reflects the j_security_check destination). When I execute: asadmin get server-config.security-service.audit-module.default.* it returns classname=com.sun.enterprise.security.Audit default.name=default default.property.auditOn=false However in the server.log, it states: "Cannot load AuditModule = default"
        Hide
        Anissa Lam added a comment -

        To access admin console remotely, you need to turn on Secure Admin. Have you done that ?

        Show
        Anissa Lam added a comment - To access admin console remotely, you need to turn on Secure Admin. Have you done that ?
        Hide
        bw22942 added a comment -

        Hmm, odd had to do enable-secure-admin twice.

        Show
        bw22942 added a comment - Hmm, odd had to do enable-secure-admin twice.

          People

          • Assignee:
            Anissa Lam
            Reporter:
            bw22942
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated: