glassfish
  1. glassfish
  2. GLASSFISH-21027

Cannot deploy on GF 4.0.1 (nightly latest) but can deploy on GF 4.0 and GF 3.1.1

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 4.1
    • Fix Version/s: None
    • Component/s: cdi
    • Labels:
      None
    • Environment:

      4.0.1 (nightly latest), JDK 1.8.0 (32 Bit), Win 7 Pro SP1 (64 Bit)

      Description

      My rather complex EAR deploys without any problem on GF 4.0 and GF 3.1.1 but not at all on GF 4.0.1!

      I am getting the following error message:

      remote failure: Fehler beim Deployment: Exception while loading the app : java.lang.IllegalStateException: ContainerBase.addChild: start: org.apache.catalina.Li
      fecycleException: com.google.common.util.concurrent.UncheckedExecutionException: org.jboss.weld.exceptions.IllegalStateException: WELD-001328 Unable to identify
       the correct BeanManager. The calling class org.jboss.weld.servlet.WeldInitialListener is not placed in bean archive. Weitere Informationen finden Sie unter server.log.
      Command deploy failed.
      

      (Also see attched server.log for more information!)

      The strange thing is that I am not using neither CDI in common nor WELD in particular at all! The EAR is completely CDI free, moreover it actively switches CDI completely OFF thanks to bean-discovery-mode="none" in beans.xml!

      This is a blocker for us as we cannot deploy anymore!

      EAR file is closed source and must not get published in JIRA, so if you need it to reproduce, please provide an email address where we can send the file to.

        Activity

        mkarg added a comment -

        J. j. please see my eMail sent to j.j.snyder@oracle.com - it provides instructions how to obtain the EAR.

        jjsnyder83 added a comment -

        Fixed with Committed revision 63454.

        jjsnyder83 added a comment -

        We were not taking into account the bean-discovery-mode attribute of beans in beans.xml when checking for implicit archives.

        mkarg added a comment -

        I hereby confirm that with GF-nightly of July 22 the problem is gone and we can deploy the same EAR again! Thanks, JJ!

        jjsnyder83 added a comment -

        Excellent. Thanks for your patience Markus.


          People

          • Assignee:
            phil.zampino
            Reporter:
            mkarg
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: