glassfish
  1. glassfish
  2. GLASSFISH-21077

EJB injection works only for first ejbModule in ear if the beans.xml is not provided

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 4.0, 4.1_b07
    • Fix Version/s: None
    • Component/s: cdi, ejb_container
    • Labels:
      None
    • Status Whiteboard:

      EJB injection works only in first ejbModule in ear if the beans.xml not provided.

      Show
      EJB injection works only in first ejbModule in ear if the beans.xml not provided.

      Description

      I am migrating application from SGES2.1.1 with JDK6 to Glassfish4 with JDK8.

      If I deploy EAR application with two or more EJB modules without beans.xml file, only in the first ejbModule injection works (@EJB and @Stateless annotations).

      If I add beans.xml file to ejbModules, injection works in all of them.
      I think this is a minor issue because this simple workaround exists, but this behavior is still incorrect.

        Activity

        jjsnyder83 added a comment -

        Can you attach a reproducible test case.


          People

          • Assignee:
            jjsnyder83
            Reporter:
            dmatej
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 2 hours
              2h
              Remaining:
              Remaining Estimate - 2 hours
              2h
              Logged:
              Time Spent - Not Specified
              Not Specified